Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem ze SQL


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
14 odpowiedzi w tym temacie

#1 Karmi1

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:61
  • Lokalizacja:Gdańsk
Offline

Napisano 06.10.2011 17:47

Witam, mam następujący problem. Otóż mam serwer Diablo Mod zedytowany przeze mnie. Wszystko ładnie działa, /klasa jest, /questy są i wydaje się że jest dobrze. Niestety czasami dochodzi do Crashów serwera. Postanowiłem spojrzeć w logi. Nie ma logów Error. Myślę sobie : Sprawdzę diablo.log. Patrzę a tam następujące logi :


L 10/03/2011 - 06:39:51: 10/03/2011 - 06:39:51 ### MAPA: cs_max ###
L 10/03/2011 - 06:58:57: 10/03/2011 - 06:58:57 ### MAPA: cs_militia ###
L 10/03/2011 - 07:18:03: 10/03/2011 - 07:18:03 ### MAPA: de_dust2 ###
L 10/03/2011 - 07:37:09: 10/03/2011 - 07:37:09 ### MAPA: de_dust2002 ###
L 10/03/2011 - 07:56:16: 10/03/2011 - 07:56:16 ### MAPA: de_dust4ever ###
L 10/03/2011 - 08:15:22: 10/03/2011 - 08:15:22 ### MAPA: de_eldorado ###
L 10/03/2011 - 08:36:12: 10/03/2011 - 08:36:12 ### MAPA: de_dust2 ###
L 10/03/2011 - 08:36:14: Error on Table query: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
L 10/03/2011 - 08:36:14: Could not connect to SQL database.
L 10/03/2011 - 08:55:21: 10/03/2011 - 08:55:21 ### MAPA: de_dust2002 ###
L 10/03/2011 - 09:14:27: 10/03/2011 - 09:14:27 ### MAPA: de_dust4ever ###
L 10/03/2011 - 09:33:33: 10/03/2011 - 09:33:33 ### MAPA: de_eldorado ###
L 10/03/2011 - 09:52:39: 10/03/2011 - 09:52:39 ### MAPA: de_inferno ###
L 10/03/2011 - 10:11:45: 10/03/2011 - 10:11:45 ### MAPA: de_kabul ###
L 10/03/2011 - 10:30:51: 10/03/2011 - 10:30:51 ### MAPA: de_nuke ###
L 10/03/2011 - 10:49:57: 10/03/2011 - 10:49:57 ### MAPA: de_piranesi ###
L 10/03/2011 - 11:09:03: 10/03/2011 - 11:09:03 ### MAPA: de_rats_1337 ###

Jak widać o 8:36 nastąpił crash. Zawsze po crashu występuje ten log. Czy może to być błąd w .sma? Czy może coś źle z MySQL robię. Powtarzam że /klasa działa.
  • +
  • -
  • 0

#2 glut

    Godlike

  • Przyjaciel

Reputacja: 931
Master

  • Postów:2073
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Namysłów
Offline

Napisano 06.10.2011 19:25

podaj sql.cfg
  • +
  • -
  • 0

Nie pomagam za darmo na PW/GG/Steam od tego jest forum

 

TP Game + RR

 

Znak rozpoznawczy :coto:


#3 Karmi1

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:61
  • Lokalizacja:Gdańsk
Offline

Napisano 06.10.2011 20:44

Szczerze nie wiem po co sql.cfg skoro cvary Diablo są w amxx.pl

SQL.CFG


amx_sql_host "178.33.55.111"
amx_sql_user "sql_ts4534"
amx_sql_pass "xxx
amx_sql_db "sql_ts4534"
amx_sql_table "amxbans"
amx_sql_type "mysql"


AMXX.CFG


diablo_sql_host "178.33.55.111"
diablo_sql_user "sql_ts4534"
diablo_sql_pass "XXX"
diablo_sql_database "sql_ts4534"
diablo_sql_table "dbmod_"
diablo_sql_save "0"

diablo_classes "abcdefghi"
diablo_avg "0"
diablo_xpbonus "5"
diablo_xpbonus2 "20"
diablo_xpbonus3 "30"
diablo_durability "5"
SaveXP "1"
diablo_saveitems "0"
diablo_dir "addons/amxmodx/diablo/"
diablo_show_health "1"
diablo_knife "20"
diablo_knife_speed "1000"
diablo_arrow "120"
diablo_arrow_multi "2.0"
diablo_arrow_speed "1500"
diablo_klass_delay "2.5"
diablo_dmg_exp "20"
diablo_spawnchance "0"


MODULES.INI



;;;
; To enable a module, remove the semi-colon ( ;) in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time. Use ;;
;; amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

mysql
; sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here. ;;
;; You can just list their names, without the _amxx ;;
;; or file extension. ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded ;;
;; as needed. You do not need to enable them here ;;
;; unless you have problems. ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

fun
engine
fakemeta
geoip
sockets
regex
nvault
cstrike
csx


Wersja amxx to 1.8.1.

Proszę o szybką pomoc ;)

Użytkownik Karmi1 edytował ten post 06.10.2011 20:50

  • +
  • -
  • 0

#4 Koniarek

    Wszechwidzący

  • Zbanowany

Reputacja: 28
Życzliwy

  • Postów:250
  • Imię:Filip
  • Lokalizacja:Daleko
Offline

Napisano 06.10.2011 22:21

Zapraszam:

http://amxx.pl/topic...-diablo-modzie/

#5 Karmi1

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:61
  • Lokalizacja:Gdańsk
Offline

Napisano 08.10.2011 11:06

Bazę mam podłączoną dobrze, a te crashe występują nadal.
  • +
  • -
  • 0

#6 glut

    Godlike

  • Przyjaciel

Reputacja: 931
Master

  • Postów:2073
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Namysłów
Offline

Napisano 08.10.2011 11:19

nvault
odznacz to
w modules.ini
  • +
  • -
  • 0

Nie pomagam za darmo na PW/GG/Steam od tego jest forum

 

TP Game + RR

 

Znak rozpoznawczy :coto:


#7 Karmi1

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:61
  • Lokalizacja:Gdańsk
Offline

Napisano 08.10.2011 12:40

1. Jest odznaczone, chyba że Ci chodziło o "oznacz".
2. Nie mogę nvault wyłączyć ponieważ mam Questy od DarkGL z zapisem na Nvault.
  • +
  • -
  • 0

#8 glut

    Godlike

  • Przyjaciel

Reputacja: 931
Master

  • Postów:2073
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Namysłów
Offline

Napisano 08.10.2011 12:48

Aha nie wiedziałem :D

amx_sql_host "178.33.55.111"
amx_sql_user "sql_ts4534"
amx_sql_pass "xxx
amx_sql_db "sql_ts4534"
amx_sql_table "amxbans"
amx_sql_type "mysql"
 
diablo_sql_host "178.33.55.111"
diablo_sql_user "sql_ts4534"
diablo_sql_pass "XXX"
diablo_sql_database "sql_ts4534"
diablo_sql_table "dbmod_"

tak weź w sql.cfg zrób
  • +
  • -
  • 0

Nie pomagam za darmo na PW/GG/Steam od tego jest forum

 

TP Game + RR

 

Znak rozpoznawczy :coto:


#9 Karmi1

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:61
  • Lokalizacja:Gdańsk
Offline

Napisano 12.10.2011 14:04

Niestety to nie pomaga :/
  • +
  • -
  • 0

#10 glut

    Godlike

  • Przyjaciel

Reputacja: 931
Master

  • Postów:2073
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Namysłów
Offline

Napisano 12.10.2011 14:58

a gdzie masz bazę ? :D
  • +
  • -
  • 0

Nie pomagam za darmo na PW/GG/Steam od tego jest forum

 

TP Game + RR

 

Znak rozpoznawczy :coto:


#11 Karmi1

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:61
  • Lokalizacja:Gdańsk
Offline

Napisano 14.10.2011 19:59

Na Proserwer.pl, aczkolwiek kiedy miałem na Unixstormie to było to samo.

Odświeżam.
  • +
  • -
  • 0

#12 glut

    Godlike

  • Przyjaciel

Reputacja: 931
Master

  • Postów:2073
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Namysłów
Offline

Napisano 14.10.2011 20:04

zamiast

diablo_sql_host "178.33.55.111"

daj

diablo_sql_host "twojastrona.xaa.pl"

Oczywiście zamiast twojastrona daj nazwe swojej strony jezeli masz na proserwer :)
  • +
  • -
  • 0

Nie pomagam za darmo na PW/GG/Steam od tego jest forum

 

TP Game + RR

 

Znak rozpoznawczy :coto:


#13 Karmi1

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:61
  • Lokalizacja:Gdańsk
Offline

Napisano 20.10.2011 14:35

Wciąż to samo.
Może coś w .sma nie tak?
  • +
  • -
  • 0

#14 M@nkovsky

    Zaawansowany

  • Zbanowany

Reputacja: 57
Pomocny

  • Postów:110
  • GG:
  • Steam:steam
  • Imię:Mariusz
  • Lokalizacja:Poland
Offline

Napisano 20.10.2011 14:53

podeśłij sma .zobaczymy co jest nie tak. i daj logi z serwera

#15 Karmi1

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:61
  • Lokalizacja:Gdańsk
Offline

Napisano 22.10.2011 16:45

.sma nie dam bo dużo w Diablo dałem pracy. Mogę co najwyżej dać jakiś kawałek/kawałki kodu.
Logi dawałem u góry. (Error logów nie ma)

Pomoże ktoś? :D

Użytkownik Karmi1 edytował ten post 22.10.2011 16:48

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych