Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
PHP

Session_Start(); Sesja została już wysłana :oWarring Cannot send session cache limiter - headers already sent

PHP

  • Zamknięty Temat jest zamknięty
9 odpowiedzi w tym temacie

#1 Gh0st

    :)

  • Power User

Reputacja: 846
Czempion

  • Postów:920
  • GG:
  • Imię:Tomek
  • Lokalizacja:Rabka-Zdrój
Offline

Napisano 20.09.2011 08:13

Witam . :) Dziś rano z dniem 20.09.2011 wchodzę rano na kompa i zabieram się za robienie swojej strony www a tu nagle d*pa .
plików z sesją mam ~9 ale przy tym 1 wywala
Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at D:\xapp\xampp\htdocs\pokaz.php:1) inD:\xapp\xampp\htdocs\pokaz.php on line 1
  • Kodowanie mam bez BOM ( sprawdzane notepad++ )
  • Plików z session_start() jest 9 i tylko w tym jednym taki błąd się pojawia.
  • Oczywiście mogę ustawić error_reporting(0) i tego błędu już nie będzie , ale zawsze będzie świadomość że coś jest źle ;)
Proszę o pomoc ;)

Użytkownik Gh0st edytował ten post 20.09.2011 08:14

  • +
  • -
  • 0

#2 Fili:P

    Koleżeński

  • Power User

Reputacja: 752
Guru

  • Postów:1679
  • GG:
  • Steam:steam
  • Imię:Filip
  • Lokalizacja:Radom
Offline

Napisano 20.09.2011 11:57

Jeśli patrze na błąd to piszę, że sesja już wystartowała ;/
  • +
  • -
  • 0

BMXers.pl - Portal o tematyce BMX


#3 Gh0st

    :)

  • Autor tematu
  • Power User

Reputacja: 846
Czempion

  • Postów:920
  • GG:
  • Imię:Tomek
  • Lokalizacja:Rabka-Zdrój
Offline

Napisano 20.09.2011 12:00

Jak pisze że sesja już wystartowała to wcześniej została uruchomiona ... w moim przypadku to inny plik .
Ale nie powinno tak się dziać bo kodowanie mam
UTF-8 ( bez BOM )

Przetłumaczyć z angielskiego to ja też umiem ;)
  • +
  • -
  • 0

#4 G[o]Q

    I'm G[o]Q

  • Przyjaciel

Reputacja: 1339
Godlike

  • Postów:3556
  • Steam:steam
  • Imię:Krzysiek
  • Lokalizacja:C: / program Files / Valve / Cstrike / G[o]Q.dem
Offline

Napisano 20.09.2011 12:29

pewnie 2x zalaczyles plik ktory startuje sesje
  • +
  • -
  • 0
Manual ponad wszystko, konsola ponad manual :D :&

Chcesz wysłać do mnie PW ? użyj nazwy GoQ zamiast G[o]Q
Chcesz Kupić moduł płatności via Pukawka,Tserwery, Gamesol, Zabijaka do mojego sklepu? napisz PW cena to tylko 10 zł/sztuka

GG:6022845 (nie pomagam za free osobom ponizej rangi MoD) :D

#5 fdszpl0

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:69
  • Lokalizacja:Kraków
Offline

Napisano 20.09.2011 17:39

tutaj nie chodzi o przedwczesne powstanie sesji i inne teorie, poprostu nie da się fizycznie tworzyć najpierw treści strony a dopiero potem nagłówka HTTP - poczytaj o tym bo pewnie nie wiesz co to jest, najpierw buduje się nagłówek, w nim m.in są sesje a dzieje się to po stronie mniej widocznej. Nagłówkek MUSI być pierwszy nie moze byc przed nim nawet spacja. Da się to ominąć stosując bufory.

Ja ten blad mialem najczesciej jak robiłem przekierowania przesylajac naglowek "header", najlepiej pokaz pierwsze 10 linii tego pliku

Użytkownik fdszpl0 edytował ten post 20.09.2011 17:41

  • +
  • -
  • 3

#6 Gh0st

    :)

  • Autor tematu
  • Power User

Reputacja: 846
Czempion

  • Postów:920
  • GG:
  • Imię:Tomek
  • Lokalizacja:Rabka-Zdrój
Offline

Napisano 20.09.2011 17:49

Poierwsze 10:


<?php session_start();
$sesja = $_SESSION['login'];
#Include
include("./mysql/config.php");
include("./mysql/polacz_db.php");
include("./mysql/stworz_tabele_db.php");
#koniec
$gra = addslashes($_GET['gra']);

$szukaj_gre = mysql_query("SELECT * from `gry` where `identyfikator`='$gra'");



jaki ja jestem ... omg :>
fdszpl0

Masz mega + :X

u mnie to się zrobiło pewnie jak otwierałem program do edycji i nacisnołem przez przypadek spacje :D .

Użytkownik Gh0st edytował ten post 20.09.2011 17:54

  • +
  • -
  • 0

#7 fdszpl0

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:69
  • Lokalizacja:Kraków
Offline

Napisano 20.09.2011 17:58

jeżeli to nie działa to masz złe kodowanie pliku, nie ma innej możliwości, chyba że masz .htaccess i jakieś przekierowania - to ostatnia ewentualność

aha i jeżeli tak to wkleiłeś to na poczatku jest spacja, usun to i zobacz
  • +
  • -
  • 1

#8 Gh0st

    :)

  • Autor tematu
  • Power User

Reputacja: 846
Czempion

  • Postów:920
  • GG:
  • Imię:Tomek
  • Lokalizacja:Rabka-Zdrój
Offline

Napisano 20.09.2011 18:00

@up :) Pisałem że działa i napisałem że masz mega + :)
  • +
  • -
  • 0

#9 fdszpl0

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:69
  • Lokalizacja:Kraków
Offline

Napisano 20.09.2011 18:02

teraz zgadnij zgodnie ze swoją teza jak to wygooglowałem że akurat masz tam spacje a nie widzialem twojego kodu... hmm?
  • +
  • -
  • 0

#10 Adminek AMXX.PL

    Admin :)

  • Bot

Reputacja: 156
Profesjonalista

  • Postów:7179
  • Lokalizacja:AMXX.PL
Offline

Napisano 20.09.2011 18:10

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: problem rozwiązany

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL





Również z jednym lub większą ilością słów kluczowych: PHP

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych