Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z vipem


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 LansBans

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:11
  • GG:
  • Imię:Michał
  • Lokalizacja:FigoFago
Offline

Napisano 06.09.2011 20:52

Witam jestem tu nowy więc jak by coś było nie tak to zrozumiem. Ok przejdzmy do problemu: oto on po skompilowaniu i wżuceniu na serwer tego plugingu: http://amxx.pl/topic...za-widzialnosc/ okazało się ,że nie działa nie wiem co może być tego przyczyno dlatego proszę o pomoc.
A i jeszcze
L 09/06/2011 - 20:38:08: Start of error session.
L 09/06/2011 - 20:38:08: Info (map "awp_india") (file "addons/amxmodx/logs/error_20110906.log")
L 09/06/2011 - 20:38:08: Plugin called message_begin with an invalid message id (0).
L 09/06/2011 - 20:38:08: [AMXX] Run time error 10 (plugin "vip4.amxx") (native "message_begin") - debug not enabled!
L 09/06/2011 - 20:38:08: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 09/06/2011 - 20:38:15: Plugin called message_begin with an invalid message id (0).
L 09/06/2011 - 20:38:15: [AMXX] Run time error 10 (plugin "vip4.amxx") (native "message_begin") - debug not enabled!
L 09/06/2011 - 20:38:15: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 09/06/2011 - 21:09:06: Start of error session.
L 09/06/2011 - 21:09:06: Info (map "aim_map") (file "addons/amxmodx/logs/error_20110906.log")
L 09/06/2011 - 21:09:06: [AMXX] Plugin file open error (plugin "debugvip4.amxx")
L 09/06/2011 - 21:16:03: Start of error session.
L 09/06/2011 - 21:16:03: Info (map "de_dust2x2") (file "addons/amxmodx/logs/error_20110906.log")
L 09/06/2011 - 21:16:03: [AMXX] Plugin file open error (plugin "debugvip4.amxx")
bo bym zapomniał. dziękuje i proszę o jak najszybszą odpowieć.

Użytkownik LansBans edytował ten post 06.09.2011 20:53

  • +
  • -
  • 0

#2 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 06.09.2011 21:06

L 09/06/2011 - 21:09:06: [AMXX] Plugin file open error (plugin "debugvip4.amxx")


niczego innego po tym nie mozna sie spodziewac jak przed pluginem ktos wpisuje debug
zamiast tego czegos co wpisales do plugins.ini wpisz jesli juz

vip4.amxx debug

Użytkownik hiroshima edytował ten post 06.09.2011 21:53
plugins.ini nie users.ini ;)

  • +
  • -
  • 0

#3 Misiaczek ;c

    /dev/null

  • Moderator

Reputacja: 1662
Godlike

  • Postów:2495
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Halemba
Offline

Napisano 06.09.2011 21:19


#include <amxmodx>
#include <fakemeta_util>

new niewidzialnosc, maxplayers, gmsgSayText;
new n[32], g_lastwpn[33];
new vip[] = "t";
static const COLOR[] = "^x04";
new bool:g_invis[33];

public plugin_init()
{
register_plugin("V.I.P", "1.0", "MisieQ")
register_event("CurWeapon", "Event_CurWeapon", "be", "1=1");
maxplayers = get_maxplayers()
register_clcmd("say", "vip_say")
niewidzialnosc = register_cvar("amx_vip_niewidzialnosc", "100")
gmsgSayText = get_user_msgid("SayText");
}

/* Funkcja od Sprawdzania Uprawnien(Flag) */
public has_flags(id,string[])
{
new ret=1
new byte
new len = strlen(string)
new p_flag = get_user_flags(id)

for(new i=0;i<=len;i++)
{
if(string[i]>='a' && string[i]<='z') byte = (1<<(string[i]-'a'))
else if(string[i]>='A' && string[i]<='Z') byte = (1<<(string[i]-'A'))
else if(string[i]==',' && ret==1) return 1
else if(string[i]==',') ret=1
if(byte!=0 && !(p_flag & byte)) ret=0

byte=0
}
return ret
}

/* Info HUD */
public client_authorized(id)
{
if(has_flags(id,vip))
{
get_user_name(id, n, 31);
set_hudmessage(255, 255, 0, 0.04, 0.76, 0, 6.0, 6.0)
show_hudmessage(0, "V.I.P %s^nWbija na Serwer", n)
}
}

public client_putinserver(id)
{
if(has_flags(id,vip))
{
get_user_name(id, n, 31);
set_hudmessage(255, 255, 0, 0.04, 0.76, 0, 6.0, 6.0)
show_hudmessage(0, "V.I.P %s^n Dolaczyl do Gry!^nGL & HF", n)
}
}

/* Informacje kto ma VIPA */
public vip_say(id)
{
new said[192]
read_args(said,192)
if( ( containi(said, "vip") != -1 && containi(said, "/vip") != -1 ) )
set_task(0.1,"print_vip",id)
return PLUGIN_CONTINUE
}

public print_vip(user)
{
new vipnames[33][32]
new message[256]
new id, count, x, len

for(id = 1 ; id <= maxplayers ; id++)
if(is_user_connected(id))
if(has_flags(id,vip))
get_user_name(id, vipnames[count++], 31)

len = format(message, 255, "%s V.I.P: ",COLOR)
if(count > 0)
{
for(x = 0 ; x < count ; x++)
{
len += format(message[len], 255-len, "%s%s ", vipnames[x], x < (count-1) ? ", ":"")
if(len > 96 )
{
print_message(user, message)
len = format(message, 255, "%s ",COLOR)
}
}
print_message(user, message)
}
else
{
len += format(message[len], 255-len, "Brak grajacych V.I.P.")
print_message(user, message)
}

}

print_message(id, msg[])
{
message_begin(MSG_ONE, gmsgSayText, {0,0,0}, id)
write_byte(id)
write_string(msg)
message_end()
}

/* Niewidzialnosc & Sprawdzanie czy ma niewidzialnosc */
public Event_CurWeapon(id)
{
if (!is_user_alive(id)) return;
if(has_flags(id,vip)) return;

new weapon_id = read_data(2);

g_invis[id] = false;

if ( g_lastwpn[id] != weapon_id )
{
set_invis(id);
}

g_lastwpn[id] = weapon_id;
}

public set_invis(id)
{
new wartosc;
wartosc = get_pcvar_num(niewidzialnosc);
if (!is_user_alive(id)) return;
if(has_flags(id,vip))
{
fm_set_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransTexture, wartosc);
g_invis[id] = true;
}
else
{
fm_set_rendering(id);
g_invis[id] = false;
}
}

  • +
  • -
  • 0

#4 LansBans

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:11
  • GG:
  • Imię:Michał
  • Lokalizacja:FigoFago
Offline

Napisano 06.09.2011 21:49

niczego innego po tym nie mozna sie spodziewac jak przed pluginem ktos wpisuje debug
zamiast tego czegos co wpisales do users ini wpisz jesli juz

vip4.amxx debug

Trafna podpowiedz lecz z błędem jak już to trzeba bylo to vip4.amxx debug
do plugins.ini
a nie do jak to napisałeś users ini

Dziękuje za pomoc.

Użytkownik LansBans edytował ten post 06.09.2011 21:38

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych