Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z kompilacją IPLog


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 Fajled

    Wszechwidzący

  • Użytkownik

Reputacja: 56
Pomocny

  • Postów:279
  • GG:
  • Imię:Damian
  • Lokalizacja:Wrocław
Offline

Napisano 05.09.2011 18:17

Witam.
Mam pewne problemy z kompilacją pluginu. Pokazuje on IP graczy którzy są/byli na serwerze i zapisuje logi do pliku.

Oto błędy podczas kompilacji:

Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright (c) 1997-2006 ITB CompuPhase, AMX Mod X Team

IPLog.sma(9) : error 017: undefined symbol "register_plugin"
IPLog.sma(14) : error 017: undefined symbol "is_user_bot"
IPLog.sma(14) : error 017: undefined symbol "PLUGIN_CONTINUE"
IPLog.sma(19) : error 017: undefined symbol "get_user_name"
IPLog.sma(20) : error 017: undefined symbol "get_user_ip"
IPLog.sma(22) : error 017: undefined symbol "date"
IPLog.sma(24) : error 017: undefined symbol "formatex"
IPLog.sma(26) : error 017: undefined symbol "log_to_file"
IPLog.sma(27) : error 017: undefined symbol "PLUGIN_CONTINUE"

9 Errors.
Could not locate output file IPLog.amxx (compile failed).

Za pomoc + :)

W załączniku plugin.

Załączone pliki


  • +
  • -
  • 0

#2 LaaGer

    Banned

  • Zbanowany

Reputacja: 83
Zaawansowany

  • Postów:153
  • GG:
  • Steam:steam
  • Imię:Andrzej
  • Lokalizacja:Warszawa
Offline

Napisano 05.09.2011 18:49

Brakuje podanych include w pluginie

*sma naprawione

 
[attachment=23300:IPLog.sma]
+ skompilowane do *amxx
[attachment=23301:IPLog.amxx]


Powionno Działac :)

Załączone pliki


Użytkownik LaaGer edytował ten post 05.09.2011 18:54


#3 Fajled

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 56
Pomocny

  • Postów:279
  • GG:
  • Imię:Damian
  • Lokalizacja:Wrocław
Offline

Napisano 05.09.2011 18:53

Wielkie dzięki.
Plusik :)
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych