Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z adminem w amxbans 1.5.1


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 Seerq.

    Zaawansowany

  • Użytkownik

Reputacja: 6
Nowy

  • Postów:76
  • GG:
  • Lokalizacja:Lębork
Offline

Napisano 20.08.2011 17:52

Witam. Dzisiaj zainstalowałem sobie modyfikację jaką jest AmxBans 1.5.1 dokładnie tę: [GmAMXBans] GmAMXBans 1.5.1 - FINAL - AMXX.pl: Support AMX Mod X Wszystko było dobrze strona fajnie działa itd, lecz wchodzę na serwera a tu "d*pa" próbuję wejść w amxmodmenu a tu nic "Nie możesz użyć tej komendy". Nie wiem co się stało przed dodaniem modyfikacji wszystko było dobrze. Strona jest na hostingu xaa.pl a serwer na OwnServer.pl
Wersja amxmodx to 1.8.1 DPROTO 0.9.86
Dołączę parę plików:
Tak wygląda dodany admina w AmxBans: ImageShack� - Online Photo and Video Hosting
Tak wygląda dodany admin na stronie OwnServer: http://img9.imagesha.../problem2ff.jpg
A tak wygląda plik users.ini: http://img405.images...6/problem3r.jpg
I jeszcze jak wygląda początek pliku plugins.ini: http://img845.images...82/problem4.jpg
W załączniku dodam plik amxbans.cfg i logi z dzisiejszego dnia.
Dorzucam pliki które były wskazane w regulaminie

Załączone pliki

  • Załączony plik  amxbans.cfg   4,21 KB  23 Ilość pobrań
  • Załączony plik  logi.txt   110,18 KB  16 Ilość pobrań
  • Załączony plik  modules.ini   1,13 KB  14 Ilość pobrań
  • Załączony plik  plugins.ini   2,66 KB  11 Ilość pobrań
  • Załączony plik  sql.cfg   498 bajtów  14 Ilość pobrań
  • Załączony plik  logs.rar   7,34 KB  12 Ilość pobrań

Użytkownik SEERQ666 edytował ten post 20.08.2011 18:05

  • +
  • -
  • -1

#2 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 20.08.2011 17:57

// Wczytywanie adminów
// 0 z bazy SQL, 1 = z pliku users.ini, 2 = nie laduje adminów
amxbans_use_admins_file "1"

zamien na

// Wczytywanie adminów
// 0 z bazy SQL, 1 = z pliku users.ini, 2 = nie laduje adminów
amxbans_use_admins_file 0
i dodaj adminow w strefie admina w amxbans

L 08/20/2011 - 18:30:36: [amxbans_main.amxx] [AMXBans] Message: Can't connect to MySQL server on '127.0.0.1' (111) (2003)


musze ci tlumaczyc? zly host...
  • +
  • -
  • 1

#3 Seerq.

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 6
Nowy

  • Postów:76
  • GG:
  • Lokalizacja:Lębork
Offline

Napisano 20.08.2011 18:06

Pytanie.
Dodałem ss adminów z amxbansa i czy ten admin jest dobrze dodany ?
I gdzie zmienić ten host ?

Użytkownik SEERQ666 edytował ten post 20.08.2011 18:07

  • +
  • -
  • 0

#4 A może sma?

    Godlike

  • Power User

Reputacja: 539
Wszechwiedzący

  • Postów:1464
  • GG:
  • Steam:steam
  • Imię:Tomasz
  • Lokalizacja:Polska
Offline

Napisano 20.08.2011 18:19

w sql.cfg
  • +
  • -
  • 1

#5 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 20.08.2011 18:25

w sql.cfg masz podac poprawny host do bazy danych a potem nadac mu odpowiednie uprawnienia i tutaj z pomoca przychodza te 2 linki:

[GmAMXBans] AMXBANS i MySQL. TUTORIAL - AMXX.pl: Support AMX Mod X
[GmAMXBans] Instalacja AMXBans 6.x / GmAMXBANS - AMXX.pl: Support AMX Mod X

nie tylko masz to przeczytac ale i zrozumiec
  • +
  • -
  • 1

#6 Seerq.

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 6
Nowy

  • Postów:76
  • GG:
  • Lokalizacja:Lębork
Offline

Napisano 20.08.2011 18:48

Hmm.
Przeczytałem i spróbowałem zrozumieć co mi wysłałeś ale się nie udało.
Problem polega na tym że nie wiem gdzie niby mogę znaleźć ten host ?
Proszę o pomoc bo trochę tego nie rozumiem :/
Jeżeli spróbuję dodać IP serwera do tego: "Hosty którym przydzielono dostęp" to wyświetla mi się taki błąd:
Usuń hosty bazy danych
Sorry, the "Access Host" field must be a valid hostname.
(Example domain.com)
(Wildcard Example %.domain.com)
O co chodzi ?
Czy trzeba jeszcze coś w tym zmienić:?

amx_sql_host "Tutaj ten host tylko skąd wsiąść poprawny"
amx_sql_user "Użytkownik bazy danych?"
amx_sql_pass "Hasło do tej nazwy użytkownika bazy danych? "
amx_sql_db "Nazwa bazy danych"
amx_sql_table "admins" ---> Tutaj coś zmienić ?
amx_sql_type "mysql" ---> Tutaj coś zmienić ?

Dodano 21 sierpień 2011 - 06:50:
Z tym problemem się uporałem ^^ Reinstall serwera pomógł :)
Ale teraz mam nowy problem :/
Jest on następujący.
Wchodzę na serwer otwieram amxmodmenu wszystko ładnie działa biorę Zbanuj Gracza wybieram siebie specjalnie usunąłem flagę "a" wybieram czas bana (5min) i wybieram powód. Wszystko fajnie ale nic się nie dzieje :/ Kiedy zbanuję się przez stronę AmxBansa to jest tylko napisane w grze "Kicked Testy" i nic więcej na serwer mogę normalnie wejść :(
Jeżeli będą potrzebne jakieś pliki to proszę mówić :)

Dodano 21 sierpień 2011 - 09:04:
Dodam do tego Logi plik amxbans.cfg i sql.cfg.
Nie ma logów z ERROR

Dodano 21 sierpień 2011 - 18:14:
To jak pomoże ktoś ?

Załączone pliki


Użytkownik SEERQ666 edytował ten post 21.08.2011 10:39

  • +
  • -
  • 0

#7 Kamil0

    Pomocny

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:59
  • GG:
  • Steam:steam
  • Imię:Kamil
  • Lokalizacja:Małopolska
Offline

Napisano 21.08.2011 18:41

"ultrashooter.xaa.pl"


host jest dobry, może litrówka albo zdalne połączenia nadaj dla ip serwera.
  • +
  • -
  • 1

#8 Seerq.

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 6
Nowy

  • Postów:76
  • GG:
  • Lokalizacja:Lębork
Offline

Napisano 21.08.2011 19:30

Już wszystko dobrze :) Jakoś sam sobie pomogłem.
Nawet nie wiem co tak właściwie pomogło :D
Temat proszę już zamknąć.


P.S Bardzo przepraszam za spam :)
  • +
  • -
  • 0

#9 Adminek AMXX.PL

    Admin :)

  • Bot

Reputacja: 156
Profesjonalista

  • Postów:7178
  • Lokalizacja:AMXX.PL
Offline

Napisano 21.08.2011 19:32

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: problem rozwiązany

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych