Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Friendly Fire nie działa


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 Wykfalifikowany

    Nowy

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:4
  • Imię:Maciek
  • Lokalizacja:Polska
Offline

Napisano 06.08.2011 09:01

Witam.
Mam problem z friendly fire. Otóż , po zmianie mapy friendly fire się włącza. Mam w server.cfg mp_friendlyfire 0 , w amxx.cfg amx_cvar mp_friendlyfire 0 , mam zainstalowany plugin , dzięki któremu też ma być wyłączone , ale nic z tego , nic nie działa. Czy ktoś wie , czym to może być spowodowane ?

#2 speedkill

    Godlike

  • Przyjaciel

Reputacja: 1570
Godlike

  • Postów:2733
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Prudnik
Offline

Napisano 06.08.2011 09:04

Może ustaw z poziomu serwera w amxmodmenu w ustawieniach serwera
  • +
  • -
  • 0

If you can dream it, you can do it.


#3 Wykfalifikowany

    Nowy

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:4
  • Imię:Maciek
  • Lokalizacja:Polska
Offline

Napisano 06.08.2011 10:36

Nic z tego , nie pomaga.

#4 fejk

    Wszechpomocny

  • Zbanowany

Reputacja: 53
Pomocny

  • Postów:336
  • GG:
  • Lokalizacja:users.ini
Offline

Napisano 06.08.2011 10:45

ale nie rozumie.. Ty chcesz żeby friend fire było włączone czy wyłączone??

#5 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10832
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 06.08.2011 11:22

spróbuj tak
#include <amxmisc>
#include <hamsandwich>

#define PLUGIN "New Plug-In"
#define VERSION "1.0"
#define AUTHOR "DarkGL"

public plugin_init() {
	register_plugin(PLUGIN, VERSION, AUTHOR)
	
	RegisterHam(Ham_TakeDamage,"player","fwDamage")
}

public fwDamage(this, idinflictor, idattacker, Float:damage, damagebits){
	if(is_user_connected(this) && is_user_connected(idattacker) && get_user_team(this) == get_user_team(idattacker))
		return HAM_SUPERCEDE;
	
	return HAM_IGNORED;
}

  • +
  • -
  • 0

#6 Wykfalifikowany

    Nowy

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:4
  • Imię:Maciek
  • Lokalizacja:Polska
Offline

Napisano 06.08.2011 12:00

Nic z tego nie pomaga.

ale nie rozumie.. Ty chcesz żeby friend fire było włączone czy wyłączone??

- Chcę mieć wyłączone.

Próbowałem już zmieniać ze strony postrzelaj , ale nic nie daje.

#7 Julia

    Profesjonalista

  • Girl

Reputacja: 36
Życzliwy

  • Postów:163
  • Steam:steam
  • Imię:Julia
  • Lokalizacja:Gdynia
Offline

Napisano 06.08.2011 12:39

Może wejdź w konsolę, wpisz amx_rcon exec server.cfg
Zmień mapę i sprawdź
  • +
  • -
  • 0

#8 V3ko

    Guru

  • Power User

Reputacja: 82
Zaawansowany

  • Postów:746
  • Lokalizacja:Stopnica
Offline

Napisano 06.08.2011 12:46

A może w amxx.cfg wpisz mp_friendlyfire 0 bez amx_cvar i zrestartuj serwer.
  • +
  • -
  • 0

#9 Wykfalifikowany

    Nowy

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:4
  • Imię:Maciek
  • Lokalizacja:Polska
Offline

Napisano 06.08.2011 14:15

A może w amxx.cfg wpisz mp_friendlyfire 0 bez amx_cvar i zrestartuj serwer.

nic z tego nadal nic.

w konsoli jest napisane , Server cvar : "mp_friendlyfire" = "1"
Server cvar : "mp_tkpunish" = "0"
Server cvar : "mp_autokick" = "0"




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych