Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[SRN] Brak połączenia z bazą danych


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 Muphet

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:17
  • Imię:Marcin
  • Lokalizacja:Polska
Offline

Napisano 30.07.2011 20:58

Witam.

Zainstalowałem u siebie System Rezerwacji Nicków (SRN). Wszystko zostało skonfigurowane poprawnie lecz mimo wszystko serwer nie łączy się z bazą danych. Odpowiedź amxa (w logach) wygląda tak:
L 07/30/2011 - 21:53:25: [srn.amxx] [SRN] Polaczenie nieudane!
L 07/30/2011 - 21:53:25: [srn.amxx] [SRN] Blad zapytania, lokacja: 16
L 07/30/2011 - 21:53:25: [srn.amxx] [SRN] Wiadomosc: Access denied for user 'xxx'@'IP HERE' (using password: YES) (1045)
L 07/30/2011 - 21:53:25: [srn.amxx] [SRN] Status zapytania: 
L 07/30/2011 - 21:53:25: [srn.amxx] [SRN] Blad podczas laczenia z serwerem mysql!
//też mnie to dziwi, bo serwer próbuje połączyć się z MySql znajdującym się na tym samym serwerze a baza danych uruchomiona jest na zewnętrznym serwerze..

Czy ktoś wie, gdzie leży problem?
  • +
  • -
  • 0
Dołączona grafika

#2 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 30.07.2011 21:02

//też mnie to dziwi, bo serwer próbuje połączyć się z MySql znajdującym się na tym samym serwerze a baza danych uruchomiona jest na zewnętrznym serwerze..


pokaz cvary z tego pluginu (te od mysql)


uzytkownik posiada wszystkie uprawnienia do bazy? nadales dostep dla zewnetrznych hostów do bazy?
  • +
  • -
  • 0

#3 Muphet

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:17
  • Imię:Marcin
  • Lokalizacja:Polska
Offline

Napisano 30.07.2011 21:09

Tak oczywiście. Nie jest to mój pierwszy serwer a przy pozostałych wszystko działa (np amxbans).
srn_sql_host "188.165.245.114"
srn_sql_user "user"
srn_sql_pass "xxx"
srn_sql_db "baza"
srn_res_time "2592000"
srn_spam_delay "60"
srn_maxres "1"

to jest plik srn.cfg w którym jedynie podmieniłem dane..

Użytkownik Muphet edytował ten post 30.07.2011 21:09

  • +
  • -
  • 0
Dołączona grafika

#4 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 30.07.2011 21:22

Wiadomosc: Access denied for user 'xxx'@'IP HERE' (using password: YES) (1045)


albo user nie ma uprawnien do tej bazy, albo nie ma uprawnienia do polaczenia sie z tego hosta, z ktorego się łączy

  • +
  • -
  • 0

#5 Muphet

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:17
  • Imię:Marcin
  • Lokalizacja:Polska
Offline

Napisano 30.07.2011 21:25

ma pełne uprawnienia, bo żywcem skopiowałem dane z drugiego serwera który jest połączony z amxbans..
  • +
  • -
  • 0
Dołączona grafika

#6 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 30.07.2011 21:29

[GmAMXBans] AMXBANS i MySQL. TUTORIAL - AMXX.pl: Support AMX Mod X - zamiast kopiowac cokolwiek zrob nowa baze do tego. tutaj masz opisane jak to zrobic, czesc o amxbans omin.
  • +
  • -
  • 0

#7 Muphet

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:17
  • Imię:Marcin
  • Lokalizacja:Polska
Offline

Napisano 30.07.2011 21:43

Dzięki. Dopiero dodanie % (wszystkich hostów) pozwoliło na połączenie z bazą..
do zamknięcia.
  • +
  • -
  • 0
Dołączona grafika




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych