Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

DiabloMod - /item - item.txt


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 Ooze

    Zaawansowany

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:82
  • GG:
  • Lokalizacja:Łódź
Offline

Napisano 03.01.2009 15:26

Witam.

Mam takowy problem. Posiadam serwer na linuxie z diablomodem i kiedy ustawie chmod item.txt na 777 plik sie nie kasuje tylko dopisuje i mam po chwili overflode. jesli jest inny chmod niz 777 to znou nie dzialaja komendy /item oraz /czary ...

ma ktos rozwiazanie takiego problemu?

[ Dodano: 03-01-2009, 13:52 ]
Hmmm... no widze ze nikt nie jest w stanie mi pomoc... no trudno... powiem tylko tyle ze mnie sie udalo rozwiazac ten problem...

a tutaj jego rozwiazanie...

edytujemy .sma i zamiast "%s/diablo/item.txt" zostawiamy tylko "%sitem.txt" i kompilujemy...

pozdrawiam i sry za spam
  • +
  • -
  • 0

#2 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 03.01.2009 15:30

Aha, czyli zamist wrzucic folder diablo do config, to przeniosles tylko pliki z tego folderu do config?
  • +
  • -
  • 0

#3 Ooze

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 2
Nowy

  • Postów:82
  • GG:
  • Lokalizacja:Łódź
Offline

Napisano 03.01.2009 16:29

Aha, czyli zamist wrzucic folder diablo do config, to przeniosles tylko pliki z tego folderu do config?


oh nie , nie... cala instalacja wyglada tak samo jak na windowsie!

Zmiana polega na tym ze trzeba edytowac plik .sma (diablo moda) i potem go skompilowac! (innymi slowy, grzebiemy w samym kodzie :) )
  • +
  • -
  • 0

#4 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 03.01.2009 16:37

%s/diablo -> amxmodx/config/diablo/

%s -> amxmodx/config

Jesli nie mogl pracowac na pliku, a zmiana kodu z adresem folderu pomogla, to albo nie bylo mod 777 w folderu config/diablo, albo nie bylo folderu config/diablo ;>
  • +
  • -
  • 0

#5 Ooze

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 2
Nowy

  • Postów:82
  • GG:
  • Lokalizacja:Łódź
Offline

Napisano 03.01.2009 17:39

miczu, zle to rozumujesz zaraz postaram ci to dokladnie wytlumaczyc...

oryginalny kod pliku dbmod.sma (tu wersja 5.8d)

format(g_ItemFile,63,"%s/diablo/item.txt",amxbasedir)
if(file_exists(g_ItemFile))
delete_file(g_ItemFile)

poniewaz mam serwer na linuxie zle odczytywal sciezke dostepu, odczytywal ja jako format windows czyli "/diablo/" a nie format linuxowy czyli "diablo". sama zmiana "/" na "" nie dawala pozadanego efektu dlatego trzeba zmienic styl pobierania folderu docelowego... i kod wynikowy :

format(g_ItemFile,63,"%sitem.txt",amxbasedir)
if(file_exists(g_ItemFile))
delete_file(g_ItemFile)

teraz linux tworzy wlasna poprawna sciezke dostepu do pliku i jest ok ;) co prawda zmienia sie ona i plik z zapisem tworzy sie w katalogu addons ale dziala :P
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych