Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Nie dzialaja mi modele w vipie


  • Zamknięty Temat jest zamknięty
Brak odpowiedzi do tego tematu

#1 NewaX

    Wszechwidzący

  • Użytkownik

Reputacja: 28
Życzliwy

  • Postów:241
  • Imię:Marcin
  • Lokalizacja:Biłgoraj
Offline

Napisano 04.07.2011 17:04

A wiec mam vipa probowalem zrobic go z modelami ale cos nie dziala. Podczas kompilacji pojawia sie 1 warring. Pomoze ktos? bo zalezy mi aby dzialaly modele.
/* Plugin generated by AMXX-Studio */

#include <amxmodx>
#include <hamsandwich>
#include <cstrike>
#include <fun>



public plugin_init() {
	register_plugin("Vip", "1.0", "newax");
	register_event("ResetHUD", "resetModel", "b");
	RegisterHam(Ham_Spawn, "player", "fwHamPlayerSpawnPost", 1);
	return PLUGIN_CONTINUE
}
public plugin_precache() {
        precache_model("models/player/vip_t/vip_t.mdl")
        precache_model("models/player/vip_ct/vip_ct.mdl")
	return PLUGIN_CONTINUE
}
public resetModel(id, level, cid) {

	if (get_user_flags(id) & ADMIN_LEVEL_H) {
                new CsTeams:userTeam = cs_get_user_team(id)
                if (userTeam == CS_TEAM_T) {
                        cs_set_user_model(id, "vip_t")
                }
                else if(userTeam == CS_TEAM_CT) {
                        cs_set_user_model(id, "vip_ct")
                }
                else {
                        cs_reset_user_model(id)
                }
        }
return PLUGIN_CONTINUE
}

public fwHamPlayerSpawnPost(id){
	
	if (get_user_flags(id) & ADMIN_LEVEL_H) {
		
		set_user_health(id, 120);
		
		new kasa = cs_get_user_money(id);
		cs_set_user_money(id, kasa + 1500);
	}
}
/* AMXX-Studio Notes - DO NOT MODIFY BELOW HERE
*{\\ rtf1\\ ansi\\ ansicpg1250\\ deff0\\ deflang1045{\\ fonttbl{\\ f0\\ fnil Tahoma;}}\n\\ viewkind4\\ uc1\\ pard\\ f0\\ fs16 \n\\ par }
*/

Dodano 04 lipiec 2011 - 17:09:
Ok juz ogarnolem. Do zamkniecia.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych