Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

nvault - nie dziala odczyt


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 eRBeKa#

    Pomocny

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:72
  • Lokalizacja:Poznań
Offline

Napisano 29.06.2011 14:07

Dodałem nowe include:

#include <nvault>

nad plugin_ini dałem:

new g_vault;

do plugin_ini dałem:

g_vault = nvault_open("dr_punkty");

pod plugin_ini dałem:

public SaveData(id)
{
	if(!is_user_connected(id))
		return PLUGIN_CONTINUE
		
	new name[31]
	get_user_name(id,name,30)
	new vaultkey[64],vaultdata[24]
	format(vaultkey,63,"%s-DR",name)
	format(vaultdata,23,"%i",punkty[id])
	nvault_set(g_vault,vaultkey,vaultdata)
	return PLUGIN_CONTINUE
}
public LoadData(id)
{
	if(!is_user_connected(id))
		return PLUGIN_CONTINUE
		
	new name[35]
	get_user_name(id,name,34)
	new vaultkey[64]
	format(vaultkey,63,"%s-DR",name)
	new v_punkty[31]
	nvault_get(g_vault,vaultkey,v_punkty,30)
	punkty[id] = str_to_num(v_punkty)
	
	return PLUGIN_CONTINUE
}

I nie działa...

Wie ktoś co jest źle ?
  • +
  • -
  • 0
Jestem jaki jestem, i dobrze mi z tym :)
Just-Frags.PL - Prawdziwa pasja nie zna granic!!

#2 Fili:P

    Koleżeński

  • Power User

Reputacja: 752
Guru

  • Postów:1679
  • GG:
  • Steam:steam
  • Imię:Filip
  • Lokalizacja:Radom
Offline

Napisano 29.06.2011 14:45

new g_vault;

daj nie w funkcji, czyli poza plugin_init i innymi funkcjami
  • +
  • -
  • 0

BMXers.pl - Portal o tematyce BMX


#3 eRBeKa#

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 7
Nowy

  • Postów:72
  • Lokalizacja:Poznań
Offline

Napisano 29.06.2011 15:25

nad plugin_ini dałem:

new g_vault;


Pisze wyraźnie, że dałem nad... Jest między innymi funkcjami.
  • +
  • -
  • 0
Jestem jaki jestem, i dobrze mi z tym :)
Just-Frags.PL - Prawdziwa pasja nie zna granic!!

#4 Fili:P

    Koleżeński

  • Power User

Reputacja: 752
Guru

  • Postów:1679
  • GG:
  • Steam:steam
  • Imię:Filip
  • Lokalizacja:Radom
Offline

Napisano 29.06.2011 16:47

tak powinno wyglądać LoadData
public LoadData(id)
{
if(!is_user_connected(id))
return PLUGIN_CONTINUE

new name[35]
get_user_name(id,name,34)
new vaultkey[64],vaultdata[24]
format(vaultkey,63,"%s-DR",name)
new v_punkty[31]
nvault_get(g_vault,vaultkey,v_punkty,30)
replace_all(vaultdata, 23, "#", " ")
parse(vaultdata, v_punkty, 30)
punkty[id] = str_to_num(v_punkty)

return PLUGIN_CONTINUE
}

  • +
  • -
  • 1

BMXers.pl - Portal o tematyce BMX


#5 eRBeKa#

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 7
Nowy

  • Postów:72
  • Lokalizacja:Poznań
Offline

Napisano 29.06.2011 19:39

Zaraz sprawdzę, masz plusa nawet jak nie będzie działać.

Niestety ale nie działa..

Użytkownik eRBeKa# edytował ten post 29.06.2011 19:55

  • +
  • -
  • 0
Jestem jaki jestem, i dobrze mi z tym :)
Just-Frags.PL - Prawdziwa pasja nie zna granic!!

#6 Fili:P

    Koleżeński

  • Power User

Reputacja: 752
Guru

  • Postów:1679
  • GG:
  • Steam:steam
  • Imię:Filip
  • Lokalizacja:Radom
Offline

Napisano 30.06.2011 08:19

Spróbuję raz ostatni, pod plugin init dodaj te 3 funkcję
public client_connect(id)
LoadData(id)
public client_disconnect(id){
SaveData(id)
punkty[id]=0
}
public plugin_end()
nvault_close(g_vault)

  • +
  • -
  • 1

BMXers.pl - Portal o tematyce BMX


#7 eRBeKa#

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 7
Nowy

  • Postów:72
  • Lokalizacja:Poznań
Offline

Napisano 30.06.2011 23:43

Kurde nie działa... Zapis działa, lecz odczyt już nie.
  • +
  • -
  • 0
Jestem jaki jestem, i dobrze mi z tym :)
Just-Frags.PL - Prawdziwa pasja nie zna granic!!




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych