Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

Problem z odgrywaniem dźwięki

CoD Nowy

  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 Luker12

    Zaawansowany

  • Użytkownik

Reputacja: 5
Nowy

  • Postów:99
  • GG:
  • Lokalizacja:Nie musisz wiedzieć
Offline

Napisano 24.06.2011 21:37

Otóż mam problem z nowym dźwiękiem. Zastąpiłem stary dźwięk awansu na nowy, oczywiście dałem go w nowym folderze(format .wav). Wszystko ładnie się ściągnęło, ale dźwięku tego nie odgrywa przy awansie.

Linijki odpowiedzialne za ten dźwięk:

W public plugin_precache():

public plugin_precache()
{
precache_sound("QTM_CodMod/select.wav");
precache_sound("QTM_CodMod/start.wav");
precache_sound("QTM_CodMod/start2.wav");
precache_sound("QTM_CodMod/Cod/Level.wav");
}


Linijkę z nowym dźwiękiem pogrubiłem.

W public SprawdzPoziom(id):

else if(zdobyl_poziom)
{
punkty_gracza[id] = (poziom_gracza[id]-1)*2-inteligencja_gracza[id]-zdrowie_gracza[id]-wytrzymalosc_gracza[id]-kondycja_gracza[id];
set_hudmessage(212, 255, 85, 0.31, 0.32, 0, 6.0, 5.0);
ShowSyncHudMsg(id, SyncHudObj2,"Awansowales do %i poziomu!", poziom_gracza[id]);
client_cmd(id, "spk QTM_CodMod/Cod/Level");
}


Linijkę z nowym dźwiękiem pogrubiłem.
  • +
  • -
  • 0

#2 Misiaczek ;c

    /dev/null

  • Moderator

Reputacja: 1662
Godlike

  • Postów:2495
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Halemba
Offline

Napisano 24.06.2011 21:55

zamień
precache_sound("QTM_CodMod/Cod/Level.wav");


zamień na

precache_sound("QTM_CodMod/nowypoziom.wav");



zamień
client_cmd(id, "spk QTM_CodMod/cod/Level");


zamień na

client_cmd(id, "spk QTM_CodMod/nowypoziom");


dzwięk nazwij nowypoziom.wav i wgraj do katalogu QTM_CodMod

jest to najprostsze rozwiązanie, najlepiej sprawdzić czy dźwięk odgrywa się w cs ;] jeśli działa w cs to powinien tez działać przez plugin, jesli nie należy naprawić ów dźwięk aby był odgrywany w cs ;]
  • +
  • -
  • 1

#3 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 24.06.2011 21:59

developer 2
spk QTM_CodMod/Cod/Level.wav
developer 0

uruchom to i dostaniesz na żółto info dlaczego .wav nie gra
  • +
  • -
  • 2

#4 Luker12

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:99
  • GG:
  • Lokalizacja:Nie musisz wiedzieć
Offline

Napisano 06.07.2011 13:43

Niby wszystko ładnie się ściągnęło, ale jest taki błąd:
Warning: Unable to open sound/QTM_CodMod/nowypoziom.wav for transfer

  • +
  • -
  • 0

#5 V3ko

    Guru

  • Power User

Reputacja: 82
Zaawansowany

  • Postów:746
  • Lokalizacja:Stopnica
Offline

Napisano 06.07.2011 14:00

Zła częstotliwość ?
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: CoD Nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych