Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Szybkość Klas


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 Zielas

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Imię:Arek
  • Lokalizacja:Toruń
Offline

Napisano 22.06.2011 10:36

Witam serdecznie, ze względu na to iż jestem nowy na waszym forum najpierw krótko się przedstawię.
Mam na imię Arek , niedługo kończę 19 lat i jestem z Torunia.

Dobra do rzeczy mój problem polega na szybkości klas w starym Cod Modzie, mianowicie niektóre klasy biegają z zabójczą prędkością , oczywiście wiem gdzie się to ustawia ale myślę że coś jest nie tak. Próbowałem wszystkiego zwiększałem np: 1.3, 1.4 itp zmniejszałem, np: 0.8, 0.6 itp i nic to niedawało poszczególne klasy nadal biegały jak na SH :/ Naprzykład klasa "Swat" biega strasznie szybko, i naprawdę niewiem jak to ustawić, być może ja coś żle robię ale nie wydaje mi się że bym popełniał jakiś błąd w tak banalnej sprawie.

Oto wycinek z mojego pliku .sma:

enum { NONE = 0, Snajper, Komandos, Piechur, Terrorysta, Kamikadze, Demolitions, Rambo, Medyk, Szturmowiec, Powstaniec, SWAT, Tropiciel, Spadochroniarz, Rebeliant, Marynarz, Inzynier, Komunista, Kapitan, Maszynista, Policjant, Agent};
new const zdrowie_klasy[] = { 0, 120, 140, 100, 110, 110, 110, 130, 130, 115, 100, 120, 110, 120, 100, 120, 120, 110, 120, 130, 130, 120};
new const Float:szybkosc_klasy[] = {0.0, 1.2, 1.1, 0.9, 0.8, 1.0, 1.0, 1.0, 1.1, 0.8, 1.0, 1.1, 1.15, 1.15, 1.3, 1.0, 1.3, 1.2, 1.1, 1.2, 1.0, 0.9};
new const pancerz_klasy[] = { 0, 100, 100, 100, 150, 25, 100, 150, 0, 140, 50, 200, 100, 50, 0, 100, 100, 150, 100, 0, 50, 100};
new const nazwy_klas[][] = {"Brak",


Będe wdzięczny jeśli ktoś pomoże. Pozdrawiam
  • +
  • -
  • 0

#2 sharkowy

    Lokalna anomalia sejsmiczna o nieustalonej genezie.

  • Przyjaciel

Reputacja: 71
Pomocny

  • Postów:1913
Offline

Napisano 22.06.2011 10:43

Nie zmieniałeś u siebie przypadkiem tego:
#define STANDARDOWA_SZYBKOSC 250.0
??

Lub
server_cmd("sv_maxspeed 320");
??
  • +
  • -
  • 0

2011 - Admin FFA

2011 ~ 2012 - Support Team

2012 ~ 2014 - Moderator

2014 - Junior Admin

2015 - Przyjaciel  R.I.P. sharkowy :(

 


#3 Zielas

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Imię:Arek
  • Lokalizacja:Toruń
Offline

Napisano 22.06.2011 10:55

Nie zmieniałeś u siebie przypadkiem tego:

#define STANDARDOWA_SZYBKOSC 250.0
??

Lub
server_cmd("sv_maxspeed 320");
??


Nie pamiętam żebym coś takiego zmieniał.

Podobna linijka którą w tej chwili znalazłem to:

szybkosc_gracza[id] = STANDARDOWA_SZYBKOSC*szybkosc_klasy[klasa_gracza[id]]+floatround(kondycja_gracza[id]*1.3);

- nie za bardzo rozumiem o co tu chodzi ale dla pewności podam.

Użytkownik Zielas edytował ten post 22.06.2011 11:00

  • +
  • -
  • 0

#4 sharkowy

    Lokalna anomalia sejsmiczna o nieustalonej genezie.

  • Przyjaciel

Reputacja: 71
Pomocny

  • Postów:1913
Offline

Napisano 22.06.2011 11:07

Możesz spróbować zmniejszyć mnożnik, podmień tą linijkę na np. taką:

szybkosc_gracza[id] = STANDARDOWA_SZYBKOSC*szybkosc_klasy[klasa_gracza[id]]+floatround(kondycja_gracza[id]*1.0);

  • +
  • -
  • 0

2011 - Admin FFA

2011 ~ 2012 - Support Team

2012 ~ 2014 - Moderator

2014 - Junior Admin

2015 - Przyjaciel  R.I.P. sharkowy :(

 


#5 Zielas

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Imię:Arek
  • Lokalizacja:Toruń
Offline

Napisano 22.06.2011 14:07

Znalazłem tą linijkę:

STANDARDOWA_SZYBKOSC 250.0

Wygląda ona tak, i niewiem w czym problem. :/
  • +
  • -
  • 0

#6 WazzaP

    Super Hero

  • Użytkownik

Reputacja: 129
Zaawansowany

  • Postów:1161
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Łęczna
Offline

Napisano 22.06.2011 15:19

A ten cod to jakiś unikalny? Bo szybciej by wyszło, gdybyś dał sma.
  • +
  • -
  • 0

#7 Zielas

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Imię:Arek
  • Lokalizacja:Toruń
Offline

Napisano 22.06.2011 16:41

A ten cod to jakiś unikalny? Bo szybciej by wyszło, gdybyś dał sma.

Niema problemu , proszę .sma w załączniku.
I jeśli byłaby taka możliwośc , to bardzo bym prosił aby ktoś mi to ustabilizował, żeby klasy biegały troszke ponad norme od standardu ale nie szybko tak przeciętnie, klasa "Agent" i "Maszynista" Troszke szybciej. Mam nadzieje że zbyt wiele nie wymagam. ;]

Załączone pliki


Użytkownik Zielas edytował ten post 22.06.2011 16:42

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych