Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

29 errorów z ColorChat


  • Zamknięty Temat jest zamknięty
5 odpowiedzi w tym temacie

#1 Optymalny193

    Wszechwidzący

  • Zbanowany

Reputacja: 30
Życzliwy

  • Postów:294
  • Imię:Paweł
  • Lokalizacja:Europa
Offline

Napisano 02.05.2011 13:27

Cześć.
Mam plugin MoneyMod (Nie mogę go udostępnić bo prywatny)

I gdy skompilowałem go to wyskoczyły takie błędy:
Warning: Tag mismatch on line 209
Warning: Tag mismatch on line 427
Warning: Tag mismatch on line 431
Warning: Tag mismatch on line 444
Warning: Tag mismatch on line 448
Warning: Tag mismatch on line 460
Warning: Tag mismatch on line 464
Warning: Tag mismatch on line 477
Warning: Tag mismatch on line 481
Warning: Tag mismatch on line 494
Warning: Tag mismatch on line 498
Warning: Tag mismatch on line 511
Warning: Tag mismatch on line 515
Warning: Tag mismatch on line 528
Warning: Tag mismatch on line 532
Warning: Tag mismatch on line 687
Warning: Tag mismatch on line 698
Warning: Tag mismatch on line 794
Warning: Tag mismatch on line 798
Warning: Tag mismatch on line 802
Warning: Tag mismatch on line 815
Warning: Tag mismatch on line 820
Warning: Tag mismatch on line 863
Warning: Loose indentation on line 1116
Warning: Tag mismatch on line 1118
Warning: Loose indentation on line 1138
Warning: Tag mismatch on line 1224
Warning: Tag mismatch on line 1235
Warning: Symbol is never used: "Color" on line 1248
Header size:           3764 bytes
Code size:            51612 bytes
Data size:            39064 bytes
Stack/heap size:      16384 bytes; max. usage is unknown, due to recursion
Total requirements:  110824 bytes

29 Warnings.
Done.


W każdej tej linijce jest wiadomość ColorChat
CO zrobić?

Użytkownik Optymalny193 edytował ten post 02.05.2011 13:28


#2 Goliath

    Godlike

  • Przyjaciel

Reputacja: 1227
Godlike

  • Postów:2334
  • GG:
  • Steam:steam
  • Imię:Maciej
  • Lokalizacja:Mońki
Offline

Napisano 02.05.2011 16:03

Prawdopodobnie masz w tym pluginie wgranego tutora. Zmień w funkcji MakeTutor wszystkie Color, na np. Col. Potem zmień to:
enum { RED = 1, BLUE, YELLOW, GREEN }

Na np.:
enum { TUT_RED = 1, TUT_BLUE, TUT_YELLOW, TUT_GREEN }

Na koniec zmień we wszystkich funkcjach przywołujących tutora z RED na TUT_RED i analogicznie zrób z resztą kolorów. Nie powinno wtedy się bugować. Wiem, bo miałem ten sam problem.
  • +
  • -
  • 1

#3 Optymalny193

    Wszechwidzący

  • Autor tematu
  • Zbanowany

Reputacja: 30
Życzliwy

  • Postów:294
  • Imię:Paweł
  • Lokalizacja:Europa
Offline

Napisano 02.05.2011 17:38

Ok
Mam jeszcze jeden problem natomiast taki:
błąd w tej linijce
1138:
	engfunc(EngFunc_SetModel,ent,"models/paczka.mdl");[sma]
1116: [sma]{


A błąd taki:
Warning: Loose indentation on line 1116
Warning: Loose indentation on line 1138


#4 Nenczoks

    Banned

  • Zbanowany

Reputacja: 50
Pomocny

  • Postów:358
  • Lokalizacja:Warszawa
Offline

Napisano 02.05.2011 17:42

Warning: Loose indentation on line 1116Warning: Loose indentation on line 1138


To tylko warningi - one pokazują, że źle jest ułożona klamra/funkcja.


engfunc(EngFunc_SetModel,id,"models/paczka.mdl");


Jest dobrze.

Daj wszystkie wycinki z tym colorchat'em.
A tak Btw. -> engfunc(EngFunc_SetModel,victim,"models/paczka.mdl");
to daj więcej tego kodu.

Użytkownik Nenczoks edytował ten post 02.05.2011 17:42


#5 Optymalny193

    Wszechwidzący

  • Autor tematu
  • Zbanowany

Reputacja: 30
Życzliwy

  • Postów:294
  • Imię:Paweł
  • Lokalizacja:Europa
Offline

Napisano 02.05.2011 17:52

Ok do zamknięcia zrobione.
Nenczoks, przecież wiem że źle ułożone, ale może być spowodowane innym błędem.
CLOSE

@@EDIT
A masz plusa na zachęte :)

Użytkownik Optymalny193 edytował ten post 02.05.2011 17:52


#6 Nenczoks

    Banned

  • Zbanowany

Reputacja: 50
Pomocny

  • Postów:358
  • Lokalizacja:Warszawa
Offline

Napisano 02.05.2011 18:05

Nenczoks, przecież wiem że źle ułożone, ale może być spowodowane innym błędem.


Nie mój drogi. Sprawdzałem u Siebie w kodzie to wiem.




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych