Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z ładowaniem klas


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 bartu233

    Zaawansowany

  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:87
  • Lokalizacja:Słupsk
Offline

Napisano 17.04.2011 19:16

Witam, tak jak w tytule mam problem z ładowaniem klas. Mam DM z 28 klasami i na początku klasy/lvl ładowały się do 10 rund, dzisiaj postanowiłem przenieść bazę do zabijaki żeby połączenie szło "localem" i wgrałem to - [Tutorial] Klasa gdy wejdzie nowy gracz - AMXX.pl: Support AMX Mod X i /klasa ładuje się zazwyczaj po rozgrzewce, czasami troszkę dłużej lecz na lvl to trzeba czekać kilka rund, a niekiedy nawet do końca mapy nie potrafi się załadować. Ma ktoś pomysł na jakąś optymalizację połączenia ? Ew. może gdzieś być jakiś błąd w kodzie ? Ten mój DM to przerobiony 5.9l.

Użytkownik bartu233 edytował ten post 17.04.2011 19:17

  • +
  • -
  • 0

#2 V3ko

    Guru

  • Power User

Reputacja: 82
Zaawansowany

  • Postów:746
  • Lokalizacja:Stopnica
Offline

Napisano 18.04.2011 13:03

Hmm nie wiem, czy to może pomóc, ale ogranicz kod to maksymalnej tzn. usuń zbędne linijki i modyfikacje diablo które są zbędne ;d

/// po co mnie minusujecie? prawde powiedziałem...

Użytkownik V3ko edytował ten post 18.04.2011 14:40

  • +
  • -
  • -1

#3 sebul

    Godlike

  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 18.04.2011 13:10

To jak szybko wczytuje się exp, itp. to zależy od bazy, ale oczywiście optymalizacja kodu związanego z bazą danych przyśpieszyła by trochę te wczytywania. Gdzie masz postawioną bazę? Może kup jakąś lepszą, gdzie są większe ograniczenia.
  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#4 bartu233

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:87
  • Lokalizacja:Słupsk
Offline

Napisano 18.04.2011 15:42

sebul, bazy mam 2 - jedna od Hitme, gdzie nigdy nie miałem problemów z bazą (na poprzednim 11 klasowym DM wszystko ładowało się normalnie), ale że długo się /klasa wczytywała to przeniosłem ją tam gdzie mam serwer, czyli do zabijaki i połączenie leci po "localu", w obu przypadkach jest to samo.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych