Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Crashe serwera bf2


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 fake?

    Nowy

  • Pijawka

Reputacja: 0
zer0.

  • Postów:3
  • Imię:Krzysztof
  • Lokalizacja:3miasto
Offline

Napisano 15.04.2011 19:14

Witam, od kilku dni crashuje mi się serwer bf2.
Poniżej zamieszczam logi.


L 04/15/2011 - 15:20:25: replace() buffer not big enough (136>=127)
L 04/15/2011 - 15:20:25: [AMXX] Displaying debug trace (plugin "statsx.amxx")
L 04/15/2011 - 15:20:25: [AMXX] Run time error 10: native error (native "replace")
L 04/15/2011 - 15:20:25: [AMXX] [0] 22319.attach::client_color (line 259)
L 04/15/2011 - 15:20:25: [AMXX] [1] 22319.attach::cmdHp (line 1048)
L 04/15/2011 - 16:23:16: Start of error session.

Pytanie moje jest, czy po wgraniu na nowo statsx.amxx strace wszystkie staty serwera ?

Proszę o pomoc.
  • +
  • -
  • 0

#2 V3ko

    Guru

  • Power User

Reputacja: 82
Zaawansowany

  • Postów:746
  • Lokalizacja:Stopnica
Offline

Napisano 16.04.2011 08:20

Ludziom będzie łatwiej gdy podasz .sma /// albo te linijki w których jest błąd.
  • +
  • -
  • 0

#3 fake?

    Nowy

  • Autor tematu
  • Pijawka

Reputacja: 0
zer0.

  • Postów:3
  • Imię:Krzysztof
  • Lokalizacja:3miasto
Offline

Napisano 16.04.2011 12:13

statsx sma

linijka 259 to
while(replace(msg,127,"!W","^x01")){}

1048
client_color( id, g_sBuffer)


dodam tylko, że dzisiaj był kolejny crash
o to logi.
[AMXX] Displaying debug trace (plugin "bf2rank.amxx")
[AMXX] Run time error 10: native error (native "nvault_set")
[AMXX] [0] save.inl::vault_server_save (line 280)
[AMXX] [1] save.inl::server_save (line 144)
[AMXX] [2] forwards.inl::plugin_end (line 108)

Dodano 18 kwiecień 2011 - 22:27:
Pomoze ktoś?

Dodano 21 kwiecień 2011 - 13:58:
podbijam
  • +
  • -
  • 0

#4 speedkill

    Godlike

  • Przyjaciel

Reputacja: 1570
Godlike

  • Postów:2733
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Prudnik
Offline

Napisano 21.04.2011 14:51

Pokaż plik modules.ini
  • +
  • -
  • 0

If you can dream it, you can do it.


#5 niebieski12

    Pomocny

  • Zbanowany

Reputacja: -6
Mniej niż zer0.

  • Postów:48
  • Imię:Kuba
  • Lokalizacja:Polska
Offline

Napisano 22.04.2011 07:49

tez mialem kiedys taki blad, sprobuj reinstalowac amxa; mi to pomoglo

#6 fake?

    Nowy

  • Autor tematu
  • Pijawka

Reputacja: 0
zer0.

  • Postów:3
  • Imię:Krzysztof
  • Lokalizacja:3miasto
Offline

Napisano 23.04.2011 23:13

;;;

; To enable a module, remove the semi-colon (<img src='http://img.amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' /> in front of its name.

; If it's not here, simply add it its name, one per line.

; You don't need to write the _amxx part or the file extension.

;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;; SQL Modules usually need to be enabled manually ;;

;; You can have any number on at a time.  Use      ;;

;;  amx_sql_type in sql.cfg to specify the default ;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



mysql

sqlite



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;; Put third party modules below here.              ;;

;; You can just list their names, without the _amxx ;;

;;  or file extension.                              ;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;







;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;; These modules will be auto-detected and loaded   ;;

;;  as needed.  You do not need to enable them here ;;

;;  unless you have problems.                       ;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



fun

engine

;fakemeta

geoip

sockets

;regex

;nvault

cstrike

csx

hamsandwich


  • +
  • -
  • 0

#7 Kaster

    Wszechwidzący

  • Użytkownik

Reputacja: 32
Życzliwy

  • Postów:268
  • GG:
  • Imię:Kamil
  • Lokalizacja:Gliwice
Offline

Napisano 24.04.2011 09:50

Usuń srednik ";" przed modułem nVault a na wszelki wypadek też przed fakemeta oraz regex. Ja mam zawsze po włączane wszystkie moduły.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych