Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Błędy podczas kompilacji CodMod'a.Pełno błędów niewiadomego pochodzenia :)


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 Svizz

    Zaawansowany

  • Użytkownik

Reputacja: 33
Życzliwy

  • Postów:142
  • GG:
  • Imię:Svizz
  • Lokalizacja:Polska :)
Offline

Napisano 12.04.2011 07:26

Witam. Jutro mija mi termin oddania CodMod'a, którego edytowałem. Już jest praktycznie gotowy, tylko robiłem drobne poprawki, coś poprzestawiałem i oto wynik:
QTM_CodMod.sma(556) : warning 217: loose indentation
QTM_CodMod.sma(557) : warning 217: loose indentation
QTM_CodMod.sma(558) : warning 217: loose indentation
QTM_CodMod.sma(582) : error 017: undefined symbol "WczytajDane"
QTM_CodMod.sma(587) : error 017: undefined symbol "WybierzKlase"
QTM_CodMod.sma(755) : error 017: undefined symbol "ResetujPunkty"
QTM_CodMod.sma(760) : error 017: undefined symbol "PrzydzielPunkty"
QTM_CodMod.sma(766) : error 017: undefined symbol "ZmienUbranie"
QTM_CodMod.sma(892) : error 017: undefined symbol "UTIL_In_FOV"
QTM_CodMod.sma(1011) : error 017: undefined symbol "Display_Fade"
QTM_CodMod.sma(1021) : error 017: undefined symbol "SprawdzPoziom"
QTM_CodMod.sma(1030) : error 017: undefined symbol "parachute_reset"
QTM_CodMod.sma(1051) : error 017: undefined symbol "set_user_clip"
QTM_CodMod.sma(1059) : error 017: undefined symbol "DajPrzedmiot"
QTM_CodMod.sma(1059) : error 088: number of arguments does not match definition
QTM_CodMod.sma(1071) : error 017: undefined symbol "SprawdzPoziom"
QTM_CodMod.sma(1079) : warning 217: loose indentation
QTM_CodMod.sma(1079) : error 029: invalid expression, assumed zero
QTM_CodMod.sma(1079) : error 004: function "client_connect" is not implemented
QTM_CodMod.sma(1106) : error 017: undefined symbol "UsunPrzedmiot"
QTM_CodMod.sma(1109) : error 029: invalid expression, assumed zero
QTM_CodMod.sma(1109) : error 004: function "client_disconnect" is not implemented
QTM_CodMod.sma(1117) : error 017: undefined symbol "ZapiszDane"
QTM_CodMod.sma(1118) : error 017: undefined symbol "UsunPrzedmiot"
QTM_CodMod.sma(1119) : error 017: undefined symbol "parachute_reset"
QTM_CodMod.sma(1122) : error 029: invalid expression, assumed zero
QTM_CodMod.sma(1122) : error 017: undefined symbol "RozbrajaBombe"
QTM_CodMod.sma(1123) : warning 217: loose indentation
QTM_CodMod.sma(1126) : warning 217: loose indentation
QTM_CodMod.sma(1126) : error 029: invalid expression, assumed zero
QTM_CodMod.sma(1126) : error 017: undefined symbol "BombaPodlozona"
QTM_CodMod.sma(1149) : error 017: undefined symbol "SprawdzPoziom"

Compilation aborted.
26 Errors.

O co w tym może chodzić... Pomożecie? Na czym może polegać błąd? Sma nie udostępnie, bo autorskie. Chodzi o starego CodMod'a.
  • +
  • -
  • 0

#2 kasza

    Godlike

  • Przyjaciel

Reputacja: 887
Czempion

  • Postów:4102
  • GG:
  • Steam:steam
  • Imię:Imię
  • Lokalizacja:Lokalizacja
Offline

Napisano 12.04.2011 07:32

Bez sma raczej nikt Ci tu za wiele nie pomoże.
  • +
  • -
  • 0

Skillownia.com

 

 #3 [UWC3NG] Skillownia.com - 213.189.52.253:27301

 


#3 Svizz

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 33
Życzliwy

  • Postów:142
  • GG:
  • Imię:Svizz
  • Lokalizacja:Polska :)
Offline

Napisano 12.04.2011 07:38

Chce tylko wiedzieć, na czym ten błąd może polegać :)
  • +
  • -
  • 0

#4 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6034
Godlike

  • Postów:10832
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 12.04.2011 08:56

klamry sprawdz
  • +
  • -
  • 1

#5 Svizz

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 33
Życzliwy

  • Postów:142
  • GG:
  • Imię:Svizz
  • Lokalizacja:Polska :)
Offline

Napisano 12.04.2011 09:04

Fakt, jeden klamry brakowalo... Wszystko smiga, kompiluje sie, ale w grze nie pokazuje HUD'a, mod ogolnie dziala w polowie, tak jakby poprostu nie czytało tej połowy. Cala konsole spamuje mi cos takiego (wlaczylem debug):
L 04/12/2011 - 10:01:26: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 04/12/2011 - 10:01:26: [AMXX] Run time error 10: native error (native "get_pcvar_float")
L 04/12/2011 - 10:01:26: [AMXX]    [0] QTM_CodMod_114253.sma::client_PreThink (line 2302)
L 04/12/2011 - 10:01:26: Invalid CVAR pointer

i to:

L 04/12/2011 - 10:01:26: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 04/12/2011 - 10:01:26: [AMXX] Run time error 10: native error (native "ShowSyncHudMsg")
L 04/12/2011 - 10:01:26: [AMXX]    [0] QTM_CodMod_114253.sma::PokazInformacje (line 2095)
L 04/12/2011 - 10:01:26: HudSyncObject -1 is invalid
)

Tylko tymi 2 błędami spamuje. Co to?
  • +
  • -
  • 0

#6 Dalinor

    Zaawansowany

  • Użytkownik

Reputacja: 28
Życzliwy

  • Postów:77
  • GG:
  • Lokalizacja:Rabka :)
Offline

Napisano 12.04.2011 09:42

Pokaż te 2 linie.

(line 2095)

(line 2302)
  • +
  • -
  • 0

#7 Rafal_94

    Wszechpomocny

  • Użytkownik

Reputacja: 45
Pomocny

  • Postów:383
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Woźniki
Offline

Napisano 12.04.2011 13:24

nie ma w regulaminie obowiązku dawania sma?
jak autorski to czemu edytujesz go - nie powinieneś ty mieć sma

skoro autorskie sma niby ze ty zrobiles to czemu nas sie pytasz? ;]
  • +
  • -
  • 0

#8 Svizz

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 33
Życzliwy

  • Postów:142
  • GG:
  • Imię:Svizz
  • Lokalizacja:Polska :)
Offline

Napisano 12.04.2011 15:15

Te linijki, z ktorych pochodza bledy sa pod komentarzem:
{		
		set_hudmessage(255, 255, 255, 0.6, -1.0, 0, 0.0, 0.3, 0.0, 0.0, 2);
		ShowSyncHudMsg(id, SyncHudObj, "Klasa : %s^nDoswiadczenie : %i / %i^nPoziom : %i^nPrzedmiot : %s", nazwy_klas[klasa_gracza[target]], doswiadczenie_gracza[target], doswiadczenie_poziomu[poziom_gracza[target]], poziom_gracza[target], nazwy_przedmiotow[informacje_przedmiotu_gracza[target][0]]);
		
		return PLUGIN_CONTINUE;
	}
	set_hudmessage(0, 0, 255, 0.02, 0.23, 0, 0.0, 0.3, 0.0, 0.0);
// ponizej jest ta linijka az do konca
	ShowSyncHudMsg(id, SyncHudObj, "[Klasa : %s]^n[Doswiadczenie : %i / %i]^n[Poziom : %i]^n[Przedmiot : %s]", nazwy_klas[klasa_gracza[id]], doswiadczenie_gracza[id], doswiadczenie_poziomu[poziom_gracza[id]], poziom_gracza[id], nazwy_przedmiotow[informacje_przedmiotu_gracza[id][0]]);
// o wlasnie dotad
	return PLUGIN_CONTINUE;
}

A to ten fragment z linijka 2302:
public client_PreThink(id)
{
	//parachute.mdl animation information
	//0 - deploy - 84 frames
	//1 - idle - 39 frames
	//2 - detach - 29 frames

	if (!is_user_alive(id)) return
// to jest ta linijka... tak jakby serwer nie czytal funkcji get_pcvar_float...
	new Float:fallspeed = get_pcvar_float(SpadochronSpadanie) * -1.0
// koniec
	new Float:frame

Użytkownik Svizz edytował ten post 12.04.2011 15:18

  • +
  • -
  • 0

#9 Dalinor

    Zaawansowany

  • Użytkownik

Reputacja: 28
Życzliwy

  • Postów:77
  • GG:
  • Lokalizacja:Rabka :)
Offline

Napisano 13.04.2011 11:52

public client_PreThink(id)
{
new cvarr = get_pcvar_float(SpadochronSpadanie)
//parachute.mdl animation information
//0 - deploy - 84 frames
//1 - idle - 39 frames
//2 - detach - 29 frames

if (!is_user_alive(id)) return
// to jest ta linijka... tak jakby serwer nie czytal funkcji get_pcvar_float...
new Float:fallspeed = cvarr*-1.0
// koniec
new Float:frame



Nie wiem jakie jest oznaczenie na ujemną liczbę, bo to prawdopodobnie przez to może być błąd(, ale nie jestem pewien !)
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych