Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

problem z xredirect - nie dziala /servernie działa /server


  • Zamknięty Temat jest zamknięty
Brak odpowiedzi do tego tematu

#1 freetu

    Wszechwiedzący

  • Power User

Reputacja: 71
Pomocny

  • Postów:504
  • Lokalizacja:Kwidzyn
Offline

Napisano 10.04.2011 19:41

Witam,
Mam problem z pluginem xredirect.
Sądzę że plugin jest poprawnie skonfigurowany, gdyż w grze amx pokazuje że plugin działa:
Dołączona grafika
i faktycznie niby działa ale jednak nie poprawnie?
gdy wpisuję komendę /server na różne kombinacje (/servery /serwer /serwery) nic się nie dzeieje, nie pokazuje się menu. Gdy jest full jeden z serwerów nie kieruje graczy na żaden z innych które są wpisane w config. JEDNAK, gdy wpiszę komendę /retry wypluwa mi że nie mogę użyć tej komendy bla bla tak samo jest gdy wpiszę /follow
Czyli to dowodzi że plugin jest zainstalowany...

Używam wersji

Aktualna Stabilna wersja: 1.0.3.3

Nie pozostaje nic innego jak podać config tego wszystkiego:
dam przykład cfg na jednym serwerze o ip aa.zz.cc.xx:vvvv, bo na pozostałych serwerach cvar "redirect_external_address" zawiera ip serwera na którym jest wgrany plugin
amxx.cfg cvary

//redirect serwer
redirect_active "1" 
redirect_auto "1"
redirect_manual "3"
redirect_follow "1"
redirect_external_address "aa.zz.cc.xx:vvvv"
redirect_check_method "2"
redirect_announce "40"
redirect_announce_mode "3"
redirect_announce_alivepos_x "-1.0"
redirect_announce_alivepos_y "0.01"
redirect_announce_deadpos_x "-1.0"
redirect_announce_deadpos_y "0.01"
redirect_show "1"
redirect_adminslots "1"
redirect_maxadmins "0"
redirect_retry "1"
redirect_hidedown "2"
redirect_localslots "0"
redirect_countbots "1"
natomiast plik serverlist.ini wypełniony jest tak:
[TP+BF2]
address=aa.zz.cc.xx:vvvv
port=vvvv
cmdbackup=3
noauto=0
nomanual=0
nodisplay=0
adminslots=2

[4fun]
address=aa.zz.cc.xx:vvvv
port=vvvv
cmdbackup=3
noauto=0
nomanual=0
nodisplay=0
adminslots=1

[CSDM]
address=aa.zz.cc.xx:vvvv
port=vvvv
cmdbackup=3
noauto=0
nomanual=0
nodisplay=0
adminslots=1

Dodam, że jak konsolą przekieruje siebie na inny serwer komendą: redirect_user pokazuje że serwer jest pełny jak to jest nie prawda:
Dołączona grafika

Oryginały dałem w załącznikach

ufff chyba wszystko opisałem :P
czekam na pomoc

PS: zapomniałem napisać o error logach:
w error logach nie mam nick.
W logach serwera:
L 04/10/2011 - 20:32:13: [xredirect.amxx] BLAD: Wlasny serwer nie zsotal poprawnie rozpoznany, plugin nie bedzie dzialal prawidowo
L 04/10/2011 - 20:32:13: [xredirect.amxx] Not auto-redirecting <Swistak> (1), automode: 1, current players/max: 1/21 - mam mnóstwo takich wiadomości

Dodano 11 kwiecień 2011 - 20:38:
można zamknąć, poradziłem sobie ;)

Załączone pliki


Użytkownik freetu edytował ten post 10.04.2011 19:55

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych