Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Logi w latarce Diablo.


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 GoldeN

    Wszechmogący

  • Zbanowany

Reputacja: 69
Pomocny

  • Postów:676
  • Imię:Kamil
  • Lokalizacja:DG
Offline

Napisano 01.04.2011 15:43

L 04/01/2011 - 16:30:02: [AMXX] Displaying debug trace (plugin "dbmod_5.9l.amxx")
L 04/01/2011 - 16:30:02: [AMXX] Run time error 4: index out of bounds 
L 04/01/2011 - 16:30:02: [AMXX]    [0] dbmod_5.9l.sma::client_PreThink (line 2403)


Linia 2403:

		new index1, bodypart1
get_user_aiming(id,index1,bodypart1) // 2403
if ((get_user_team(id)!=get_user_team(index1)) && (index1!=0) && player_class[index1] != Cain)
{
if ((index1!=54) && (is_user_connected(index1))) set_user_rendering(index1,kRenderFxGlowShell,flashlight_r,flashlight_g,flashlight_b,kRenderNormal,4)
remove_task(TASK_FLASH_LIGHT+index1);
set_task(7.5, "un_rander",TASK_FLASH_LIGHT+index1)
//set_task(15.0,"un_rander",TASK_NAME,index1)
}


#2 sebul

    Godlike

  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 01.04.2011 16:03

Nie będę specjalnie pisał jak to zrobić, bo lepiej zrobić to co niżej w poście
[Tutorial] Problem z naświetlaniem Ninji? Znaczek widoczności! - AMXX.pl: Support AMX Mod X
tylko zamiast
get_user_aiming(id, index1, bodypart1);
if(is_user_alive(index1)) {
if(index1 != 54 && get_user_team(id) != get_user_team(index1)) {
naswietlony[index1] = 1;
set_renderchange(index1);
Display_Icon(index1, ICON_FLASH, "dmg_bio", 200, 100, 0);
if(task_exists(index1+TASK_FLASH_LIGHT)) remove_task(index1+TASK_FLASH_LIGHT);
set_task(7.5, "un_rander", index1+TASK_FLASH_LIGHT);
}
}

daj
get_user_aiming(id, index1, bodypart1);
if(is_user_alive(index1)) {
if(index1 != 54 && get_user_team(id) != get_user_team(index1) && player_class[index1] != Cain) {
naswietlony[index1] = 1;
set_renderchange(index1);
Display_Icon(index1, ICON_FLASH, "dmg_bio", 200, 100, 0);
if(task_exists(index1+TASK_FLASH_LIGHT)) remove_task(index1+TASK_FLASH_LIGHT);
set_task(7.5, "un_rander", index1+TASK_FLASH_LIGHT);
}
}

  • +
  • -
  • 1
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#3 GoldeN

    Wszechmogący

  • Autor tematu
  • Zbanowany

Reputacja: 69
Pomocny

  • Postów:676
  • Imię:Kamil
  • Lokalizacja:DG
Offline

Napisano 01.04.2011 16:17

Konsola servera w czasie crasha:

FATAL ERROR (shutting down): New message started when msg '97' has not been sent yet
email debug.log to linux@valvesoftware.com
pią, 1 kwi 2011, 17:19:31 CEST: Server restart in 10 seconds


O co chodzi?

#4 sebul

    Godlike

  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 01.04.2011 16:27

A jakieś błędy z logów pluginu?
  • +
  • -
  • 1
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#5 GoldeN

    Wszechmogący

  • Autor tematu
  • Zbanowany

Reputacja: 69
Pomocny

  • Postów:676
  • Imię:Kamil
  • Lokalizacja:DG
Offline

Napisano 01.04.2011 20:38

W tym problem, że nic. Jedynie ten jeden w pierwszym poście (No i kilka innych, które mam już od miesięcy). Ale zmieniłem na to co mi dałeś i nadal Crashuje. ; / Może to mój hosting ma jakieś problemy?


@Edit:

Naprawiłem, messag'u nie zakończyłem. xD

Użytkownik GoldeN edytował ten post 02.04.2011 11:12





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych