Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Crash serwa


  • Zamknięty Temat jest zamknięty
Brak odpowiedzi do tego tematu

#1 BoB0_

    Wszechpomocny

  • Użytkownik

Reputacja: 38
Życzliwy

  • Postów:365
  • GG:
  • Lokalizacja:Przemyśl
Offline

Napisano 08.03.2011 19:28

Witam.

Otóż mam problem z tym że serwer codziennie wyłącza mi się po kilka razy. Próbowałem to naprawić sprawdzałem logi ale były czyste. Wgrałem wiec HLShield 2.6 nowe dproto oraz binarki. Niestety dalej to samo. Tak więc zrobiłem reinstall plikow tak samo z hlshield itp. Wynik ten sam. W końcu zrobiłem reinstall całego serwera ale nadal to samo. Do nowego serwera dodałem HlShield 2.6 dproto 0.9.7 oraz binarki 5006. Zgodnie z poleceniami admina hostingu.

Serwer przeinstalowałem ponieważ po dłuższym czasie udało mi się znależć przyczyne crashów. Otóż była ona tylko w konsoli na stronie hostingu a była tylko przez ok 30 sekund.

Oto ten błąd :
./hlds_run: line 329: 6244 Naruszenie ochrony pamięci $HL_CMD

Jeszcze przed reinstallem serwa zmieniłem tylko metamoda i to samo było. Po reinstalce nie zmieniałem ponieważ hosting zapewniał mnie że jest nowy metamod. Mimo tego co zrobiłem serwer nadal się wyłączał. Crashe były rzadsze ale serwer po nich nie mógł wstać.

Potem miałem takie błędy w logach :
03/07/2011 - 20:27:33: [META] dll: Loaded plugin 'dproto_EF': dproto_EF v0.9.87 2010-10-26, Crock
L 03/07/2011 - 20:27:33: [XDSOPT]: Version 0.1 Linux
L 03/07/2011 - 20:27:33: [XDSOPT]: Sorry, this version of engine doesn't supported
L 03/07/2011 - 20:27:33: [XDSOPT]: PerformPatching() failed.
L 03/07/2011 - 20:27:33: [META] WARNING: dll: Failed attach plugin 'xdsopt': Error from Meta_Attach(): 0
L 03/07/2011 - 20:27:33: [META] WARNING: dll: Failed to attach plugin 'xdsopt'
L 03/07/2011 - 20:27:33: [META] WARNING: dll: Failed to load plugin 'xds_opt.so'
L 03/07/2011 - 20:27:33: [META] WARNING: dll: Not loading plugin 'Fun'; already loaded (status=running)
L 03/07/2011 - 20:27:33: [META] WARNING: dll: Failed to load plugin 'fun_amxx_i386.so'
L 03/07/2011 - 20:27:33: [META] WARNING: dll: Not loading plugin 'Engine'; already loaded (status=running)
L 03/07/2011 - 20:27:33: [META] WARNING: dll: Failed to load plugin 'engine_amxx_i386.so'
L 03/07/2011 - 20:27:33: [META] WARNING: dll: Not loading plugin 'FakeMeta'; already loaded (status=running)
L 03/07/2011 - 20:27:33: [META] WARNING: dll: Failed to load plugin 'fakemeta_amxx_i386.so'
L 03/07/2011 - 20:27:33: [META] WARNING: dll: Not loading plugin 'Ham Sandwich'; already loaded (status=running)
L 03/07/2011 - 20:27:33: [META] WARNING: dll: Failed to load plugin 'hamsandwich_amxx_i386.so'
L 03/07/2011 - 20:27:33: [META] dll: Finished loading 2 plugins
L 03/07/2011 - 20:27:33: Log file closed

Administrator hostingu kazał usunać wpisy z modules.ini ponieważ nowy metamod juz sam w sobie laduje moduły. Zrobiłem tak jak mowił i proszę co mi wyskoczyło w logach : patrz post niżej

Dodano 08 marzec 2011 - 19:29:
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:09: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/08/2011 - 13:56:09: [AMXX] Run time error 7: stack low 
L 03/08/2011 - 13:56:10: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")

I to jest niewielka częsc tego, ponieważ cały log zajmował aż 6,8 MB.

Na posumowaniu serwer wyłączył się ponownie i znowu udało mi się wyłapać błąd w konsoli na stronie. Oto on:
./hlds_run: line 321: 15779 Naruszenie ochrony pamięci $HL_CMD
WARNING: msg overflowed for SNAJPER11
SZ_GetSpace: overflow on Client Datagram
L 03/08/2011 - 18:51:50: [AMXX] [0] QTM_CodMod.sma::CurWeapon (line 821)
L 03/08/2011 - 18:51:50: [AMXX] Run time error 3: stack error 
L 03/08/2011 - 18:51:50: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
Reason: Client sent 'drop'

A administrator hostingu podsumował że to wina COD'a który ma błędy w kodzie. Dlatego też daję wam w załączniku sma mojego coda proszę o pomoc bo przez te crashe tracę wielu graczy. Chciałem tylko dodać ze na jednej stronie jakis kolega powiedzial ze tez mial taki blad i musial wymieniac polowe plikow z serwera i teraz mu dziala niestety nie udalo mi sie wyciagnąć z niego jakie to pliki.

Załączone pliki


Użytkownik BoB0_ edytował ten post 08.03.2011 19:31

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych