Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

- - - - -

Steam lub sXe


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
35 odpowiedzi w tym temacie

#21 guldur

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
Offline

Napisano 29.04.2008 12:26

Dobra, gdzie indziej mi pomogli. Juz dziala.
  • +
  • -
  • 0

#22 bordeux

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:1
Offline

Napisano 07.07.2008 07:31

A ma ktoś może kod źródłowy tego? *.sma?
  • +
  • -
  • 0

#23 jose

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:Częstochowa
Offline

Napisano 10.07.2008 20:00

A po co?
Nie chodzi Ci bez?

Jeszcze ktoś uzna go za swojego...
  • +
  • -
  • 0

#24 Oleczek

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • GG:
Offline

Napisano 15.07.2008 18:17

Pojawia się tylko cały czas Sxe i strona downloadu ale nie wyrzuca nikogo. Dlaczego?
  • +
  • -
  • 0

#25 bicek

    Ja tu tylko sprzątam.

  • Zbanowany

Reputacja: 914
Master

  • Postów:796
  • Lokalizacja:Wieluń
Offline

Napisano 20.07.2008 03:00

Oleczek, a zmienia nicki graczy bez sXe?

Pojawia się tylko cały czas Sxe i strona downloadu...

gdzie się pojawia? można prości screena?

#26 eXine

    Zaawansowany

  • Użytkownik

Reputacja: 4
Nowy

  • Postów:127
  • Lokalizacja:Wrocław
Offline

Napisano 04.09.2008 14:12

Mozna dostac *.sma tego pluginu? Bo tak bym chociaz poprawil, zeby dzialalo na serwerach nie czytajacych steamid
  • +
  • -
  • 0

#27 Gość__*

  • Autor tematu
  • Gość

Reputacja: 0

Offline

Napisano 04.09.2008 14:42

Mozna dostac *.sma tego pluginu? Bo tak bym chociaz poprawil, zeby dzialalo na serwerach nie czytajacych steamid

Jak chcesz *.sma to będzie ciężko ( pisz na PW q2 ) :)

#28 choyrack

    Wszechpomocny

  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:369
  • GG:
  • Lokalizacja:Wrocław
Offline

Napisano 04.09.2008 15:35

Ja mam coś takiego :-)
Chyba powinno Cie to zadowolić.

#include <amxmodx>
#include <amxmisc>
#include <engine>
#include <fun>
new offclient[33]
new kick[33]

#define REASON "Wymagany Steam lub sXe-I"

public plugin_init()
{
	register_plugin("1", "1", "1")
	register_cvar("amx_protect", "1")
	register_cvar("amx_tag", "[NO-sXe-I]")
	register_cvar("amx_timekick", "20")
	register_cvar("amx_imsteam", "0")
}
public client_putinserver(id)
        set_task(1.5,"entered",id) 

public entered(id)
{
    	new name[32]
    	get_user_name(id, name, 31)
	return check_tag(id, name)
}
check_tag(id, name[])
{	
	new AUTHID[30], tag[24]
	get_user_authid(id, AUTHID, 29)
	get_cvar_string("amx_tag",tag,23)
	
	if(equal(AUTHID, "VALVE_ID_LAN"))
		{
		if((!is_user_admin(id)) && (containi(name, tag)>=0))
			{
			offclient[id] = 1
			delay_kick(id)
        		}
		}
    	return PLUGIN_CONTINUE
}
public delay_kick(id){
	if(offclient[id] >= 1){
		if(kick[id] <= 0)
			{
			new userid=get_user_userid(id)
     			new KICKTIME = get_cvar_num("amx_timekick")
			set_task(float(KICKTIME), "kick_now", userid)
			}
		show_motd(id,"/addons/amxmodx/plugins/help.txt","Help")
		set_task(4.0,"delay_kick",id)
		kick[id] = 1
		new clip, ammo, weapon = get_user_weapon(id, clip, ammo) 				
		if(weapon==CSW_P228 || weapon==CSW_SCOUT || weapon==CSW_HEGRENADE || weapon==CSW_XM1014 || weapon==CSW_C4 || weapon==CSW_MAC10 || weapon==CSW_AUG || weapon==CSW_SMOKEGRENADE || weapon==CSW_ELITE || weapon==CSW_FIVESEVEN || weapon==CSW_UMP45 || weapon==CSW_SG550) 
			{
			strip_user_weapons(id)
			}		
		if(weapon==CSW_GALI || weapon==CSW_GALIL || weapon==CSW_FAMAS || weapon==CSW_USP || weapon==CSW_GLOCK18 || weapon==CSW_AWP || weapon==CSW_MP5NAVY || weapon==CSW_M249 || weapon==CSW_M3 || weapon==CSW_M4A1 || weapon==CSW_TMP || weapon==CSW_G3SG1 || weapon==CSW_FLASHBANG || weapon==CSW_DEAGLE || weapon==CSW_SG552 || weapon==CSW_AK47 || weapon==CSW_KNIFE || weapon==CSW_P90) 
			{
			strip_user_weapons(id)
			}
		return PLUGIN_CONTINUE
		}
	return PLUGIN_CONTINUE
}
public client_infochanged(id)
{
        new name[32]
        get_user_info(id, "name", name, 31)
	return check_tag(id, name)
}
public client_connect(id)
{ 
	kick[id] = 0
	offclient[id] = 0
}
public client_disconnect(id) {
	remove_task(id)
	return PLUGIN_CONTINUE
}
public kick_now(userid)
{
	server_cmd("kick #%d %s", userid, REASON)
}

  • +
  • -
  • 0

#29 eXine

    Zaawansowany

  • Użytkownik

Reputacja: 4
Nowy

  • Postów:127
  • Lokalizacja:Wrocław
Offline

Napisano 04.09.2008 15:51

choyrack, dzięki ale to nie jest dokladnie to czego szukam :] Pasuje mi plug z tego tematu wlasnie, no nic napisalem do q2 czekam na odpowiedz :P
  • +
  • -
  • 0

#30 chlebek74

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:1
Offline

Napisano 16.09.2008 20:16

witajcie mam taki problem z tym pluginem
jak ktoś wchodzi na serwer przez steam
to go wywala i daje :LAN servers are restricted to local clients
a w server.cfg mam usunięte sv_lan
:help:
ps binarki podmieniłem
na te czytające steamid
  • +
  • -
  • 0

#31 choyrack

    Wszechpomocny

  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:369
  • GG:
  • Lokalizacja:Wrocław
Offline

Napisano 17.09.2008 01:33

chlebek74, w server.cfg daj sv_lan 1
  • +
  • -
  • 0

#32 Tifa

    Zaawansowany

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:77
  • GG:
  • Lokalizacja:Szczecin
Offline

Napisano 03.09.2009 00:09

Przepraszam za Refresh
Ale mam Pytanko:
Czy orientuje się ktoś czy po Aktualizacjach Valve to nadal działa??
Tj na serwerze z dproto 0.2.5
  • +
  • -
  • 0

#33 pawlik

    Wszechwiedzący

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:579
  • Steam:steam
  • Lokalizacja:Podkarpacie
Offline

Napisano 04.09.2009 16:30

j/w
Mam to samo pytanie, bo coś nie chce mi działać :/
  • +
  • -
  • 0

#34 Grycuk

    Zaawansowany

  • Użytkownik

Reputacja: 16
Początkujący

  • Postów:113
  • GG:
  • Steam:steam
  • Imię:Kamil
  • Lokalizacja:Minsk Mazowiecki
Offline

Napisano 05.09.2009 09:37

z tego co sie orientuje to ten plugin dziala na starszych wersjach sxe nie na najnowszych
  • +
  • -
  • 0

#35 seba76

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:56
  • GG:
  • Lokalizacja:Katowice
Offline

Napisano 18.11.2009 21:41

Dobra, gdzie indziej mi pomogli. Juz dziala.


No wez sie nie wygłupiaj, napisz jak dać sobie z tym rade. To jest forum, nie GG.
  • +
  • -
  • 0

#36 paulin

    Pomocny

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:56
  • Lokalizacja:warsaw
Offline

Napisano 26.01.2010 17:52

No też by mi się przydała jakaś dobra wersja... ponieważ jest problem z działaniem sxe z nowym csem u klientow jakies bledy ...
  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika
Dołączona grafika
Dołączona grafika




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych