Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Nie działa hasło admina... można sobię wchodzić.


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 Aezakmi

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:38
Offline

Napisano 27.11.2008 17:57

Witam. Mój problem polega na tym, że admin ma przydzieloną flagę "a", która odpowada za to, że jeżeli gracz wbija pod danym namem bez podania hasła, to nie może się z nim połączyć. U mnie nieważne czy poda się hasło, czy nie zawsze można wbić na serwer. Pisze tylko, że invalid password no i dalej się łączy. W pliku amxx.cfg mam włączone amx_mode na 1. Instalowałem inne amxmodx i to samo. Jak to naprawić? Oto mój plik users.ini:
; Users configuration file
; File location: $moddir/addons/amxmodx/configs/users.ini

; Line starting with ; is a comment

; Access flags:
; a - immunity (can't be kicked/baned/slayed/slaped and affected by other commmands)
; b - reservation (can join on reserved slots)
; c - amx_kick command
; d - amx_ban and amx_unban commands
; e - amx_slay and amx_slap commands
; f - amx_map command
; g - amx_cvar command (not all cvars will be available)
; h - amx_cfg command
; i - amx_chat and other chat commands
; j - amx_vote and other vote commands
; k - access to sv_password cvar (by amx_cvar command)
; l - access to amx_rcon command and rcon_password cvar (by amx_cvar command)
; m - custom level A (for additional plugins)
; n - custom level B
; o - custom level C
; p - custom level D
; q - custom level E
; r - custom level F
; s - custom level G
; t - custom level H
; u - menu access
; z - user (no admin)

; Account flags:
; a - disconnect player on invalid password
; b - clan tag
; c - this is steamid/wonid
; d - this is ip
; e - password is not checked (only name/ip/steamid needed)

; Password:
; Add to your autoexec.cfg: setinfo _pw ""
; Change _pw to the value of amx_password_field

; Format of admin account:
;

; Examples of admin accounts:
"MOJNAME" "HASLO" "abcefghijklmnopqrstu" "a"
  • +
  • -
  • 0

#2 MafiaDL

    Naj-Najstarszy Moderator

  • Przyjaciel

Reputacja: 554
Wszechwiedzący

  • Postów:3492
  • GG:
  • Imię:Łukasz
  • Lokalizacja:Warsaw
Offline

Napisano 27.11.2008 19:05

moze zle haslo wpisujesz przed wejsciem na serwa

setinfo _pw "haslo"

pokaz amxx.cfg
  • +
  • -
  • 0

#3 Aezakmi

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:38
Offline

Napisano 27.11.2008 20:06

Nie zrozumiałeś mnie. Ja nie chcę wpisywać hasła. Sprawdzam, czy da się wejść na nick administratora bez hasła. No i niestety się da (co może być przyczyną podszywania się i psucia opinii)
mój amxx.cfg
// AMX Configuration File
echo Executing AMX Mod X Configuration File

// Default access for all non admin players (see users.ini for access details)
amx_default_access "z"

// Name of setinfo which should store a password on a client (you should change this)
// (Example: setinfo _pw "password")
amx_password_field "_pw"

// Mode of logging to a server
// 0 - disable logging, players won't be checked (and access won't be set)
// 1 - normal mode which obey flags set in accounts
// 2 - kick all players not on list
amx_mode 1

// Show admins activity
// 0 - disabled
// 1 - show without admin name
// 2 - show with name
amx_show_activity 2

// Frequency in seconds and text of scrolling message
amx_scrollmsg "Welcome to %hostname% -- This server is using AMX Mod X" 600

// Center typed colored messages (last parameter is a color in RRRGGGBBB format)
amx_imessage "Welcome to %hostname%" "000255100"
amx_imessage "This server is using AMX Mod XnVisit http://www.amxmodx.org" "000100255"

// Frequency in seconds of colored messages
amx_freq_imessage 180

// Set in seconds how fast players can chat (chat-flood protection)
amx_flood_time 0.75

// Amount of reserved slots, amx_hideslots must be 1 to use this cvar (for more details see comments in plugin source)
amx_reservation 0

// If you set this to 1, you can hide slots on your server
amx_hideslots 0

// Displaying of time remaining
// a - display white text on bottom
// b - use voice
// c - don't add "remaining" (only in voice)
// d - don't add "hours/minutes/seconds" (only in voice)
// e - show/speak if current time is less than this set in parameter
amx_time_display "ab 1200" "ab 600" "ab 300" "ab 180" "ab 60" "bcde 11"

// Announce "say thetime" and "say timeleft" with voice
amx_time_voice 1

// Minimum delay in seconds between two voting sessions
amx_vote_delay 10

// How long voting session goes on
amx_vote_time 10

// Display who votes for what option
amx_vote_answers 1

// Some ratios for voting success
amx_votekick_ratio 0.40
amx_voteban_ratio 0.40
amx_votemap_ratio 0.40
amx_vote_ratio 0.02

// Max. time to which map can be extended
amx_extendmap_max 90

// Step for each extending
amx_extendmap_step 15

// Rank mode
// 0 - by nick
// 1 - by authid
// 2 - by ip
csstats_rank 1

// Max size of the stats file
csstats_maxsize 3500

// Duration of HUD-statistics
amx_statsx_duration 12.0

// HUD-statistics display limit relative round freeze end
// Negative time will clear the HUD-statstics before the round freeze time has ended
amx_statsx_freeze -2.0

//If you set this to 0, clients cannot chose their language
amx_client_languages 1

// Plugin Debug mode
// 0 - No debugging (garbage line numbers)
// 1 - Plugins with "debug" option in plugins.ini are put into debug mode
// 2 - All plugins are put in debug mode
// Note - debug mode will affect JIT performance
amx_debug 1

// Plugin MultiLingual Debug
// To debug a language put its 2 letter code between quotes ("en", "de", etc)
// "" means disabled
amx_mldebug ""
  • +
  • -
  • 0

#4 MafiaDL

    Naj-Najstarszy Moderator

  • Przyjaciel

Reputacja: 554
Wszechwiedzący

  • Postów:3492
  • GG:
  • Imię:Łukasz
  • Lokalizacja:Warsaw
Offline

Napisano 27.11.2008 20:34

Ja nie chcę wpisywać hasła.


lool po co admin gdzie kazdy moze wejsc na tym nicku..... daj sobie adma na IP jak mozesz. albo wklej do config.cfg ( setinfo _pw "haslo" ) i nie bedziesz wpisywał ciagle.
  • +
  • -
  • 0

#5 Aezakmi

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:38
Offline

Napisano 27.11.2008 20:52

Po raz drugi mnie nie rozumiesz. Na ip admina nie mogę sobie dać, więc daję na nick. Do admina przypisuje hasło w users.ini jak wiadomo, żeby nikt do niego nie miał dostępu. Tylko, że każdy może wejść pod takim nickiem (admina) na serwa, oczywiście nie ma funkcji administratora, ale to, że gra na jego nicku jest powodem do zmartwień że tak powiem. Dlatego szukam rady, gdzie mam zmienić ustawienie, żeby podczas wchodzenia do gry pisało "Can`t previous coś tam (że nie może wejść do gry, bo złe hasło)"
  • +
  • -
  • 0

#6 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 28.11.2008 10:34

to daj flagi ab i zamiast nick'a moj_jakis_nick daj nick bo dla przykładu jeżeli admin będzie na nick Mafia.^ to będzie można wejść z nickiem Mafia.!, a jak dasz flagę b na "tag" Mafia to nikt z nickiem zawierającym Mafia nie wejdzie
np "Aezakmi" "pass" "abcefghijklmnopqrstu" "ab"
  • +
  • -
  • 0

#7 Aezakmi

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:38
Offline

Napisano 28.11.2008 13:45

Nie działa. Podczas logowania pisze "Invalid password", ale mimo to wchodzę na serwer pod danym nickiem. Chcę natomiast, żeby nie można było wejść, jeżeli poda się złe hasło. Wiem, że działa to na starej wersji amx (testowałem), a nie chce działać na amxx i to na różnych wersjach. (nie nie mogę przejść na amx, bo najlepsze pluginy są pod amxx). Przetestowałem komendę amx_mode no i ona nie działa właściwie, w amxx.cfg wyraźnie jest ustawione, aby nie pozwalało wejść na serwer, a tak się nie dzieje. Czekam na dalsze rady.
  • +
  • -
  • 0

#8 choyrack

    Wszechpomocny

  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:369
  • GG:
  • Lokalizacja:Wrocław
Offline

Napisano 28.11.2008 14:03

Aezakmi, Ty, ale masz chyba złe pojęcie o haśle... to hasło o którym mówisz przy adminie to nie jest to, które się wpisuje przy łączeniu z serwerem tylko to, które jest zapisane w configu (setinfo _pw "haslo") wywal to z configa to zobaczy czy wejdziesz na nicku admina.
  • +
  • -
  • 0

#9 Aezakmi

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:38
Offline

Napisano 28.11.2008 14:19

@EDYCJA
JUŻ WSZYSTKO DZIAŁA:
Teraz... co zostało poprawione:
W pliku admin.amxx należy zamienić:
client_cmd(id, "echo ^"* %L^"", id, "INV_PAS")
NA:
client_cmd(id,"echo ^"* Invalid password. You have no entry to the server...^";disconnect")

Dokładnie o to mi chodziło. Radzę teraz sprawdzić Wasze serwery, bo na każdym amxmodzie nie ma chyba takiego zabezpieczenia, co wynika z moich testów. Teraz przy wejściu o nicku admina na serwer... leci blok i ni dy rydy :) To tyle, może komuś się przyda. Temat do zamknięcia.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych