Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Nie zapisuje sie lvl baza sql


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 master245

    Profesjonalista

  • Zbanowany

Reputacja: 8
Nowy

  • Postów:205
  • Lokalizacja:Witów
Offline

Napisano 01.02.2011 11:10

Otoz mam problem dodalem zloto oraz armor wedlug instrukcji na tym forum, ale nie chce sie lvl zapisywac.
Wchodzilemw baze sql robilem reset ale nie pomoglo.
Mam dodane cvary savexp jak cos.
W bazie sql nie ma wpisu natomiast od armoru, od zlota jest.
Diablo bralem z tego forum przerobione przez patryk1345
link
http://amxx.pl/topic/28335-diablo-mod-diablo-59l-nowy/

to jest z bazy sql

nick   	 varchar(64)  	   	    	
ip 	varchar(64) 			
sid 	varchar(64) 			
klasa 	int(2) 			
lvl 	int(3) 			
exp 	int(9) 			
str 	int(3) 			
int 	int(3) 			
dex 	int(3) 			
agi 	int(3) 			
pkt 	int(4)

w zalczniku moje sma

za kazda pomoc dam +

Załączone pliki



#2 V3ko

    Guru

  • Power User

Reputacja: 82
Zaawansowany

  • Postów:746
  • Lokalizacja:Stopnica
Offline

Napisano 01.02.2011 11:48

Daj logi. Prawdopodobnie nie zapisuje ci sie exp z powodu braku wpisu w tabeli MySQL:)
  • +
  • -
  • 1

#3 master245

    Profesjonalista

  • Autor tematu
  • Zbanowany

Reputacja: 8
Nowy

  • Postów:205
  • Lokalizacja:Witów
Offline

Napisano 01.02.2011 11:54

zalacznik ;]
thx

Załączone pliki



#4 Goliath

    Godlike

  • Przyjaciel

Reputacja: 1227
Godlike

  • Postów:2334
  • GG:
  • Steam:steam
  • Imię:Maciej
  • Lokalizacja:Mońki
Offline

Napisano 01.02.2011 11:59

Nie zdefiniowałeś tworzenia się kolumny `arm` w bazie. Masz, naprawione. Jak dalej będą błędy to pisz. Polecam zrobić reset tabeli.

Załączone pliki


Użytkownik Goliath edytował ten post 01.02.2011 11:59

  • +
  • -
  • 1

#5 master245

    Profesjonalista

  • Autor tematu
  • Zbanowany

Reputacja: 8
Nowy

  • Postów:205
  • Lokalizacja:Witów
Offline

Napisano 01.02.2011 12:01

thx

Dodano 01 luty 2011 - 12:15:
edit nadal nie ma wpisu w bazie sql a na serwie nie patrzylem
jestem gdzie indziej i nie mam jak wbic ale chyba by sie stowrzyl wpis??

Dodano 01 luty 2011 - 19:09:
Dobra dziala.
A mam pytanie moge wiedziec czego zapomnailem dodac bo planuje dodawac inne wpisy do bazy sql.
Ale tak dokladnie jaka linijka lub kod ;]
z gory dzięki dostaliscie +

#6 Goliath

    Godlike

  • Przyjaciel

Reputacja: 1227
Godlike

  • Postów:2334
  • GG:
  • Steam:steam
  • Imię:Maciej
  • Lokalizacja:Mońki
Offline

Napisano 01.02.2011 19:24

Linia 731:
format(q_command,511,"CREATE TABLE IF NOT EXISTS `%s` ( `nick` VARCHAR( 64 ),`ip` VARCHAR( 64 ),`sid` VARCHAR( 64 ), `klasa` integer( 2 ) , `lvl` integer( 3 ) DEFAULT 1, `exp` integer( 9 ) DEFAULT 0,  `str` integer( 3 ) DEFAULT 0, `int` integer( 3 ) DEFAULT 0, `dex` integer( 3 ) DEFAULT 0, `agi` integer( 3 ) DEFAULT 0, `pkt` integer( 4 ) DEFAULT 0 , `arm` integer( 4 ) DEFAULT 0 ) ",g_sqlTable)
A miałeś:
format(q_command,511,"CREATE TABLE IF NOT EXISTS `%s` ( `nick` VARCHAR( 64 ),`ip` VARCHAR( 64 ),`sid` VARCHAR( 64 ), `klasa` integer( 2 ) , `lvl` integer( 3 ) DEFAULT 1, `exp` integer( 9 ) DEFAULT 0,  `str` integer( 3 ) DEFAULT 0, `int` integer( 3 ) DEFAULT 0, `dex` integer( 3 ) DEFAULT 0, `agi` integer( 3 ) DEFAULT 0, `pkt` integer( 4 ) DEFAULT 0 ) ",g_sqlTable)

  • +
  • -
  • 1

#7 master245

    Profesjonalista

  • Autor tematu
  • Zbanowany

Reputacja: 8
Nowy

  • Postów:205
  • Lokalizacja:Witów
Offline

Napisano 02.02.2011 07:51

dzięki temat off dostajesz kolejnego +

Dodano 04 luty 2011 - 18:02:
Znow ten problem ale nic nie dodalem ;[
Exp leci mam swoj np.50 lvl ale jak sie zmieni mapka to juz expa nie ma resetuje sie do tego co był wczesniej ;[
Mam savexp na 1




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych