Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Ustawienie Predkosci Gracza..


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 AmD

    aemde

  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 25.01.2011 22:18

Witam!


Mam problem z ustawieniem prędkości gracza, wydaje się mnie że wszystko jest dobrze lecz nie działa...

oto części Kodu które powinny się przydać:

tablice:

new bool:speed[33];
new const Float:gfCSSpeeds[]={
000.0,
250.0, 000.0, 260.0, 250.0, 240.0,
250.0, 250.0, 240.0, 250.0, 250.0,
250.0, 250.0, 210.0, 240.0, 240.0,
250.0, 250.0, 210.0, 250.0, 220.0,
230.0, 230.0, 250.0, 210.0, 250.0,
250.0, 235.0, 221.0, 250.0, 245.0
};


Event:
register_event("CurWeapon","CurWeapon","be")


Funkcja Dla Eventu[a?](a raczej jej część):

public CurWeapon(id){
new WeaponNum = read_data(2)

//new speedspr += get_user_maxspeed(id)

switch(speed[id])
{
case 0: set_user_maxspeed(id,gfCSSpeeds[WeaponNum] +1.0);
case 1: set_user_maxspeed(id,gfCSSpeeds[WeaponNum] +200.0);
}
// dalej juz inny kod


Funkcja Przyznająca Prędkość:


case 31: {
if(marzenia[id] <= s31){
ColorChat(id, GREEN, "[%s]^x01 Masz Za Malo Marzen :(", prefix);
}
else
{
if(bz[id])
{
marzenia[id] -= s31;
speed[id] = true
bz[id] = false;
ColorChat(id, GREEN, "[%s]^x01 Kupiles:^x03 Szybkie Bieganie", prefix);
if(!slot[id])
slot[id] = true
}
else
{
ColorChat(id, GREEN, "[%s]^x01 Juz To Kupiles :(", prefix);
}
}
menu_destroy(menu_stat);
SklepHookCT(id);
SaveXp(id);

return PLUGIN_HANDLED;
}


Coś jest źle?
ps. dodam że ustawiam sv_maxspeed na 1000


Pozdrawiam!

Użytkownik AmD edytował ten post 25.01.2011 22:19

  • +
  • -
  • 0

#2 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 26.01.2011 20:34

po co takie zabawy ze switchem

if(speed[id]){
set_user_maxspeed(id,gfCSSpeeds[WeaponNum] +200.0);
}

i tyle nie trzeba nic wiecej
  • +
  • -
  • 1

#3 AmD

    aemde

  • Autor tematu
  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 26.01.2011 21:08

dzięki, chodź pomogło (to co zawsze zapominam) zmiana cvaru cl_back/for speed :)

można close.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych