Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Obrazenia na botach damage+=x nie dziala?


  • Zamknięty Temat jest zamknięty
Brak odpowiedzi do tego tematu

#1 Zaszka

    Banned

  • Zbanowany

Reputacja: 53
Pomocny

  • Postów:215
  • Imię:Ja
Offline

Napisano 03.01.2011 20:33

Witam zrobilem zobie plugin ktory powinien dzialac dobrze z botami ale gdy chce kontrolowac obrazenia na boty to nie dziala

wiadomo mam funkcje gdy obrazenia sa zadane itd w tym

new damage = read_data(2)

if (SilaGracza[attacker]/2>=1)
{
new dmg5 = SilaGracza[attacker]/2-HartGracza[id]/3
damage+=dmg5
}

set_hudmessage(0, 100, 200, -1.0, 0.55, 2, 0.1, 4.0, 0.02, 0.02, -1)
ShowSyncHudMsg(attacker, g_MsgSync, "%i^n", damage)
set_hudmessage(255, 0, 0, -1.0, 0.45, 2, 0.1, 4.0, 0.02, 0.02, -1)
ShowSyncHudMsg(id, g_MsgSync, "%i^n", damage)


i cos takiego by pokazywalo obrazenia niestey wszystko jest ok pokazuje obrazenia nawet gdy zada je bot w przeksztalconym stanie
ale gdy ja bije bota(Ustawilem mu 500 hp na start dziala) ustawilem zobie damage na +=400 I nie zabijam go dwoma trafieniami tylko musze go udezyc ponad 30 razy z lewego ;/ czyli nie dziala to na niego czy da sie to jakos naprawic ?

Chodzi mi by w pelni dzialalol bo troche bez sensu mozna u mnie miec nawet 1400dmg za jednym udezeniem i ok 10000 zycia jest max jakby tak bot siekal po 1400 a ty go po 15 to troche niezbyt...

Dodano 04 styczeń 2011 - 16:50:
help

Dodano 04 styczeń 2011 - 18:30:
Zrobilem nowa funkcje:

if (is_user_bot(id))
{
new zycie = get_user_health(id)
if(zycie-damage<1)
{
if(get_user_team(attacker)!=get_user_team(id))
set_user_frags(attacker,get_user_frags(attacker) +1);

if (cs_get_user_money(attacker) + 300 <= 16000)
cs_set_user_money(attacker,cs_get_user_money(attacker)+300)
else
cs_set_user_money(attacker,16000)
log_kill(attacker, id, "knife", 0)
}
else
{
set_user_health(id,get_user_health(id)-damage)
}
}

stock log_kill(killer, victim, weapon[],headshot) 
{
set_msg_block(g_msgDeathMsg, BLOCK_SET)
ExecuteHamB(Ham_Killed, victim, killer, 2)
set_msg_block(g_msgDeathMsg, BLOCK_NOT)
message_begin(MSG_ALL, g_msgDeathMsg, {0,0,0}, 0)
write_byte(killer)
write_byte(victim)
write_byte(headshot)
write_string(weapon)
message_end()
new kname[32], kauthid[32], kteam[10]
get_user_name(killer, kname, 31)
get_user_team(killer, kteam, 9)
get_user_authid(killer, kauthid, 31)
if (killer != victim)
{
new vname[32] , vauthid[32], vteam[10]
get_user_name(victim, vname, 31)
get_user_team(victim, vteam, 9)
get_user_authid(victim, vauthid, 31)
log_message("^"%s<%d><%s><%s>^" killed ^"%s<%d><%s><%s>^" with ^"%s^"",
kname, get_user_userid(killer), kauthid, kteam,
vname, get_user_userid(victim), vauthid, vteam, weapon)
}
else
{
log_message("^"%s<%d><%s><%s>^" killed self with ^"%s^"",
kname, get_user_userid(killer), kauthid, kteam, weapon)
}
UpdateScore(killer, victim, 0,0, 1)
return PLUGIN_CONTINUE
}

ale wtedy wyslakuje blad jak zabijam bota nie wiem czy dobrze zrobilem ;/

Użytkownik Zaszka edytował ten post 04.01.2011 16:49





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych