Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

W czym jest błąd


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 no name

    Wszechpomocny

  • Użytkownik

Reputacja: 56
Pomocny

  • Postów:387
  • GG:
  • Steam:steam
  • Imię:Wojciech
  • Lokalizacja:Kraków
Offline

Napisano 18.12.2010 19:48

Witam. Przejdę do rzeczy...

Plugin nie działa, a przy kompilacji 0 błędów. W logach mam tylko:


L 12/18/2010 - 19:35:51: Function "event_CurWeapon" was not found
L 12/18/2010 - 19:35:51: [AMXX] Run time error 19 (plugin "vip_ut.amxx") - debug not enabled!
L 12/18/2010 - 19:35:51: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).


Plugin w załączniku

Załączone pliki


Użytkownik no name edytował ten post 18.12.2010 19:48

  • +
  • -
  • 0

#2 MaDaFaKa

    Zaawansowany

  • Zbanowany

Reputacja: 59
Pomocny

  • Postów:96
  • Imię:Damian
  • Lokalizacja:Warszawa
Offline

Napisano 18.12.2010 20:16

Omg. Rejestrujesz event, którego nie ma nawet w Twoim pliku .sma :mur: Usunąłem registra Cur Weapon'a, lecz nie jestem pewien czy będzie działało. Łapaj.

PS. Dodaj debug za plikiem w plugins.ini i pokaż errory, a wtedy postaram się Ci pomogę.

Załączone pliki


Użytkownik MaDaFaKa edytował ten post 18.12.2010 20:19


#3 no name

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 56
Pomocny

  • Postów:387
  • GG:
  • Steam:steam
  • Imię:Wojciech
  • Lokalizacja:Kraków
Offline

Napisano 18.12.2010 21:13

Zarejestrowałem bo miało być z menu z broniami, ale wolałem to w osobnym pliku zrobić, bo mogę wyłączać na mapkach fy/aim/awp. Zapomniałem usunąć. Działa wszystko, dzięki. Mam tylko problem z:


//TABELE INFO VIP
public MessageScoreAttrib(iMsgID, iDest, iReceiver)
{
new iPlayer = get_msg_arg_int(1);
if(get_user_flags(iPlayer) & ADMIN_LEVEL_H)
{
if(is_user_connected(iPlayer))
{
if(cs_get_user_team(iPlayer)==CS_TEAM_CT)
{
set_msg_arg_int(2, ARG_BYTE, is_user_alive(iPlayer) ? SCOREATTRIB_VIP : SCOREATTRIB_DEAD);
}
else
{
set_msg_arg_int(2, ARG_BYTE, is_user_alive(iPlayer) ? SCOREATTRIB_VIP : SCOREATTRIB_BOMB);
}
}
}
}


W ziołem to z innego pluga, bo mi nie szło, ale to też jakoś nie chce.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych