Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem Snowball War - znika paka


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 VirusX

    Pomocny

  • Użytkownik

Reputacja: 75
Zaawansowany

  • Postów:48
  • Imię:Adam
  • Lokalizacja:Zabrze
Offline

Napisano 16.12.2010 02:24

Witam.
Ostatnio odpalilem u siebie moda Snowball war.
Postanowilem uzywac go na wybranych mapach wykorzystujac maptypecfg.
I tak, dla mapy de_dust w configu mapy wpisywalem sw_toggle uruchamiajacy moda.
Na pozostalych toggle byl ustawiony na 0.
Wszystko byloby ladnie, pieknie gdyby nie to, ze uzywajac moda znika paka - i to nie tylkko na mapach gdzie mod jest wlaczony ale i tam, gdzie jest wylaczony.
Co ciekawe probowalem juuz roznych sztuczek - pauzowanie, zatrzymywanie pluginu nic nie daje. Dopiero wylaczenie go w plugins.ini przywraca normalny stan rzeczy (paka sie pojawia).
Gdzie jest bug?

Oferuje naprawdę dobre piwo za pomoc, za ktora jak zawsze z gory dziekuje.
Dolaczam sma.

Pozdrawiam.

Załączone pliki


  • +
  • -
  • 0

#2 lajT?.

    Pomocny

  • Użytkownik

Reputacja: 11
Początkujący

  • Postów:57
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Polska
Offline

Napisano 16.12.2010 10:25

Kod odpowiedzialny za to:
//This can affect gameplay
new const g_not_needed[][] =
{
"weaponbox",
"armoury_entity",
"grenade",
"func_bomb_target",
"info_bomb_target",
"info_vip_start",
"func_vip_safetyzone",
"func_escapezone",
"hostage_entity",
"monster_scientist",
"func_hostage_rescue",
"info_hostage_rescue"
}

  • +
  • -
  • 1

#3 VirusX

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 75
Zaawansowany

  • Postów:48
  • Imię:Adam
  • Lokalizacja:Zabrze
Offline

Napisano 16.12.2010 20:34

dodalem punkcik.
Czy ewentualnie ktos moglby poradzic jak to uzaleznic od tego, czy jest wlaczony sw_toggle czy nie?
Kombinowalem troche ale nie uzyskalem zadowalajacego efektu.

public fw_SpawnEntity(entity)
{
	// Invalid entity
	if (!pev_valid(entity)) return FMRES_IGNORED

if(get_pcvar_num(pcvar_on))
{

	// Get classname
	new classname[32]
	pev(entity, pev_classname, classname, sizeof classname - 1)
	
	// Check whether it needs to be removed
	
	for (new i = 0; i < sizeof g_not_needed; i++)
	{
		if (equal(classname, g_not_needed[i]))
		{
			engfunc(EngFunc_RemoveEntity, entity)
			return FMRES_SUPERCEDE
		}
	}
}	
	
	return FMRES_IGNORED
}

Gdy dodalem ifa w taki sposob to bomba co prawda pojawia sie ale przy jej podkladaniu zamienia sie w sniezke i znika - choc nie zawsze.
Jak moge uzaleznic dzialanie calego pluginu od sw_toggle, tak by mozna bylo wlaczac plugin na wybranych mapach za pomoca tej komendy - bez koniecznosci restartu?
Raz jeszcze bardzo proszę o pomoc.

Pozdrawiam.

Dodano 16 grudzień 2010 - 18:38:
nie ma nadziei? :(

Dodano 16 grudzień 2010 - 20:34:
moge ewentualnie zlecic komercyjnie poprawienie pluginu.

Użytkownik VirusX edytował ten post 16.12.2010 12:47

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych