Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z kompilacją COD moda


  • Zamknięty Temat jest zamknięty
5 odpowiedzi w tym temacie

#1 OgUreK

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Lokalizacja:Lubień
Offline

Napisano 08.12.2010 23:16

/home/groups/amxmodx/tmp3/phpFyWT9H.sma(152) : error 001: expected token: "}", but found "-string-"
/home/groups/amxmodx/tmp3/phpFyWT9H.sma(154) : error 010: invalid function or declaration
/home/groups/amxmodx/tmp3/phpFyWT9H.sma(167) : error 001: expected token: "}", but found "-string-"
/home/groups/amxmodx/tmp3/phpFyWT9H.sma(168) : error 010: invalid function or declaration
/home/groups/amxmodx/tmp3/phpFyWT9H.sma(426) : error 017: undefined symbol "Morderca"
/home/groups/amxmodx/tmp3/phpFyWT9H.sma(455) : error 017: undefined symbol "Morderca"
/home/groups/amxmodx/tmp3/phpFyWT9H.sma(455) : error 029: invalid expression, assumed zero
/home/groups/amxmodx/tmp3/phpFyWT9H.sma(455) : warning 215: expression has no effect
/home/groups/amxmodx/tmp3/phpFyWT9H.sma(455) : error 001: expected token: ";", but found ")"
/home/groups/amxmodx/tmp3/phpFyWT9H.sma(455) : fatal error 107: too many error messages on one line

mam problem z kompilacją proszę o poprawę

Załączone pliki


  • +
  • -
  • 0

#2 pAC

    Wszechobecny

  • Zbanowany

Reputacja: 87
Zaawansowany

  • Postów:425
  • Steam:steam
  • Lokalizacja:Żagań
Offline

Napisano 09.12.2010 09:39

zrobione trzymaj

Załączone pliki



#3 OgUreK

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Lokalizacja:Lubień
Offline

Napisano 09.12.2010 09:42

Dobra. z edycją i kompilacją .sma poradziłem sobie sam , lecz mam inny problem ,
(1) mianowicie dodałem klasie niewidzialność , wszystko działa prócz tego , że niewidzialność "przechodzi" do następnej klasy przy jej zmianie .
(2) i jeszcze jedno jak zrobić by na początku rundy nie było "standardowej" dla każdej klas broni tj. USP , zależy mi , by tak nie było , gdyż zrobiłęm klasę Ninja i chciałbym aby miałą tylko nóż


Z góry dziękuje . Pomocnym obiecuje punkty reputacji :) W załączniku .sma mojego Coda
Pozdrawiam OgUreK

@@ edit z 2 problem też mam z głowy , teraz tylko taa niewidzialność :)z tym że na dodatek niewidzialność , gdy jest ustawiona na nóż (klasa Morderca) to przechodzi również na AK jak i na USP Pomocy :) Reputacja nadal czeka na chętnych :)

Załączone pliki


Użytkownik OgUreK edytował ten post 09.12.2010 17:37

  • +
  • -
  • 0

#4 pAC

    Wszechobecny

  • Zbanowany

Reputacja: 87
Zaawansowany

  • Postów:425
  • Steam:steam
  • Lokalizacja:Żagań
Offline

Napisano 09.12.2010 15:13

zeby klasa miala tylko noz
znajdz

case ninja:


i dodaj tam takie cos


strip_user_weapons(id);
give_item(id, "weapon_knife");


co do tego 1 sam niewiem bez bicia sie przyznam ;)

#5 OgUreK

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Lokalizacja:Lubień
Offline

Napisano 09.12.2010 18:13

Myślę , że cały mój problem zawarty jest tu
public CurWeapon(id)
{
	if(freezetime || !klasa_gracza[id])
		return PLUGIN_CONTINUE;
		
	new weapon = read_data(2);

	UstawSzybkosc(id);
	
	if(weapon == CSW_C4)
		podkladajacy = id;
	if(klasa_gracza[id] == Morderca && weapon == CSW_KNIFE) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 15);
	if(klasa_gracza[id] == Morderca && weapon == CSW_AK47) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255); 
        if(klasa_gracza[id] == Morderca && weapon == CSW_USP) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255);
	if(klasa_gracza[id] == Ninja && weapon == CSW_KNIFE) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 15);
	return PLUGIN_CONTINUE;
}

tylko jako początkujący nie wiem gdzie zrobiłem błąd . proszę o pomoc :)

Użytkownik OgUreK edytował ten post 09.12.2010 18:23

  • +
  • -
  • 0

#6 Maussanti

    Zaawansowany

  • Użytkownik

Reputacja: 47
Pomocny

  • Postów:114
  • GG:
  • Imię:Maussanti
  • Lokalizacja:.
Offline

Napisano 10.12.2010 20:15

public CurWeapon(id)
{
if(freezetime || !klasa_gracza[id])
return PLUGIN_CONTINUE;

new weapon = read_data(2);

UstawSzybkosc(id);

if(weapon == CSW_C4)
podkladajacy = id;
if(klasa_gracza[id] == Morderca && weapon == CSW_KNIFE) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 15);
if(klasa_gracza[id] == Morderca && weapon == CSW_AK47) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255);
if(klasa_gracza[id] == Morderca && weapon == CSW_USP) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255);
if(klasa_gracza[id] == Ninja && weapon == CSW_KNIFE) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 15);
return PLUGIN_CONTINUE;
}

Tutaj jest wszysto dobrze ewentualnie radzę zrobić tak

public CurWeapon(id)
{
if(freezetime || !klasa_gracza[id])
return PLUGIN_CONTINUE;

new weapon = read_data(2);

UstawSzybkosc(id);

if(weapon == CSW_C4)
podkladajacy = id;
if(klasa_gracza[id] == Morderca && weapon == CSW_KNIFE) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 15);
else
set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255);

if(klasa_gracza[id] == Morderca && weapon == CSW_AK47) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255);
else
set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255);

if(klasa_gracza[id] == Morderca && weapon == CSW_USP) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255);
else
set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255);

if(klasa_gracza[id] == Ninja && weapon == CSW_KNIFE) set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 15);
else
set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255);
return PLUGIN_CONTINUE;
}



Jest możliwość, że w Twoim kodzie się zbuguje (Inne klasy też bd miały INVI, jeżeli wcześniej używali wyznaczonych klas)
Jeżeli wlepisz ten kod co ja dałem ten bug nie powinien się pojawić.

Użytkownik Maussanti edytował ten post 10.12.2010 20:16

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych