Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.
  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
GmAMXBans

Problem z błędem powody bana

GmAMXBans

  • Zamknięty Temat jest zamknięty
Brak odpowiedzi do tego tematu

#1 EufooZ

    Profesjonalista

  • Użytkownik

Reputacja: 25
Życzliwy

  • Postów:183
  • Lokalizacja:Łódź
Offline

Napisano 25.11.2010 14:18

- Wersję AMXBansa: Gm 1.4 (możliwe, że 1.3a ale nie wiem pobrałem najnowszą modyfiakcję i upgrade też zrobiłęm)
- Wersję AMXMODX: 1.8.1

- Wersję serwera: dproto
- Logi brak
- Plugins.ini - nie potrzeba moim zdaniem (przed modyfikacją nie było problemu)
- Modules.ini - nie potrzeba moim zdaniem (przed modyfikacją nie było problemu)
- sql.cfg - nie potrzeba moim zdaniem (przed modyfikacją nie było problemu)

Opis:
No więc. Wyskakuje mi taki błąd (praktycznie to nie błąd bo on nie przeszkadza, lecz może przez to coś nie działać):
Serwer -> Powody Banów -> W zestawie klikam "Edytuj" i tam sobie wybieram co gdzie i jak.
No i teraz przy zaznaczaniu, obok tego okienka wyskakuje mi takie coś:
Warning: preg_split() [function.preg-split]: No ending delimiter ',' found in /home/cszajefa/public_html/web/include/smarty/plugins/modifier.strinstr.php on line 8

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/cszajefa/public_html/web/include/smarty/plugins/modifier.strinstr.php on line 9
/>
Do słowie przy każdym okienku jest to samo. Mam modyfikację amxbans z tego forum i przed jej "zainstalowaniem" było wszystko dobrze, tylko po tej mody. tak się dzieje.

Mój modifier.strinstr.php:
<?php
/**
 * Smarty plugin
 
 */
function smarty_modifier_strinstr($source, $splitwith, $search, $return)
{
	$array=preg_split($splitwith,$source);
	if( in_array($search,$array)) 
	{
		return $return;
		exit;
	}
	return "";
}
?>

Czekam na pomoc.

Dodano 25 listopad 2010 - 14:36:
Ale jak wrzuce ten oryginalny Gm 1.4 to jest ok.

Orginał:
<?php
/**
 * Smarty plugin
 
 */
function smarty_modifier_strinstr($source, $splitwith, $search, $return)
{
	$array=split($splitwith,$source);
	if( in_array($search,$array)) {
		return $return;
		exit;
	}
	return "";
}
?>

  • +
  • -
  • 0

Cs-Move.xaa.pl - JailBreak - 178.19.106.146:27092

Cs-Move.xaa.pl - PaintBall - 178.19.106.150:27088

Forum - Cs-Move.xaa.pl


ZAPRASZAMY SERDECZNIE






Również z jednym lub większą ilością słów kluczowych: GmAMXBans

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych