Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Serwer się wyłącza .


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 baku

    [M]anchester[U]nited

  • Przyjaciel

Reputacja: 452
Wszechobecny

  • Postów:1054
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Polska
Offline

Napisano 03.11.2008 21:05

Witam .

Mam pytanie . Otóż mam serwer [SURF], a w nim tylko 1 plugin mianowicie surf_olimpics.amx . Serwer ma być i jest przystosowany do map tylko i wyłącznie surf, no ale jeżeli ktoś da restart serwera to serwer pada, bo nie ma chyba podstawowej mapy . Skąd takie wnioski ? Wnioski wyciągnąłem po tym, gdyż nie ma mapy podstawowej i chce uruchomić serwer to on się nie uruchamia, a gdy dam mapę podstawową np. de_dust2 to się serwer włącza . Może to też być spowodowane pluginem ponieważ, w logach znalazłem taki error wyskakuje on cały czas ;>

L 11/01/2008 - 09:51:50: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 11/01/2008 - 09:55:38: Start of error session.
L 11/01/2008 - 09:55:38: Info (map "surf_ski_2") (logfile "error_110108.log")
L 11/01/2008 - 09:55:38: Function is not present (function "remove_weapon") (plugin "surf_olympics.amxx")
L 11/01/2008 - 09:55:38: [AMXX] Run time error 10 (plugin "surf_olympics.amxx") (native "set_task") - debug not enabled!
L 11/01/2008 - 09:55:38: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).


Rozumiem, że muszę te "debug" dodać do plugins.ini ale nie wiem dokładnie gdzie :)

Jeżeli zły dział to przesuńcie, bo nie byłem pewien czy w dobrym dziale znajduje się tema .

Aha i serwer oczywiście jest na płatnym hostingu .
  • +
  • -
  • 0

#2 Abes Mapper

    Repulsion Gel

  • Przyjaciel

Reputacja: 1996
Godlike

  • Postów:7356
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Sulejówek
Offline

Napisano 03.11.2008 21:36

[...]
surf_olympics.amxx debug           ; Bardzo fajny plugin do surfu
[...]

Ten opis pluga dałem żeby było wiadomo gdzie ma być to debug :P
  • +
  • -
  • 0

#3 Saper

    Godlike

  • Przyjaciel

Reputacja: 220
Profesjonalista

  • Postów:1315
  • GG:
  • Imię:Juzio ;d
  • Lokalizacja:Bialystok
Offline

Napisano 03.11.2008 21:50

Mozesz tez dac
-debug
do lini startowej servera
  • +
  • -
  • 0

#4 wizu

    Godlike

  • Przyjaciel

Reputacja: 224
Profesjonalista

  • Postów:1217
  • GG:
  • Lokalizacja:Sanok
Offline

Napisano 03.11.2008 21:52

Tylko, w tym wypadku sma musi być chyba w scriptings, tak?
  • +
  • -
  • 0

#5 baku

    [M]anchester[U]nited

  • Autor tematu
  • Przyjaciel

Reputacja: 452
Wszechobecny

  • Postów:1054
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Polska
Offline

Napisano 06.11.2008 15:10

Abes_Ziomal, teraz mam takie errory .

L 11/05/2008 - 21:42:38: Function is not present (function "remove_weapon") (plugin "surf_olympics.amxx")
L 11/05/2008 - 21:42:38: [AMXX] Displaying debug trace (plugin "surf_olympics.amxx")
L 11/05/2008 - 21:42:38: [AMXX] Run time error 10: native error (native "set_task")
L 11/05/2008 - 21:42:38: [AMXX] [0] phpfri3xp.sma::Event_DeathMsg (line 1321)

Mozesz tez dac
Kod:
-debug
do lini startowej servera


Możesz jaśniej ;>
  • +
  • -
  • 0

#6 MafiaDL

    Naj-Najstarszy Moderator

  • Przyjaciel

Reputacja: 554
Wszechwiedzący

  • Postów:3492
  • GG:
  • Imię:Łukasz
  • Lokalizacja:Warsaw
Offline

Napisano 06.11.2008 15:17

baku, nie kazdy ma taką linie startową :P skad masz serwa?


w shooters takie cos


Dołączona grafika

i tam dopisujesz -debug

Komenda uruchamiająca serwer

./ -game cstrike +maxplayers 12 +ip 195.42.112.6 +port 27030 +exec server.cfg +map de_dust2 -autoupdate

  • +
  • -
  • 0

#7 baku

    [M]anchester[U]nited

  • Autor tematu
  • Przyjaciel

Reputacja: 452
Wszechobecny

  • Postów:1054
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Polska
Offline

Napisano 06.11.2008 17:38

baku, nie kazdy ma taką linie startową :P skad masz serwa?

Z unixstorm.org .

No ale dalej nie wiem dlaczego serwer mi się wyłącza jak nie mam podstawowej mapy ..
  • +
  • -
  • 0

#8 MafiaDL

    Naj-Najstarszy Moderator

  • Przyjaciel

Reputacja: 554
Wszechwiedzący

  • Postów:3492
  • GG:
  • Imię:Łukasz
  • Lokalizacja:Warsaw
Offline

Napisano 06.11.2008 19:29

a masz tą linie startową?
  • +
  • -
  • 0

#9 baku

    [M]anchester[U]nited

  • Autor tematu
  • Przyjaciel

Reputacja: 452
Wszechobecny

  • Postów:1054
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Polska
Offline

Napisano 11.11.2008 21:50

Mafia, nie .
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych