Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z Pluginem


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 Mr.Whit3

    Pomocny

  • Użytkownik

Reputacja: 24
Życzliwy

  • Postów:65
  • Lokalizacja:Dom
Offline

Napisano 17.11.2010 18:35

Witam, robię nowy mod Lord of the Rings
ale mam 1 błąd:
L 11/17/2010 - 18:22:13: [AMXX] Displaying debug trace (plugin "LoR.amxx")
L 11/17/2010 - 18:22:13: Plugin called message_begin with an invalid message id (0).
L 11/17/2010 - 18:22:13: [AMXX] [0] LoR.sma::client_PreThink (line 1529)
L 11/17/2010 - 18:22:13: [AMXX] Run time error 10: native error (native "message_begin")
L 11/17/2010 - 18:22:13: [AMXX] Displaying debug trace (plugin "LoR.amxx")
L 11/17/2010 - 18:22:13: Plugin called message_begin with an invalid message id (0).
L 11/17/2010 - 18:22:13: [AMXX] [0] LoR.sma::client_PreThink (line 1529)
L 11/17/2010 - 18:22:13: [AMXX] Run time error 10: native error (native "message_begin")
L 11/17/2010 - 18:22:13: [AMXX] Displaying debug trace (plugin "LoR.amxx")
L 11/17/2010 - 18:22:13: Plugin called message_begin with an invalid message id (0).
L 11/17/2010 - 18:22:13: [AMXX] [0] LoR.sma::client_PreThink (line 1529)


Ten błąd pokazuje się co chwile w logach
linijka 1529:
message_begin( MSG_ONE, gmsgBartimer, {0,0,0}, id )

cały public:
public client_PreThink(id) 
{
new button2 = get_user_button(id);
new weapon = get_user_weapon(id);

if ( weapon == CSW_KNIFE && get_entity_flags(id) & FL_ONGROUND && (!(button2 & (IN_FORWARD+IN_BACK+IN_MOVELEFT+IN_MOVERIGHT))))
{
if(casting[id]==1 && halflife_time()>cast_end[id])
{
message_begin( MSG_ONE, gmsgBartimer, {0,0,0}, id )
write_byte( 0 )
write_byte( 0 )
message_end()
casting[id]=0
call_cast(id)
}
else if(casting[id]==0)
{
new Float: time_delay = 5.0

cast_end[id]=halflife_time()+time_delay

new bar_delay = floatround(time_delay,floatround_ceil)

casting[id]=1

message_begin( MSG_ONE, gmsgBartimer, {0,0,0}, id )
write_byte( bar_delay )
write_byte( 0 )
message_end()
}
}
else
{
if(casting[id]==1)
{
message_begin( MSG_ONE, gmsgBartimer, {0,0,0}, id )
write_byte( 0 )
write_byte( 0 )
message_end()
}
casting[id]=0
}
return PLUGIN_CONTINUE
}


proszę o pomoc ;]
  • +
  • -
  • 0
Na GG: 7502883 pomagam odpłatnie ( chyba że to lekka edycja )
Pomogłem ?? Naciśnij Dołączona grafika !! Nic cię to nie kosztuje , a mnie Cieszy ^^

#2 kondzixd

    Wszechpomocny

  • Zbanowany

Reputacja: 8
Nowy

  • Postów:302
  • Lokalizacja:Olsztyn
Offline

Napisano 17.11.2010 21:08

Expertem nie jestem, ale to coś z wyświetlaniem wiadomości w say'u

#3 Mr.Whit3

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 24
Życzliwy

  • Postów:65
  • Lokalizacja:Dom
Offline

Napisano 17.11.2010 22:10

Expertem nie jestem, ale to coś z wyświetlaniem wiadomości w say'u

nie w say'u a w HuD
  • +
  • -
  • 1
Na GG: 7502883 pomagam odpłatnie ( chyba że to lekka edycja )
Pomogłem ?? Naciśnij Dołączona grafika !! Nic cię to nie kosztuje , a mnie Cieszy ^^

#4 Dangerous.

    Pomocny

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:65
  • Imię:Mateusz
  • Lokalizacja:Lublin
Offline

Napisano 17.11.2010 22:23

prawdopodobnie masz uzyte public
client_PreThink(id)

najlepiej dam sma to ci naprawię.
  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika


Dołączona grafika

#5 Mr.Whit3

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 24
Życzliwy

  • Postów:65
  • Lokalizacja:Dom
Offline

Napisano 17.11.2010 22:25

Dangerous. ja się znam na tym lepiej niż ty, a jesli piszesz że 2 razy użyty public client_prethik to nawet nie marz że ci dam sma ;] - po prostu się nie znasz
  • +
  • -
  • 1
Na GG: 7502883 pomagam odpłatnie ( chyba że to lekka edycja )
Pomogłem ?? Naciśnij Dołączona grafika !! Nic cię to nie kosztuje , a mnie Cieszy ^^

#6 Dangerous.

    Pomocny

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:65
  • Imię:Mateusz
  • Lokalizacja:Lublin
Offline

Napisano 17.11.2010 22:30

własnie widze, że sie znasz jak taki głupi błąd masz :]

pozdrawiam.

ps. urośnij.
  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika


Dołączona grafika

#7 Mr.Whit3

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 24
Życzliwy

  • Postów:65
  • Lokalizacja:Dom
Offline

Napisano 18.11.2010 07:14

hmmm. właśnie ty się nie znasz bo ten błąd nie odpowiada za 2 takie same public client_preThink ale za prawdopodobnie złe id w Message Begin
  • +
  • -
  • 1
Na GG: 7502883 pomagam odpłatnie ( chyba że to lekka edycja )
Pomogłem ?? Naciśnij Dołączona grafika !! Nic cię to nie kosztuje , a mnie Cieszy ^^




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych