Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[Preoblem]Z Diablo HUD


  • Zamknięty Temat jest zamknięty
10 odpowiedzi w tym temacie

#1 OcEt

    Pomocny

  • Zbanowany

Reputacja: -4
Mniej niż zer0.

  • Postów:40
  • Lokalizacja:Konin
Offline

Napisano 08.11.2010 22:48

Czesc mam problem zedytowalem Sobie Diablomoda bardzo duzo Ale niewidze Huda tam co pisze klasa przedmiot itp reszte widze np konkretne itemy mozna uzyc pod klawiszem E to mi sie wyswietla logi z consoli.


L 11/08/2010 - 22:38:04: [AMXX] [0] frakcje_37759.sma::client_PreThink (line 1818)
L 11/08/2010 - 22:38:04: Plugin called message_begin with an invalid message id (0).
L 11/08/2010 - 22:38:04: [AMXX] Displaying debug trace (plugin "frakcje2.amxx")
L 11/08/2010 - 22:38:04: [AMXX] Run time error 10: native error (native "message_beg

Takie cos mi sie wyswietla w CONSOLI!

Dodano 09 listopad 2010 - 09:06:
Pomoze ktos?

Dodano 09 listopad 2010 - 15:30:
Halooooooooo!!

#2 Damex

    Zaawansowany

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:98
  • GG:
  • Imię:Damian
  • Lokalizacja:Belsk
Offline

Napisano 09.11.2010 16:42

Pokaż sma ...
  • +
  • -
  • 0

#3 OcEt

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: -4
Mniej niż zer0.

  • Postów:40
  • Lokalizacja:Konin
Offline

Napisano 09.11.2010 17:12

proszę zaprawic jak mozna.

Dodano 09 listopad 2010 - 18:17:
I takie pomaganie uzytkownikom.
Ja jak bym umial tez bym pomagal anie olewacie se nas. :foch: :foch: :'( :'(

Załączone pliki



#4 false

    Wszechmogący

  • Użytkownik

Reputacja: 53
Pomocny

  • Postów:652
  • Lokalizacja:z Polski
Offline

Napisano 10.11.2010 16:29

NIE KAŻDY USER JEST ZOBOWIĄZANY ! POMOC JEST BEZPŁATNA I JAK KTOŚ BĘDZIE CHCIAŁ TO CI POMOŻE ! NA RAZIE PRZESTAŃ ODŚWIEŻAĆ TEMAT I POCZEKAJ !!!
  • +
  • -
  • 0

#5 OcEt

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: -4
Mniej niż zer0.

  • Postów:40
  • Lokalizacja:Konin
Offline

Napisano 10.11.2010 16:53

No ile juz czekam a to jest dla mnie wazne kurde no!

#6 ZiuTeK

    Wszechwiedzący

  • Użytkownik

Reputacja: 133
Zaawansowany

  • Postów:507
  • Lokalizacja:inąd
Offline

Napisano 10.11.2010 17:07

Funkcje od huda masz dobra z wyjatkiem tego:
new name[32]
get_user_name(id,name,31)
player_lvl[id]+=1
player_point[id]+=2
set_hudmessage(60, 200, 25, -1.0, 0.25, 0, 1.0, 2.0, 0.1, 0.2, 2)
show_hudmessage(id, "Awansowales do poziomu %i", player_lvl[id])
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 1000)", name, Race[player_class[id]], player_lvl[id])   
savexpcom(id)
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 3000)", name, Race[player_class[id]], player_lvl[id])   
savexpcom(id)
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 6000)", name, Race[player_class[id]], player_lvl[id])   
savexpcom(id)
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 8000)", name, Race[player_class[id]], player_lvl[id])   
savexpcom(id)
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 10000)", name, Race[player_class[id]], player_lvl[id])   
savexpcom(id)
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 15000)", name, Race[player_class[id]], player_lvl[id])   
savexpcom(id)
player_class_lvl[id][player_class[id]]=player_lvl[id]
}
Wprowadzasz ludzi w blad bo ty nie masz problemu z hudem tylko z jakas inna funkcja a watpie ze komus bedzie sie chcialo sprawdzac co ty tam przerabiales i gdzie cos namodziles.
Dodatkowo kod tego diablo jest tak nieprzyjemny dla oczu, ze przy tym nie da sie pracowac. Nie wiem po jakiego grzyba usunales wszystkie znaki tabulacji. Sugeruje zaczac swoja prace od nowa i po kazdej wprowadzonej modyfikacji sprawdzac czy wszystko jest ok i zapisywac do innego katalogu kopie bezpieczenstwa z poprzednia wersja. To znacznie skroci prace nad edycja w razie jakichs problemow.
Mialem kiedys taki blad przez zle domkniecie klamry. Niestety obecnie nie moge sobie przypomniec co wtedy edytowalem.
  • +
  • -
  • 0

#7 OcEt

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: -4
Mniej niż zer0.

  • Postów:40
  • Lokalizacja:Konin
Offline

Napisano 10.11.2010 17:48

Czyli musze to

new name[32]  get_user_name(id,name,31)  player_lvl[id]+=1  player_point[id]+=2  set_hudmessage(60, 200, 25, -1.0, 0.25, 0, 1.0, 2.0, 0.1, 0.2, 2)  show_hudmessage(id, "Awansowales do poziomu %i", player_lvl[id])  ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 1000)", name, Race[player_class[id]], player_lvl[id])     savexpcom(id)  ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 3000)", name, Race[player_class[id]], player_lvl[id])     savexpcom(id)  ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 6000)", name, Race[player_class[id]], player_lvl[id])     savexpcom(id)  ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 8000)", name, Race[player_class[id]], player_lvl[id])     savexpcom(id)  ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 10000)", name, Race[player_class[id]], player_lvl[id])     savexpcom(id)  ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 15000)", name, Race[player_class[id]], player_lvl[id])     savexpcom(id)  player_class_lvl[id][player_class[id]]=player_lvl[id]  }


Poprawic i bedzie dzialac?

#8 ZiuTeK

    Wszechwiedzący

  • Użytkownik

Reputacja: 133
Zaawansowany

  • Postów:507
  • Lokalizacja:inąd
Offline

Napisano 10.11.2010 18:30

Nie, tutaj pokazalem co mi sie nie podoba w twoim Hudzie, ale to nie powinno miec wplywu na jego wyswietlanie. O ile dobrze widze to spowoduje to tylko spam na say-u.
Dokladnie chodzi mi o te wiadomosci:
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 1000)", name, Race[player_class[id]], player_lvl[id])   
savexpcom(id)
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 3000)", name, Race[player_class[id]], player_lvl[id])   
savexpcom(id)
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 6000)", name, Race[player_class[id]], player_lvl[id])   
savexpcom(id)
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 8000)", name, Race[player_class[id]], player_lvl[id])   
savexpcom(id)
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 10000)", name, Race[player_class[id]], player_lvl[id])   
savexpcom(id)
ColorChat(0,GREEN, "** [DiabloMod] %s awansowal %s (do poziomu 15000)", name, Race[player_class[id]], player_lvl[id])
Powazniejszy blad zrobiles w innym miejscu bo w ogole nie wyswietla sie menu wyboru klas.
  • +
  • -
  • 0

#9 OcEt

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: -4
Mniej niż zer0.

  • Postów:40
  • Lokalizacja:Konin
Offline

Napisano 10.11.2010 19:03

Gdy wpisze /klasa tomoge wybrac klasy itp itd tylkko niewidze tego huda co pisze klasa:przedmiot:i lvl: tego niewidze tylko tego!

#10 ZiuTeK

    Wszechwiedzący

  • Użytkownik

Reputacja: 133
Zaawansowany

  • Postów:507
  • Lokalizacja:inąd
Offline

Napisano 10.11.2010 20:46

Dobra, sorry moj blad, mialem przeciazona baze i jak mi przez kilka minut klasa nie wyskoczyla to myslalem ze to blad gdzie indziej.
Serwer mi zawiesza przez ten spam napisami
Podmien funkcje
public write_hud(id) na oryginalna.
  • +
  • -
  • 0

#11 OcEt

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: -4
Mniej niż zer0.

  • Postów:40
  • Lokalizacja:Konin
Offline

Napisano 10.11.2010 21:50

dzięki Dziala + 4You




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych