Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Nie da się wybrać jednej z klas, restart oraz....


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 Magnetix

    Wszechobecny

  • Użytkownik

Reputacja: 26
Życzliwy

  • Postów:410
  • GG:
  • Lokalizacja:Piotrków Tryb
Offline

Napisano 05.11.2010 20:54

Witam przez ostanie dni pracowałem nad diablomodem. Dziś zakończyłem prace i chciałem go przetestować. Sma się ładnie przekompilowało ale w praniu wyszło co innego a dokładnie nie da się wybrać jednej z klas w menu. Jest druga strona klas i na niej są 4 klasy 3 są do wyboru a jedna nie. Jest normalnie odnośnik ale gdy klikam 4 (pod tą cyfrą jest ta klasa) to nic się nie dzieje. Drugim błędem jest autorestart. Podłożyłem 2 razy pakę zabiłem kolegę (grałem klasą paladyn) i co jakiś 5-10 sec od skończenia się rundy nastąpił restart. Pomimo tego gdy wybrałem klasę Magik i zabiłem przeciwnika z glocka w prawym górnym rogu było pokazane, że przeciwnika zabiłem dwa razy, choć zabiłem go raz.

Udostępnię fragmenty kodu sma na prośbę lub całe sma (całe sma tylko na PW).

Logi:

L 11/05/2010 - 20:12:52: Start of error session.
L 11/05/2010 - 20:12:52: Info (map "de_dust2_mini") (file "addons/amxmodx/logs/error_20101105.log")
L 11/05/2010 - 20:12:52: String formatted incorrectly - parameter 5 (total 4)
L 11/05/2010 - 20:12:52: [AMXX] Run time error 25 (plugin "diablo6.amxx") - debug not enabled!
L 11/05/2010 - 20:12:52: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).


Użytkownik Magnetix edytował ten post 05.11.2010 20:57

  • +
  • -
  • 0

#2 pAC

    Wszechobecny

  • Zbanowany

Reputacja: 87
Zaawansowany

  • Postów:425
  • Steam:steam
  • Lokalizacja:Żagań
Offline

Napisano 05.11.2010 21:53

sprobuj dopisac
diablo6.amxx debug
chociaz slyszalem od GoQ chyba ze to nie pomaga ale zobacz ;)

#3 Niscree

    Profesjonalista

  • Użytkownik

Reputacja: 41
Pomocny

  • Postów:174
  • Steam:steam
Offline

Napisano 05.11.2010 23:02

pomaga i nie pomaga ;P
ponieważ nie rozwiązuje problemu ale pomaga znaleźć błąd :]
a dokładniej po dopisaniu "debug" do pluginu pokaże ci dokładną linijkę z błędem ^^
  • +
  • -
  • 0

#4 KariiO

    Super Hero

  • Power User

Reputacja: 395
Wszechpomocny

  • Postów:1133
  • GG:
  • Imię:Korneliusz
  • Lokalizacja:Cieszyn
Offline

Napisano 06.11.2010 00:46

Policz ile masz wszystkich klas bez NONE i zmień ten cvar(o ile już nie masz zmienionego ;-):
diablo_classes abcdefgh - które klasy maja być dostępne
2 klasy - ab itd. , itd. :D
Co do tej broni to stawiało się gdzieś:
if (is_user_alive(id))
Co do tego nie jestem pewien , ale był taki temat :D
Jeszcze mogą to zakłócać inne pluginy choć wątpię...
  • +
  • -
  • 0

#5 Magnetix

    Wszechobecny

  • Autor tematu
  • Użytkownik

Reputacja: 26
Życzliwy

  • Postów:410
  • GG:
  • Lokalizacja:Piotrków Tryb
Offline

Napisano 06.11.2010 16:15

Policz ile masz wszystkich klas bez NONE i zmień ten cvar(o ile już nie masz zmienionego ;-):

diablo_classes abcdefgh - które klasy maja być dostępne
2 klasy - ab itd. , itd. :D
Co do tej broni to stawiało się gdzieś:
if (is_user_alive(id))
Co do tego nie jestem pewien , ale był taki temat :D
Jeszcze mogą to zakłócać inne pluginy choć wątpię...

Nic, nie zakłóca. Zaraz edytuje posta bo dopisałem debuga i czekam na logi.

L 11/06/2010 - 14:54:44: Start of error session.
L 11/06/2010 - 14:54:44: Info (map "de_nuke") (file "addons/amxmodx/logs/error_20101106.log")
L 11/06/2010 - 14:54:44: String formatted incorrectly - parameter 5 (total 4)
L 11/06/2010 - 14:54:44: [AMXX] Run time error 25 (plugin "diablo6.amxx") - debug not enabled!
L 11/06/2010 - 14:54:44: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 11/06/2010 - 16:49:51: Start of error session.
L 11/06/2010 - 16:49:51: Info (map "de_dust") (file "addons/amxmodx/logs/error_20101106.log")
L 11/06/2010 - 16:49:51: Invalid player id 0
L 11/06/2010 - 16:49:51: [AMXX] Run time error 10 (plugin "bulletdamage.amxx") (native "get_user_attacker") - debug not enabled!
L 11/06/2010 - 16:49:51: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 11/06/2010 - 16:52:39: Invalid player id 0
L 11/06/2010 - 16:52:39: [AMXX] Run time error 10 (plugin "bulletdamage.amxx") (native "get_user_attacker") - debug not enabled!
L 11/06/2010 - 16:52:39: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 11/06/2010 - 17:11:25: Start of error session.
L 11/06/2010 - 17:11:25: Info (map "awp_glass2") (file "addons/amxmodx/logs/error_20101106.log")
L 11/06/2010 - 17:11:25: String formatted incorrectly - parameter 5 (total 4)
L 11/06/2010 - 17:11:25: [AMXX] Displaying debug trace (plugin "diablo6.amxx")
L 11/06/2010 - 17:11:25: [AMXX] Run time error 25: parameter error
L 11/06/2010 - 17:11:25: [AMXX] [0] diablo6_36460.sma::award_item (line 3598)
L 11/06/2010 - 17:11:25: [AMXX] [1] diablo6_36460.sma::DeathMsg (line 1440)


Co do restartu to możliwe, że ktoś restartował bo dziś grałem na serwerze przez ponad 30min i ani jeden restart nie nastał.

Użytkownik Magnetix edytował ten post 06.11.2010 17:21

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych