Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

AmxBans problem


  • Zamknięty Temat jest zamknięty
26 odpowiedzi w tym temacie

#1 bolek12

    Pomocny

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:46
  • Lokalizacja:Juszczyn
Offline

Napisano 26.10.2008 21:58

Witajcie,

Zainstalowałem amxbans na www www.good-boys.pl/ban pokazuje mi ładnie stronę. Zainstalowałem na serwerze amxbans i dodałem do sql.cfg

amx_sql_host    "www.hekko.net.pl" //adres hosta bazy danych lub IP
amx_sql_user    "bolek" //użytkownik bazy danych
amx_sql_pass    "****" //hasło użytkownika bazy danych
amx_sql_db      "bolek_ban1" //nazwa bazy danych

Niestety gdy wejdę na serwer i próbuję dać bana to jest zero rekacji, dodam, że w konsoli pokazuje mi błąd łączenia z bazą danych chociaż wszystkie dane są dobre. W czym problem?
  • +
  • -
  • 0

#2 wizu

    Godlike

  • Przyjaciel

Reputacja: 224
Profesjonalista

  • Postów:1217
  • GG:
  • Lokalizacja:Sanok
Offline

Napisano 26.10.2008 22:07

Jesteś pewny, że host Twojej bazy danych to

www.hekko.net.pl

?
Bo mi się wydaje, że nie. Hosty baz danych hekko to coś podobnego do tego:
s1.hekko.net.pl
Upewnij się w panelu, czy wpisałeś poprawny host.
  • +
  • -
  • 0

#3 bolek12

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:46
  • Lokalizacja:Juszczyn
Offline

Napisano 26.10.2008 22:37

Ten co podałeś nie działa, a innego tam nie widzę.
  • +
  • -
  • 0

#4 d3f3nd3r

    Życzliwy

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:39
Offline

Napisano 27.10.2008 00:39

s2.hekko.net.pl

  • +
  • -
  • 0

#5 wizu

    Godlike

  • Przyjaciel

Reputacja: 224
Profesjonalista

  • Postów:1217
  • GG:
  • Lokalizacja:Sanok
Offline

Napisano 27.10.2008 09:01

Przecież ja nie jestem wróżką... Skąd mam wiedzieć jaki masz host? Podałem Ci przykład, żebyś wiedział jak to ma wygladać. W Twiom profilu, koncie, nie wiem jak to się tam nazywa na pewno masz dane do FTP i do MySQL. Po prostu je przepisz.
  • +
  • -
  • 0

#6 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 27.10.2008 09:08

Nie jestem pewny, ale do hekko dawałem coś w stylu
amx_sql_host 194.181.7.53
  • +
  • -
  • 0

#7 wizu

    Godlike

  • Przyjaciel

Reputacja: 224
Profesjonalista

  • Postów:1217
  • GG:
  • Lokalizacja:Sanok
Offline

Napisano 27.10.2008 09:15

Ale host adresu IP 194.181.7.53 to:
s1.hekko.net.pl
Więc to jest to samo. Tylko on musi sobie znaleźć host swojej bazy.
  • +
  • -
  • 0

#8 lastone

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:2
  • GG:
  • Lokalizacja:Luboń
Offline

Napisano 27.10.2008 09:16

start>cmd>

ping twojadres.hekko.pl

Zwroci IP ktore mozesz tam wpisac.
  • +
  • -
  • 0

#9 wizu

    Godlike

  • Przyjaciel

Reputacja: 224
Profesjonalista

  • Postów:1217
  • GG:
  • Lokalizacja:Sanok
Offline

Napisano 27.10.2008 09:21

Ale to nie robi żadnej różnicy, czy Ty wpiszesz host, czy adres IP. On poprostu musi poznać adres tej bazy. Ile razy mam pisać?
  • +
  • -
  • 0

#10 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 27.10.2008 09:31

wizu, masz racje, chyba że problem z DNS'ami jakiś jest.
http://geotool.serve... ... od-boys.pl => IP:91.203.133.69
http://whois.domaint...m/91.203.133.69 => host:s2.hekko.net.pl
  • +
  • -
  • 0

#11 d3f3nd3r

    Życzliwy

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:39
Offline

Napisano 27.10.2008 10:43

Przecież ja nie jestem wróżką... Skąd mam wiedzieć jaki masz host? Podałem Ci przykład, żebyś wiedział jak to ma wygladać. W Twiom profilu, koncie, nie wiem jak to się tam nazywa na pewno masz dane do FTP i do MySQL. Po prostu je przepisz.


Dokładnie ma to w panelu.
moze byc s1 s2 s3 .... musi sprawdzić,
się panowie zaczęli gorączkować, szkoda czasu na zbędną dyskusję.

OT: ktoś hackuje większość serwisów związanych z amx proponowałbym zrobić backupy oto przykład i wiele innych.
  • +
  • -
  • 0

#12 seba76

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:56
  • GG:
  • Lokalizacja:Katowice
Offline

Napisano 27.10.2008 15:47

Sorrki za offtopa ale temat świeży i dotyczy banowania.

Kurcze naprali mi sie admini i pobanowali nawzajem :-)
Gdzie w zwykłym amx_ban tym spod amx'a :

- amxmodmenu -> 2 -> NICK GRACZA ..

zapisuje sie ten ban ?? bo w tematach znalezionych mowa tylko o sql.
jesli wystarczy komenda amx_unban to jak wyswietlic liste banowanych ( w banned.cfg pusto )

hosta mam zewnetrznego, płatnego.

Nie zakładam nowego tematu bo troche wstyd :-).
  • +
  • -
  • 0

#13 wizu

    Godlike

  • Przyjaciel

Reputacja: 224
Profesjonalista

  • Postów:1217
  • GG:
  • Lokalizacja:Sanok
Offline

Napisano 27.10.2008 16:38

zobacz listip.cfg i usuń linijkę z IP owych graczy.
Jeżeli to nie pomoże, to załóż nowy temat.
  • +
  • -
  • 0

#14 d3f3nd3r

    Życzliwy

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:39
Offline

Napisano 27.10.2008 16:55

zobacz listip.cfg i usuń linijkę z IP owych graczy.


Jesli w ten sposob konieczny jest restart serwera
  • +
  • -
  • 0

#15 bolek12

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:46
  • Lokalizacja:Juszczyn
Offline

Napisano 27.10.2008 19:54

Więc tak, przy hostach

s1.hekko.net.pl / s2.hekko.net.pl
serwer pokazuje błąd łączenia z bazą danych, natomiast przy hoście
s3.hekko.net.pl
serwer się nie uruchamia. W panelu pokazuje mi host s2.hekko.net.pl, ale nie działa więc sprawdziłem każdy po kolei no i oto wyniki.
  • +
  • -
  • 0

#16 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 27.10.2008 19:56

serwer pokazuje błąd łączenia z bazą danych, natomiast przy hoście

konkretnie jak wygląda ten błąd ?
  • +
  • -
  • 0

#17 wizu

    Godlike

  • Przyjaciel

Reputacja: 224
Profesjonalista

  • Postów:1217
  • GG:
  • Lokalizacja:Sanok
Offline

Napisano 27.10.2008 19:57

I jaki masz port bazy danych?
  • +
  • -
  • 0

#18 bolek12

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:46
  • Lokalizacja:Juszczyn
Offline

Napisano 27.10.2008 19:59

L 10/27/2008 - 19:42:27: amxbans.amxx] Amxbans] Status zapytania:
L 10/27/2008 - 19:42:27: amxbans.amxx] Amxbans] Wiadomosc: Access denied for user 'bolek_ban1'@'91.204.161.216' (using password: YES) (1045)
L 10/27/2008 - 19:42:27: amxbans.amxx] Amxbans] Blad zapyania, lokacja: 17
L 10/27/2008 - 19:42:27: amxbans.amxx] Amxbans] Polaczenie nieudane!
L 10/27/2008 - 19:42:26: amxbans.amxx] Amxbans] Status zapytania:
L 10/27/2008 - 19:42:26: amxbans.amxx] Amxbans] Wiadomosc: Access denied for user 'bolek_ban1'@'91.204.161.216' (using password: YES) (1045)
L 10/27/2008 - 19:42:26: amxbans.amxx] Amxbans] Blad zapyania, lokacja: 16
L 10/27/2008 - 19:42:26: amxbans.amxx] Amxbans] Polaczenie nieudane!

Takie coś. Port to 2222
  • +
  • -
  • 0

#19 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 27.10.2008 20:05

Odkopałem moje stare backup'y i myślę że wiem w czym tkwi problem.

amx_sql_host "194.181.6.84"
amx_sql_user "pavulon_pavulon"
amx_sql_pass "moj_pass_ktorego_nie_podam"
amx_sql_db "pavulon_amx"

przy czym:
amx_sql_user = login_user
amx_sql_db = login_db
czyli dla Ciebie:
amx_sql_host  "s2.hekko.net.pl"
amx_sql_user	"bolek_bolek"
amx_sql_pass	"****"
amx_sql_db	 "bolek_ban1"

  • +
  • -
  • 0

#20 bolek12

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:46
  • Lokalizacja:Juszczyn
Offline

Napisano 27.10.2008 20:09

L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Status zapytania:
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Wiadomosc: Unknown MySQL server host '=' (1) (2005)
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Blad zapyania, lokacja: 17
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Polaczenie nieudane!
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Status zapytania:
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Wiadomosc: Unknown MySQL server host '=' (1) (2005)
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Blad zapyania, lokacja: 16
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Polaczenie nieudane!
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Status zapytania:
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Wiadomosc: Unknown MySQL server host '=' (1) (2005)
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Blad zapyania, lokacja: 16
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Polaczenie nieudane!
L 10/27/2008 - 19:58:37: amxbans.amxx] Amxbans] Status zapytania:

Po wpisaniu tego co podałeś i podaniu swoich danych coś takiego :/
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych