Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

cod mod + nowe klasy + sklepcod mod + nowe klasy + sklep


  • Zamknięty Temat jest zamknięty
12 odpowiedzi w tym temacie

#1 szczypior

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Imię:szczypior
  • Lokalizacja:slask
Offline

Napisano 25.10.2010 17:06

Witam.

Mam problem z pluginem (cod_mod_sklep).

Wgralem na swoj serwer codmod-a z nowymi klasami,i nie wiem jak dodac do tego sklep.

slyszalem ze to trzeba jakos wkleic pod koniec codmod-a ale jakos nie potrafie...

moglby ktos to dla mnie zrobic?

z gory dziekuje :)

Załączone pliki


  • +
  • -
  • 0

#2 Sajjuk

    Profesjonalista

  • Zbanowany

Reputacja: 148
Zaawansowany

  • Postów:201
  • GG:
  • Imię:Sajjuk
  • Lokalizacja:Komputer
Offline

Napisano 25.10.2010 17:25

chyba się udało... zobacz:

Dodano 25 październik 2010 - 17:26:
Sory nie dałem sma...

Załączone pliki



#3 szczypior

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Imię:szczypior
  • Lokalizacja:slask
Offline

Napisano 25.10.2010 17:35

no niby sklep dziala ale z reszta pluga jest nie tak :( :
:
Warning: Loose indentation on line 309
Warning: Unreachable code on line 328
Warning: Symbol is assigned a value that is never used: "ammount" on line 332
Warning: Symbol is assigned a value that is never used: "ammount" on line 350
Warning: Loose indentation on line 386
Warning: Loose indentation on line 395
Warning: Loose indentation on line 406
Warning: Loose indentation on line 443
Warning: Loose indentation on line 449
Warning: Loose indentation on line 458
Warning: Loose indentation on line 473
Warning: Loose indentation on line 474
Warning: Loose indentation on line 475
Warning: Loose indentation on line 486
Warning: Loose indentation on line 487
Warning: Loose indentation on line 488
Warning: Loose indentation on line 491
Error: Number of arguments does not match definition on line 785
Error: Number of arguments does not match definition on line 875
Error: Number of arguments does not match definition on line 1028
Error: Number of arguments does not match definition on line 1043
Error: Number of arguments does not match definition on line 1064
Error: Number of arguments does not match definition on line 1126
Warning: Tag mismatch on line 1430
Warning: Tag mismatch on line 1430
Warning: Tag mismatch on line 1430
Warning: Tag mismatch on line 1430
Warning: Tag mismatch on line 1502
Warning: Tag mismatch on line 1502
Warning: Tag mismatch on line 1502
Warning: Tag mismatch on line 1502
Warning: Tag mismatch on line 1541
Warning: Tag mismatch on line 1541
Warning: Tag mismatch on line 1541
Warning: Tag mismatch on line 1541
Error: Argument does not have a default value (argument 2) on line 1950
Error: Symbol already defined: "plugin_init" on line 1960

8 Errors.

Użytkownik szczypior edytował ten post 25.10.2010 17:36

  • +
  • -
  • 0

#4 Sajjuk

    Profesjonalista

  • Zbanowany

Reputacja: 148
Zaawansowany

  • Postów:201
  • GG:
  • Imię:Sajjuk
  • Lokalizacja:Komputer
Offline

Napisano 25.10.2010 17:36

mam innego mysła...

Użytkownik Sajjuk edytował ten post 25.10.2010 17:39


#5 szczypior

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Imię:szczypior
  • Lokalizacja:slask
Offline

Napisano 25.10.2010 17:40

dałem :)

wlasnie mialem odpisac o tym colorchacie ale dopisalem i nic

to wlasnie wyszkoczylo przy kompilacji :(

(a co jakby zrobic osobny plugin z tego sklepu?)
  • +
  • -
  • 0

#6 Sajjuk

    Profesjonalista

  • Zbanowany

Reputacja: 148
Zaawansowany

  • Postów:201
  • GG:
  • Imię:Sajjuk
  • Lokalizacja:Komputer
Offline

Napisano 25.10.2010 17:42

Sprobuj teraz... dodany jest takze "losowanie itemu"...

Dodano 25 październik 2010 - 17:42:

Sprobuj teraz... dodany jest takze "losowanie itemu"...

Załączone pliki



#7 szczypior

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Imię:szczypior
  • Lokalizacja:slask
Offline

Napisano 25.10.2010 17:43

ale to sklep dziala tylko cod mod wywala errory :(

Dodano 25 październik 2010 - 17:45:
Error: Number of arguments does not match definition on line 299
Error: Number of arguments does not match definition on line 311
Error: Undefined symbol "DajPrzedmiotX" on line 510
Error: Number of arguments does not match definition on line 510
Error: Number of arguments does not match definition on line 807
Error: Number of arguments does not match definition on line 897
Error: Number of arguments does not match definition on line 1050
Error: Number of arguments does not match definition on line 1065
Error: Number of arguments does not match definition on line 1086
Error: Number of arguments does not match definition on line 1148
Warning: Tag mismatch on line 1452
Warning: Tag mismatch on line 1452
Warning: Tag mismatch on line 1452
Warning: Tag mismatch on line 1452
Warning: Tag mismatch on line 1524
Warning: Tag mismatch on line 1524
Warning: Tag mismatch on line 1524
Warning: Tag mismatch on line 1524
Warning: Tag mismatch on line 1563
Warning: Tag mismatch on line 1563
Warning: Tag mismatch on line 1563
Warning: Tag mismatch on line 1563
Error: Argument does not have a default value (argument 2) on line 1972
Error: Symbol already defined: "plugin_init" on line 1982

12 Errors.


hyhy jeszcze wiecej ^^ :)

Dodano 25 październik 2010 - 17:47:
dlatego mowie moze zosatwic tego codmoda i zrobic osobny plugin z tego sklepu bo on dzialal za 1 razem tylko errory byly od codmoda
  • +
  • -
  • 0

#8 Blood Angel

    Wszechwiedzący

  • Zbanowany

Reputacja: 130
Zaawansowany

  • Postów:540
  • Steam:steam
  • Lokalizacja:Dom
Offline

Napisano 25.10.2010 18:55

Zrobione.

Błędy:
#include <colorhcat>

ma być:
#include <colorchat>

Nie było DajPrzedmiotX.
ZROBIONE!

0 Błędów.


Sajjuk, A ty kolego jak nie widzisz takich błędów ani się nie znasz nie pisz bo tylko posty wbijasz.

Załączone pliki


Użytkownik Blood Angel edytował ten post 25.10.2010 18:55

Znany jako oeN.


#9 szczypior

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Imię:szczypior
  • Lokalizacja:slask
Offline

Napisano 25.10.2010 20:27

poprawilem colorchata i wlasnie to mi wyskoczylo...

ech... juz chcialem dziekowac i ...


Error: Number of arguments does not match definition on line 299
Error: Number of arguments does not match definition on line 311
Error: Number of arguments does not match definition on line 807
Error: Number of arguments does not match definition on line 897
Error: Number of arguments does not match definition on line 1050
Error: Number of arguments does not match definition on line 1065
Error: Number of arguments does not match definition on line 1086
Error: Number of arguments does not match definition on line 1148
Warning: Tag mismatch on line 1452
Warning: Tag mismatch on line 1452
Warning: Tag mismatch on line 1452
Warning: Tag mismatch on line 1452
Warning: Tag mismatch on line 1524
Warning: Tag mismatch on line 1524
Warning: Tag mismatch on line 1524
Warning: Tag mismatch on line 1524
Warning: Tag mismatch on line 1563
Warning: Tag mismatch on line 1563
Warning: Tag mismatch on line 1563
Warning: Tag mismatch on line 1563
Error: Argument does not have a default value (argument 2) on line 2053

9 Errors.


ech... juz nie mam sily do tego

moze to ktos wrzucic .sma i .amxx

Dodano 25 październik 2010 - 20:28:
cos mi sie wydaje ze jakiegos modulu niemam albo mam zly ...

Dodano 25 październik 2010 - 20:31:
nie wiem dlaczego ale o to naprzyklad mu nie pasuje

menu_display(id, menu);

no niby dobrze, a error
  • +
  • -
  • 0

#10 pAC

    Wszechobecny

  • Zbanowany

Reputacja: 87
Zaawansowany

  • Postów:425
  • Steam:steam
  • Lokalizacja:Żagań
Offline

Napisano 25.10.2010 21:15

kompiluj lokalnie , ja niemam zadnych bledow ...

#11 szczypior

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Imię:szczypior
  • Lokalizacja:slask
Offline

Napisano 26.10.2010 14:39

lokalnie tzn.? na swoim kompie?

jesli tak to robie lokalnie i wlasnie sa errory daltego proszę o .amxx

(wiem ze robie problemy ale mi zalezy na tym plugu.)
  • +
  • -
  • 0

#12 pAC

    Wszechobecny

  • Zbanowany

Reputacja: 87
Zaawansowany

  • Postów:425
  • Steam:steam
  • Lokalizacja:Żagań
Offline

Napisano 26.10.2010 14:44

to trzymaj plik amxx

Załączone pliki



#13 szczypior

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Imię:szczypior
  • Lokalizacja:slask
Offline

Napisano 26.10.2010 17:19

dzięki zaraz wrzucam na serwa oby dzialalo :)

jeszcze raz wielkie dzięki...

Dodano 26 październik 2010 - 18:45:
ech... no tak bo po co ma dzialac

log z konsoli:

L 10/26/2010 - 19:33:01: [AMXX] [0] QTM_CodMod_+_nowe_Klasy_by_RomanPL2.sma::PokazInformacje (line 1880)
L 10/26/2010 - 19:33:01: HudSyncObject -1 is invalid
L 10/26/2010 - 19:33:01: [AMXX] Displaying debug trace (plugin "QTM_CodMod_+_nowe_Klasy_by_RomanPL.amxx")
L 10/26/2010 - 19:33:01: [AMXX] Run time error 10: native error (native "ShowSyncHudMsg")

na poczatku pisalo zeby dopisac debug w plugins.ini dopisalem i to wyskakuje.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych