Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Losowy Rendering Dla Gracza


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 AmD

    aemde

  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 17.10.2010 16:53

Witam!

Chciałem sobie zrobić Losowy Rendering ale coś mi nie wychodzi :)
zrobiłem tak:


public RendAmD(id)
{
new autoryzuj[2]
get_user_info(id, "_haslo", autoryzuj, 1);
if(str_to_num(autoryzuj) == 1) {
if(is_user_alive(id))
{
set_user_rendering(id, kRenderFxGlowShell, random(255), random(0), random(170), kRenderGlow, random(20));
set_task(30.0, "RendAmD",id+1111,_,_,"b");
}
else
remove_task(id+1111)
}
}

ale coś nie zmienia Koloru :/
dodałem też event nowej rundy dla tej funkcji ale nie pomogło (ani nie zmienia co 30sec ani jak się zrespie na nowej rundzie...)

Gdzie jest błąd?

Pozdrawiam!
  • +
  • -
  • 0

#2 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 17.10.2010 22:25

kRenderNormal zamiast kRenderGlow
  • +
  • -
  • 0

#3 AmD

    aemde

  • Autor tematu
  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 17.10.2010 23:48

nie pomogło :/

L 10/18/2010 - 00:46:47: Invalid player id 1112
L 10/18/2010 - 00:46:47: [AMXX] Displaying debug trace (plugin "kodi.amxx")
L 10/18/2010 - 00:46:47: [AMXX] Run time error 10: native error (native "get_user_info")
L 10/18/2010 - 00:46:47: [AMXX]    [0] kodi.sma::RendAmD (line 1779)
to ta linia:
get_user_info(id, "_haslo", autoryzuj, 1);
mam wpisane hasło w cfg!
  • +
  • -
  • 0

#4 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 18.10.2010 09:45

public RendAmD(id)
{
    id-=1111
oprócz tego skoro ustawiasz taska w klażdym callbacku to nie musi mieć flagi B
  • +
  • -
  • 0

#5 AmD

    aemde

  • Autor tematu
  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 18.10.2010 16:14

jeśli nadam to co napisałeś cała funkcja przestaje działać.


public RendAmD(id)
{
id-=1111
if(is_user_alive(id))
{
set_user_rendering(id, kRenderFxGlowShell, random(255), random(0), random(170), kRenderNormal, random(20));
set_task(30.0, "RendAmD",id+1111);
}
else
remove_task(id+1111)
}
tak wygląda cała funkcja.
dodam że funkcje wywołuję przez menu w formie...
bez tego "id-=1111" się uruchamia ale nie uruchamia się task.

Dodano 19 październik 2010 - 17:41:
@ref

Dodano 20 październik 2010 - 17:36:
@rf
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych