Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem - Block Maker


  • Zamknięty Temat jest zamknięty
5 odpowiedzi w tym temacie

#1 Złotówka

    Wszechwidzący

  • Użytkownik

Reputacja: 14
Początkujący

  • Postów:244
  • Imię:Adam
  • Lokalizacja:Łódź
Offline

Napisano 09.10.2010 14:17

Witam

Posiadam Block Maker'a udostępnionego w necie ( Linku nie podam ).

Z początku myślałem, że to w modelach tkwi problem, lecz po sprawdzeniu logów:

L 10/09/2010 - 14:57:54: Start of error session.
L 10/09/2010 - 14:57:54: Info (map "de_dust") (file "addons/amxmodx/logs/error_20101009.log")
L 10/09/2010 - 14:57:54: Function is not present (function "tskInitAfterCvars") (plugin "bm.amxx")
L 10/09/2010 - 14:57:54: [AMXX] Run time error 10 (plugin "bm.amxx") (native "set_task") - debug not enabled!
L 10/09/2010 - 14:57:54: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/09/2010 - 14:58:03: [FUN] Invalid player 1
L 10/09/2010 - 14:58:03: [AMXX] Run time error 10 (plugin "bm.amxx") (native "set_user_rendering") - debug not enabled!
L 10/09/2010 - 14:58:03: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/09/2010 - 15:00:28: Start of error session.
L 10/09/2010 - 15:00:28: Info (map "de_dust") (file "addons/amxmodx/logs/error_20101009.log")
L 10/09/2010 - 15:00:28: Function is not present (function "tskInitAfterCvars") (plugin "bm.amxx")
L 10/09/2010 - 15:00:28: [AMXX] Run time error 10 (plugin "bm.amxx") (native "set_task") - debug not enabled!
L 10/09/2010 - 15:00:28: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/09/2010 - 15:00:37: [FUN] Invalid player 1
L 10/09/2010 - 15:00:37: [AMXX] Run time error 10 (plugin "bm.amxx") (native "set_user_rendering") - debug not enabled!
L 10/09/2010 - 15:00:37: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/09/2010 - 15:04:05: Start of error session.
L 10/09/2010 - 15:04:05: Info (map "de_dust") (file "addons/amxmodx/logs/error_20101009.log")
L 10/09/2010 - 15:04:05: Function is not present (function "tskInitAfterCvars") (plugin "bm.amxx")
L 10/09/2010 - 15:04:05: [AMXX] Run time error 10 (plugin "bm.amxx") (native "set_task") - debug not enabled!
L 10/09/2010 - 15:04:05: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/09/2010 - 15:04:14: [FUN] Invalid player 1
L 10/09/2010 - 15:04:14: [AMXX] Run time error 10 (plugin "bm.amxx") (native "set_user_rendering") - debug not enabled!
L 10/09/2010 - 15:04:14: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/09/2010 - 15:07:26: Start of error session.
L 10/09/2010 - 15:07:26: Info (map "de_dust") (file "addons/amxmodx/logs/error_20101009.log")
L 10/09/2010 - 15:07:26: Function is not present (function "tskInitAfterCvars") (plugin "bm.amxx")
L 10/09/2010 - 15:07:26: [AMXX] Displaying debug trace (plugin "bm.amxx")
L 10/09/2010 - 15:07:26: [AMXX] Run time error 10: native error (native "set_task")
L 10/09/2010 - 15:07:26: [AMXX]    [0] Untitled.sma::plugin_init (line 645)
L 10/09/2010 - 15:07:35: [FUN] Invalid player 1
L 10/09/2010 - 15:07:35: [AMXX] Displaying debug trace (plugin "bm.amxx")
L 10/09/2010 - 15:07:35: [AMXX] Run time error 10: native error (native "set_user_rendering")
L 10/09/2010 - 15:07:35: [AMXX]    [0] Untitled.sma::eventRoundRestart (line 1709)

Jeśli będzie trzeba podam wycinek *sma

Proszę o pomoc. Dam +
  • +
  • -
  • 0

#2 Vertricus

    Godlike

  • Przyjaciel

Reputacja: 426
Wszechobecny

  • Postów:1549
  • Lokalizacja:.
Offline

Napisano 09.10.2010 14:24

brakuje funkcji tskInitAfterCvars
usuń taska albo dodaj funkcję
  • +
  • -
  • 0

#3 Złotówka

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 14
Początkujący

  • Postów:244
  • Imię:Adam
  • Lokalizacja:Łódź
Offline

Napisano 09.10.2010 14:27

W Kodzie jest coś takiego
set_task(1.0, "tskInitAfterCvars", 0, "", 0, "", 0);
}

  • +
  • -
  • 0

#4 Abes Mapper

    Repulsion Gel

  • Przyjaciel

Reputacja: 1996
Godlike

  • Postów:7356
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Sulejówek
Offline

Napisano 09.10.2010 14:56

A ja podam link, a co! :)
AlliedModders
  • +
  • -
  • 0

#5 Złotówka

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 14
Początkujący

  • Postów:244
  • Imię:Adam
  • Lokalizacja:Łódź
Offline

Napisano 09.10.2010 15:11

brakuje funkcji tskInitAfterCvars
usuń taska albo dodaj funkcję


Jak usunąłem task to wywala błędy, a jaką funkcje i gdzie dodać?

Użytkownik Znak Zapytania? edytował ten post 09.10.2010 15:34

  • +
  • -
  • 0

#6 GwynBleidD

    Godlike

  • Administrator

Reputacja: 1849
Godlike

  • Postów:3066
  • Steam:steam
  • Lokalizacja:Przemyśl
Offline

Napisano 09.10.2010 16:20

Kolega Abes Mapper dał z tego co widzę link do poprawionej wersji (jest funkcja oraz sprawdzanie czy gracz istnieje, także błędy z error loga nie powinny występować ;))
  • +
  • -
  • 0
NIE pomagam na PW. Nie trudź się, na zlecenia nie odpiszę... Od pomagania jest forum.
NIE zaglądam w tematy wysłane na PW. Jeśli są na forum to prędzej czy później je przeczytam. Jeśli mam co w nich odpisać, to odpiszę.
 
1988650.png?theme=dark




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych