Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[NOWE MENU KLAS]


  • Zamknięty Temat jest zamknięty
11 odpowiedzi w tym temacie

#1 Reprezentant

    Pomocny

  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 08.10.2010 20:32

kazda klase mozna wybrac 1 strona menu dziala dobrze (standardowe klasy). druga strona klas wywoluje klasy po nacisnieciu 3 strone a klasy z 3 strony nie dzialaja. a w nowej rundzie nie ma paska z lvl.. mam 20 klas w nowym menu + latwe dodawanie klas by GoQ.. gdzie lezy przyczyna?

#2 sebul

    Godlike

  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 08.10.2010 20:44

Bez sma nikt Ci raczej nie pomoże...
  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#3 Reprezentant

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 08.10.2010 20:49

sma tylko na pw lub dana czesc kodu

#4 Szyfrant

    Godlike

  • Przyjaciel

Reputacja: 1365
Godlike

  • Postów:3072
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Sztokholm
Offline

Napisano 08.10.2010 20:50

Napisz to normalnie. Napisałeś bardzo chaotycznie.
  • +
  • -
  • 0

#5 Pawex

    Wszechpomocny

  • Użytkownik

Reputacja: 94
Zaawansowany

  • Postów:381
  • Lokalizacja:Polska
Offline

Napisano 08.10.2010 20:52

To daj czesc kodu...
  • +
  • -
  • 0

#6 Reprezentant

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 08.10.2010 20:56

ok. po kolei
1.pobralem sma z poradnika GoQ
2.dopisalem klasy (20 lacznie jest)
3.
public mcb_create_class(id, menu, item) {
new flags[10]
get_cvar_string("diablo_classes",flags,20)
new keys = read_flags(flags)

if(keys&(2<<item))
return ITEM_ENABLED

return ITEM_DISABLED
}

zmienilem 9 na 20 (patrz wyzej) bo nie dalo sie wybrac klas tych nowych
a 1 zmienilem na 2 (patrz wyzej) bo wogóle sie nie dalo nic wybrac
4.dopisalem flagi.
5.menu dziala w nastepujacy sposob 1 strona normalnie. druga strona. wybierajac 1 klase z 2 strony wybiera nam klase z 3 strony itd a klasy z 3 strony wogóle nie dzialaja po wybraniu na dole nie ma paska z nazwa klasy lvl i itm.

to chyba lepiej jest teraz

Dodano 08 październik 2010 - 21:56:
@up napisz jakie funkcje

Dodano 09 październik 2010 - 10:11:

enum { NONE = 0,Mag,Mnich,Paladyn,Zabojca,Nekromanta,Barbarzynca,Ninja,Hunter,klasa,klasa,klasa,klasa,klasa,klasa,klasa,klasa,klasa,klasa,klasa,klasa }
new Race[][] = { "None","Mag","Mnich","Paladyn","Zabojca","Nekromanta","Barbarzynca","Ninja","Lowca","klasa","klasa","klasa","klasa","klasa","klasa","klasa","klasa","klasa","klasa","klasa","klasa" }
new race_heal[] = { 100,95,150,130,100,90,110,170,120,100,100,90,100,100,100,140,80,100,75,110,120}


register_cvar("diablo_classes", "abcdefghijklmnoprstu")

public mcb_create_class(id, menu, item) {
new flags[10]
get_cvar_string("diablo_classes",flags,20)
new keys = read_flags(flags)

if(keys&(1<<item))
return ITEM_ENABLED

return ITEM_DISABLED
}

[sma]

#7 Pawex

    Wszechpomocny

  • Użytkownik

Reputacja: 94
Zaawansowany

  • Postów:381
  • Lokalizacja:Polska
Offline

Napisano 09.10.2010 09:52

A patrzysz Czy tam masz takie wczytywanie nr klasy dobry? Nie patrzylem na te menu GoQ'a i nie wiem czy to tam jest, ale sprawdz. Jak masz wczytywanie tych numerow to zobacz czy dobrze masz powpisywane.
  • +
  • -
  • 0

#8 Reprezentant

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 09.10.2010 10:37

chodzi Ci o
new Race[][]

tam w [ ]? to powinno byc puste tez myslalem ze moze cos tutaj ale jak wpisze to sa bledy przy kompilacji

#9 Pawex

    Wszechpomocny

  • Użytkownik

Reputacja: 94
Zaawansowany

  • Postów:381
  • Lokalizacja:Polska
Offline

Napisano 09.10.2010 13:37

Nieeee.... Nie masz tam load class [nr] ?
  • +
  • -
  • 0

#10 Reprezentant

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 09.10.2010 15:22

nie ma ;o podaj dokladnie co wkleic ;>

#11 hefcio

    Życzliwy

  • Użytkownik

Reputacja: 5
Nowy

  • Postów:33
  • Lokalizacja:Polska
Offline

Napisano 09.10.2010 17:47

tu we flags masz 10 a nizej 20 oO

new flags[10]
get_cvar_string("diablo_classes",flags,20)
  • +
  • -
  • 0

#12 Mesh

    Wszechwidzący

  • Zbanowany

Reputacja: 36
Życzliwy

  • Postów:268
  • GG:
  • Steam:steam
  • Lokalizacja:Lukow
Offline

Napisano 09.10.2010 18:02

Tak ale po poprawieniu tego i tak nie dziala

Użytkownik Mesh edytował ten post 09.10.2010 18:03





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych