Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Avek steam a Motd


  • Zamknięty Temat jest zamknięty
30 odpowiedzi w tym temacie

#1 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 07.10.2010 16:11

Więc mam do was pytanie xP czy jest taka opcja żeby wziąć avek ze steam tabeli wyników i odpalić go w MOTD ?? :)

#2 Ortega

    mów mi Orti

  • Power User

Reputacja: 361
Wszechpomocny

  • Postów:640
  • GG:
  • Steam:steam
  • Imię:Marcin
  • Lokalizacja:Sosnowiec
Offline

Napisano 07.10.2010 16:30

Nie ma takiej możliwości, bo avatar ze steam pobiera gra, po stronie klienta, serwer nie ma nic do tego. Chociaż jeśli byś się dowiedział gdzie steam przechowuje u siebie te avatary to mógłbyś użyć html w motd do ich wyświetlenia(głupi pomysł), bo gracz widzi je w tablicy wyników( wtedy tworzy się tymczasowy folder z avkami ).
  • +
  • -
  • 0

#3 hardbot

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 07.10.2010 16:35

Tak :) to racja takiej odpowiedzi się spodziewałem lecz, chciałbym zrobić coś takiego (lecz widzę że się nie da) że NoNSteamowcy widzą w tym MOTD te avki xD bo przecież oni nie mają połączenia z Steam i nie pobierają tych avków :P

#4 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 07.10.2010 16:37

właściwie to jest :P widziałem gdzieś kod, który na podstawie steamid oblicza link do profilu na steamie, idziesz tam socketsami i przeglądasz kod w poszukiwaniu obrazka (pewnie ma jakieś id lub unikatową klasę), z img bierzesz src i masz bezwględny link do avatara co go możesz użyć w motd :P może kiedyś będzie mi się chciało w to bawić, na razie nie widzę takiej potrzeby
  • +
  • -
  • 0

#5 hardbot

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 07.10.2010 17:19

:) :) :) To miło :P

Jak będzie ci się chcieć to będzie ^^ :P


Temat do zamknięcia.

#6 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 09.10.2010 15:32

Właściwie to prawie nic nie musiałem robić: Convert STEAMID to Steam Community ID - Page 5 - AlliedModders

Potem tylko regex w dłoń i mamy link

<img src="http://twoja.domena/avatars/index.php?sid=STEAMID">
+chmod 600 na folder cache

Załączone pliki


  • +
  • -
  • 1

#7 hardbot

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 09.10.2010 17:10

:( nie działa coś :(

Nawet jak swoje steamID wkleiłem to też puste okienko :( nie wiem co jest nie tak :(

xD jeszcze jedno triko bo NSy mają standard VALVE_LAN i to jakoś nie czyta się z tym ;D bo wyskakiwał mi napis zamiast pustego okienka :o

Użytkownik hardbot edytował ten post 09.10.2010 17:34


#8 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 09.10.2010 17:44

shostowałeś ten plik/folder?

php raczej nie zadziała na serwerze gry
  • +
  • -
  • 0

#9 hardbot

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 09.10.2010 18:17

xD :D Czyli o co to dokładniej chodzi
(Szyfranta nie ma :/ a nie mam portu do serwera co on mi udostępnił :/)

i nie mam jak sprawdzić :D


Co do plików to all na ftp dałem i tak jak idzie ten LInczek do Imag to wstawiłem sobie i nie działa, na PW ci poślę SMA.

Użytkownik hardbot edytował ten post 09.10.2010 18:18


#10 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 09.10.2010 18:58

Mając STEAM_ID użytkownika przeliczamy go:
na wartość liczbową. dla PHP* będzie to:
$steam = "STEAM_0:0:14515212";
$parts = explode(':', $steam);
$server = $parts[1];
$auth = $parts[2];
$friend = bcmul($auth, "2");
$friend = bcadd($friend, bcadd("76561197960265728", $server));


i mamy link do profilu w postaci
http://steamcommunity.com/profiles/{$friend}

Teraz aby otrzymać XML który łatwiej się obsługuje do linku dodajemy "?xml=1"

http://steamcommunity.com/profiles/76561197989296152?xml=1
lub
http://steamcommunity.com/id/pavulon87?xml=1

potem jeżeli nie mamy parsera xml to mały regexp i mamy np. adres avatara.

	<avatarIcon><![CDATA[http://media.steampowered.com/steamcommunity/public/images/avatars/f8/f860a902b125fe9833b922b57e3adfbda1e5a19d.jpg]]></avatarIcon>
<avatarMedium><![CDATA[http://media.steampowered.com/steamcommunity/public/images/avatars/f8/f860a902b125fe9833b922b57e3adfbda1e5a19d_medium.jpg]]></avatarMedium>
<avatarFull><![CDATA[http://media.steampowered.com/steamcommunity/public/images/avatars/f8/f860a902b125fe9833b922b57e3adfbda1e5a19d_full.jpg]]></avatarFull>


* - bcmul i bcadd dla zmyłki :D
  • +
  • -
  • 1

#11 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 09.10.2010 19:03

http://www.adminscri...AM_0:0:25484058
  • +
  • -
  • 0

#12 hardbot

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 09.10.2010 19:37

a jak ustawić dany AVEK pod STEAM_ID_LAN :D

bo NSą wyskoczy okienko z Xem :o i w tedy cóż to będzie?

#13 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 09.10.2010 19:45

w kodzie wywalam w takich przypadkach 404, możesz zamiast tego wysłać własny obrazek :D zaraz zrobię update
  • +
  • -
  • 0

#14 hardbot

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 09.10.2010 20:35

w kodzie wywalam w takich przypadkach 404, możesz zamiast tego wysłać własny obrazek :D zaraz zrobię update

Nie trza :P będę się orientował ^^ ^^ i tak dużo zrobiłeś :P

#15 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 09.10.2010 20:53

ahh, zabrakło jednego ifa ;P

$friendid = steam2friend($_GET['sid']);
if($friendid === false){
        header("HTTP/1.0 404 Not Found");
	exit();
}
$cacheFile = "cache/$friendid.jpg";

  • +
  • -
  • 0

#16 hardbot

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 09.10.2010 21:04

ahh, zabrakło jednego ifa ;P

$friendid = steam2friend($_GET['sid']);
if($friendid === false){
        header("HTTP/1.0 404 Not Found");
	exit();
}
$cacheFile = "cache/$friendid.jpg";

xD wiesz co :D lepiej daj te UPDate bo już się zgubiłem :D
a co do obrazka to coś nie łapie dałem inny Link z innym SIDem do adresu i pustka :(

http://steam-script....AM_0:0:25747252

#17 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 09.10.2010 21:17

Grzebałeś w kodzie ;P

wersja .02 zgodnie z opisem Pavulona (mniej tekstu do przetworzenia, więc działa szybciej)

Załączone pliki


  • +
  • -
  • 1

#18 hardbot

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 09.10.2010 22:13

Teraz czyta ! w MOTD xD ale tylko to INVALID :D
tego Xa tylko czyta :P a tak to nawet w Przeglądarce jak SID dałem to też ukazało Xsa :D

#19 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 09.10.2010 22:23

dowiedz się które displayInvalid powoduje ten obrazek, a powiem Ci co masz poprawić; u mnie na lokalu działa dobrze, więc nei wiem jak inaczej pomóc
  • +
  • -
  • 0

#20 hardbot

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 09.10.2010 22:30

W sensie tylko jeden jest ten displayInvalid :D




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych