Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[NOWE MENU KLAS] + RESET TABELI?


  • Zamknięty Temat jest zamknięty
14 odpowiedzi w tym temacie

#1 Reprezentant

    Pomocny

  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 06.10.2010 13:44

pobralem sma z tematu nowe menu klas + latwe dodawanie menu dziala lecz te nowe klasy sa na szaro :( slyszalem ze trzeba zrobic reset tabeli czy jakos tak chyba chodzi o te przecinki w klasach spacjuje je (przestawiam) lecz ciagle nie dziala


enum { NONE = 0, Mag, Mnich, Paladyn, Zabojca, Nekromanta, Barbarzynca, Ninja, Hunter,klasa,klasa,klasa,klasa,klasa,klasa,klasa,klasa,klasa,klasa,klasa,klasa }
new Race[][] = { "None","Mag","Mnich","Paladyn","Zabojca","Nekromanta","Barbarzynca", "Ninja", "Lowca","klasa","klasa","klasa","klasa","klasa","klasa","klasa","klasa","klasa","klasa","klasa","klasa" }
new race_heal[] = { 100,95,150,130,100,90,110,170,120 ,100 ,100 ,90 ,100 ,100 ,100 ,140 ,80 ,100 ,75 ,110 ,120}


Dodano 06 październik 2010 - 14:49:
register_cvar("diablo_classes", "abcdefghijklmnoprstu")

#2 Kusek

    z Wikipedii

  • Power User

Reputacja: 445
Wszechobecny

  • Postów:1655
  • Imię:Krystian
  • Lokalizacja:Nowa Dęba
Offline

Napisano 06.10.2010 13:59

[5.9l] Nowa klasa bez resetu exp (SQL) - Nieoficjalny polski support AMX Mod X
  • +
  • -
  • 0

#3 Reprezentant

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 06.10.2010 14:14

widze ze mnie nie rozumiesz.
uzywam "latki" [Tutorial] Latwe dodawanie klas + nowe menu

Dodano 06 październik 2010 - 15:18:
w bazie danych sie wszystko tworzy. tylko klasy sa na szaro z poczatku myslalem ze chodzi o register_cvar("diablo_classes", "abcdefghijklmnoprstu")
ale tam jest 20 liter

#4 ^^^Deed

    Zaawansowany

  • Użytkownik

Reputacja: 15
Początkujący

  • Postów:90
  • Steam:steam
  • Lokalizacja:LondYn
Offline

Napisano 06.10.2010 14:45

To głównie chodzi o to.
Czy zmieniałeś na serverze cvar?
  • +
  • -
  • 0
80.72.37.13:27060 - Diablo Mod jakiego nigdy nie widziałeś!

#5 Reprezentant

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 06.10.2010 15:11

cvar? dokladnie ktory??

diablo_sql_host "*"
diablo_sql_user "*"
diablo_sql_pass "*"
diablo_sql_database "*"
diablo_sql_table

diablo_xpbonus 250 ilość expa za zabicie standardowo ustawione na 7
diablo_xpbonus2 500 ilość expa za wykonania celu misji standardowo ustawione na 50
diablo_durability 5 Tracisz wytrzymałość za każde obrażenia ? Ile za każdym razem
diablo_spawnchance 1/x szansa na zrespienia worka
SaveXp 1/0 zapisywanie doświadczenia
diablo_avg  1 - zaczynanie od sredniej serwera (liczonego od lvl 1)
diablo_dmg_exp - za ile zabranego hp wrogowi dostaje sie 1 exp (domyslnie 20, 0 - off)

Dodano 06 październik 2010 - 16:42:
dodalem
diablo_classes "abcdefghijklmnoprstu"

1 klasa zostala zablokowana "MAG"
a 1 z kaca zostala odblokowana reszta sie nie zmienila ;/

#6 Weed

    Zaawansowany

  • Użytkownik

Reputacja: 13
Początkujący

  • Postów:108
  • Imię:Ganjor
  • Lokalizacja:Holandia
Offline

Napisano 06.10.2010 15:52

new race_heal[]
new Race[][]

Tutaj zadnych cyfr nie masz...;P czy tak specjalnie podales/;>
  • +
  • -
  • 0

Dołączona grafika


#7 Reprezentant

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 06.10.2010 15:56

czytales poradnik ktory podalem w poscie wyzej?? tam pisze zeby usunac.

#8 Weed

    Zaawansowany

  • Użytkownik

Reputacja: 13
Początkujący

  • Postów:108
  • Imię:Ganjor
  • Lokalizacja:Holandia
Offline

Napisano 06.10.2010 16:13

aha sorki;>
  • +
  • -
  • 0

Dołączona grafika


#9 Reprezentant

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 06.10.2010 16:15

czyli nie potrafisz pomoc :(?

Dodano 06 październik 2010 - 20:35:
refresh

#10 hefcio

    Życzliwy

  • Użytkownik

Reputacja: 5
Nowy

  • Postów:33
  • Lokalizacja:Polska
Offline

Napisano 06.10.2010 19:38

reset tabeli = reset leveli na diablo, więc musisz, wyczyscic baze sqla, bądź skożystać z tego poradnika co kolega "frajer" wyżej podał, dodawanie klas bez resetu
  • +
  • -
  • 0

#11 Reprezentant

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 06.10.2010 19:43

czy wy nie umiecie czytac tego co ja pisze wyzej.? klasy do sql sie dodaja. ma usunac baze danych ktorej jeszcze nie ma?? zamowilem serwer przerobilem diablo. kompilacja bez bledow. lecz klasy nie dzialaja jak nie wiecie to nie spamujcie.

#12 hefcio

    Życzliwy

  • Użytkownik

Reputacja: 5
Nowy

  • Postów:33
  • Lokalizacja:Polska
Offline

Napisano 06.10.2010 19:45

a Ty myslisz ze po dodaniu 3 wersów pluginu, każdy znajdzie problem ? Ja miałem np to co Ty masz, to się okazało, że menu nie wywoływało funkcji wybierania klas, więc musiałem skożystać z innego menu
  • +
  • -
  • 0

#13 Reprezentant

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:53
  • Lokalizacja:w .sma
Offline

Napisano 06.10.2010 19:48

ja znalazlem blad ze klasy sa na szaro tak jak w poradniku GoQ pisze ze zresetowac tabelki ale nie expa.. tylko klas w .sma robie i nic wiec pisze jak robilem i co nie dziala. jak ktos bedzie chcial to dam inna czesc kodu.

Dodano 08 październik 2010 - 13:54:
refresh

#14 G[o]Q

    I'm G[o]Q

  • Przyjaciel

Reputacja: 1339
Godlike

  • Postów:3556
  • Steam:steam
  • Imię:Krzysiek
  • Lokalizacja:C: / program Files / Valve / Cstrike / G[o]Q.dem
Offline

Napisano 08.10.2010 16:12

hmm pokaz funkcje w ktorej wystepuje
read_flags
(nie pamietam nazwy)
  • +
  • -
  • 2
Manual ponad wszystko, konsola ponad manual :D :&

Chcesz wysłać do mnie PW ? użyj nazwy GoQ zamiast G[o]Q
Chcesz Kupić moduł płatności via Pukawka,Tserwery, Gamesol, Zabijaka do mojego sklepu? napisz PW cena to tylko 10 zł/sztuka

GG:6022845 (nie pomagam za free osobom ponizej rangi MoD) :D

#15 Mesh

    Wszechwidzący

  • Zbanowany

Reputacja: 36
Życzliwy

  • Postów:268
  • GG:
  • Steam:steam
  • Lokalizacja:Lukow
Offline

Napisano 08.10.2010 16:27


public mcb_create_class(id, menu, item) {
new flags[10]
get_cvar_string("diablo_classes",flags,9)
new keys = read_flags(flags)

if(keys&(1<<item))
return ITEM_ENABLED

return ITEM_DISABLED
}




get_cvar_string("diablo_classes",flags,9)

widze blad tutaj nie powinno byc 9 bo flag jest wiecej a tutaj jest okreslone pokazywac tylko 9 zmien w poradniku gdy ktos dodaje klasy zeby zemil ta liczbe

Użytkownik Mesh edytował ten post 08.10.2010 16:32





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych