Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[Nvault] Nie zapisuje/odczytuje danych z pliku...


  • Zamknięty Temat jest zamknięty
30 odpowiedzi w tym temacie

#21 ...

    Wszechmogący

  • Zbanowany

Reputacja: 166
Profesjonalista

  • Postów:612
  • Lokalizacja:Jasło
Offline

Napisano 02.10.2010 16:14

to bedzie co zmiane bronii / strzal dodawalo predkosci
get_user_maxspeed(id) zamien na 1.0

#22 AmD

    aemde

  • Autor tematu
  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 02.10.2010 16:35

to samo :/

a zapomniałem jeszcze że teraz sypie logami...

L 10/02/2010 - 17:34:21: [FUN] Invalid player 1
L 10/02/2010 - 17:34:21: [AMXX] Displaying debug trace (plugin "Fastbh_menu_v43.amxx")
L 10/02/2010 - 17:34:21: [AMXX] Run time error 10: native error (native "get_user_gravity")
L 10/02/2010 - 17:34:21: [AMXX]    [0] Fastbh_menu_v43.sma::spawned (line 3428)

a co innego może być linią 3428?

new Float:graw = get_user_gravity(id)


kyku zaraz sprawdzę...

@edit

teraz to mam prędkość 6.0/250.0 z USP (standard)

Dodano 03 październik 2010 - 17:45:
@ref

Użytkownik AmD edytował ten post 02.10.2010 16:44

  • +
  • -
  • 0

#23 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6034
Godlike

  • Postów:10832
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 03.10.2010 21:14

na samym początku dodaj warunek
if(!is_user_alive(id)){
return HAM_IGNORED;
}
  • +
  • -
  • 1

#24 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6034
Godlike

  • Postów:10832
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 03.10.2010 21:18

miśki !
set_user_maxspeed możemy podać 1.0 itp ale on bedize strasznie wolno biegł !
podajemy np 250.0 a tak naprawdę powinno byc
w evencie zmiany broni
new bron=read_data(2)
set_user_maxspeed(id,gfCSSpeeds[bron]+30.0);
i jako global
new const Float:gfCSSpeeds[]={
000.0,
250.0, 000.0, 260.0, 250.0, 240.0,
250.0, 250.0, 240.0, 250.0, 250.0,
250.0, 250.0, 210.0, 240.0, 240.0,
250.0, 250.0, 210.0, 250.0, 220.0,
230.0, 230.0, 250.0, 210.0, 250.0,
250.0, 235.0, 221.0, 250.0, 245.0
};
i dizęki temu zawsze będzie o 30.0 szybciej biegać grrr powinieneś już wiedzieć co masz źle a raczej gdzie masz za małe liczby
  • +
  • -
  • 1

#25 AmD

    aemde

  • Autor tematu
  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 03.10.2010 21:57

wnioskuję z tego że moje funkcje powinny wyglądać tak:

public spawned(id) {
new Float:graw = get_user_gravity(id)
//new Float:speed = get_user_maxspeed(id)
if(!is_user_alive(id)){
return HAM_IGNORED;
}
if(PtkGraw[id] > 0){
switch(PtkGraw[id]){
case 1: set_user_gravity(id, graw -0.1)
case 2: set_user_gravity(id, graw -0.12)
case 3: set_user_gravity(id, graw -0.14)
case 4: set_user_gravity(id, graw -0.16)
case 5: set_user_gravity(id, graw -0.17)
case 6: set_user_gravity(id, graw -0.18)
case 7: set_user_gravity(id, graw -0.20)
case 8: set_user_gravity(id, graw -0.27)
case 9: set_user_gravity(id, graw -0.29)
case 10: set_user_gravity(id, graw -0.35)
}
}
if(PtkCzar[id] == 1)
{
set_user_rendering(id, kRenderFxGlowShell, 0, 0, 255, kRenderGlow, 20)
}
return HAM_IGNORED
}


ponieważ mój curweapon jest inny daje go całego razem z twoimi zaleceniami:

public curweapon(id)
{
new WeaponNum = read_data(2)
new WeaponActive = read_data(1)
//UstawSzybkosc(id);
//set_task(0.1,"UstawSzybkosc",id+TASK_SZYBKOSC_GRACZA);

if(PtkSpeed[id] > 0){
switch(PtkSpeed[id]){
case 1: set_user_maxspeed(id,gfCSSpeeds[WeaponNum]+10.0);
case 2: set_user_maxspeed(id,gfCSSpeeds[WeaponNum]+15.0);
case 3: set_user_maxspeed(id,gfCSSpeeds[WeaponNum]+20.0);
case 4: set_user_maxspeed(id,gfCSSpeeds[WeaponNum]+22.0);
case 5: set_user_maxspeed(id,gfCSSpeeds[WeaponNum]+24.0);
case 6: set_user_maxspeed(id,gfCSSpeeds[WeaponNum]+26.0);
case 7: set_user_maxspeed(id,gfCSSpeeds[WeaponNum]+28.0);
case 8: set_user_maxspeed(id,gfCSSpeeds[WeaponNum]+30.0);
case 9: set_user_maxspeed(id,gfCSSpeeds[WeaponNum]+32.0);
case 10: set_user_maxspeed(id,gfCSSpeeds[WeaponNum]+34.0);
}
}


if ((WeaponNum != g_WeaponUsed[id]) && WeaponActive)
{
g_WeaponUsed[id] = WeaponNum

if(get_pcvar_num(kz_maxspeedmsg) == 1)
{
new clip, ammo, speed
switch(get_user_weapon(id,clip,ammo))
{
case CSW_SCOUT: speed = 260
case CSW_C4, CSW_P228, CSW_MAC10, CSW_MP5NAVY, CSW_USP, CSW_TMP, CSW_FLASHBANG, CSW_DEAGLE, CSW_GLOCK18, CSW_SMOKEGRENADE, CSW_ELITE, CSW_FIVESEVEN, CSW_UMP45, CSW_HEGRENADE, CSW_KNIFE: speed = 250
case CSW_P90: speed = 245
case CSW_XM1014, CSW_AUG, CSW_GALIL, CSW_FAMAS: speed = 240
case CSW_SG552: speed = 235
case CSW_M3, CSW_M4A1: speed= 230
case CSW_AK47: speed = 221
case CSW_M249: speed = 220
case CSW_G3SG1, CSW_SG550, CSW_AWP: speed = 210
}

kz_hud_message(id,"Maksymalna Predkosc z Ta Bronia Wynosi: %d",speed)
}
}
//set_task(0.1, "curweapon", id)
return PLUGIN_HANDLED
}


nadal na zarejestrowanym evencie:

register_event("CurWeapon","curweapon","be")


ale dalej Plugin wyrzuca błędy oraz nie działa prędkość...

@edit

poprawiłem logi musiałem dać tylko to przed floatem ;d

Użytkownik AmD edytował ten post 03.10.2010 22:10

  • +
  • -
  • 0

#26 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6034
Godlike

  • Postów:10832
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 04.10.2010 10:13

sprawdź czy napewno to sięwykonuje po
if(PtkSpeed[id] > 0){
daj client_print(id,print_chat,"Lubie AMXX.PL")'
jak nie zobaczysz na czacie Lubie AMXX.PL
znaczy to że nie ustawiasz PtkSpeed[id] na więcej niż 0
  • +
  • -
  • 1

#27 AmD

    aemde

  • Autor tematu
  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 04.10.2010 16:30


Welcome to Counter-Strike
Lubie AMXX.PL
Lubie AMXX.PL
Lubie AMXX.PL
Lubie AMXX.PL
raczej funkcja jest wywoływana...

daje SS:
http://img101.images.../8480/ssstb.png


licznik prędkości pokazuje z USP 250.0

Użytkownik AmD edytował ten post 04.10.2010 16:35

  • +
  • -
  • 0

#28 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6034
Godlike

  • Postów:10832
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 04.10.2010 18:53

daj client_print(id,print_chat,"%d",PtkSpeed[id)
i zobacz czy cosnie wymusza standardowej prędkości
po porstu poszukaj all set_user_maxspeed w kodzie :D
  • +
  • -
  • 1

#29 AmD

    aemde

  • Autor tematu
  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 04.10.2010 19:31

coś jednak jest nie tak...
skill jest na max a pokazuje jakby był na poziomie 1...
zamiast wyświetlać liczbę 34 wyświetla 10...

a tak to nic godnego uwagi w kodzie jeśli chodzi o daną funkcje...

jak chcesz to ci podeśle sma na PW zobaczysz ;)

Użytkownik AmD edytował ten post 04.10.2010 19:31

  • +
  • -
  • 0

#30 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6034
Godlike

  • Postów:10832
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 04.10.2010 20:36

ty ty dałeś tylko 10 caseow czyli jak PtkSpeed[id] jest mniejsze od 1 lub większe od 10 to nic się nie wykona i nie doda ci speeda
  • +
  • -
  • 1

#31 AmD

    aemde

  • Autor tematu
  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 04.10.2010 20:57

mam PtkSpeed na 10...

Dowód:
http://img529.images.../4013/sssji.png

jednak dam ci SMA na pw ;) jeśli będziesz chciał to zobaczysz może znajdziesz błąd ;)

Dodano 05 październik 2010 - 17:59:
@odśwież.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych