Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z ladowaniem HPDla paru klas


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 Onyke

    Godlike

  • Przyjaciel

Reputacja: 705
Guru

  • Postów:2178
Offline

Napisano 18.09.2010 17:49

Witam.
Chciałbym dodać regeneracje HP na każdej broni PARU klasą

Kod Vertricusa znaleziony na forum.
plugin_init

register_think("HealBot", "HealBotThink");
CreateHealBot();

koniec sma

CreateHealBot()
{
new Bot = engfunc(EngFunc_CreateNamedEntity, engfunc(EngFunc_AllocString, "info_target"));
if (Bot)
{
set_pev(Bot, pev_classname, "HealBot");
dllfunc(DLLFunc_Spawn, Bot);
set_pev(Bot, pev_nextthink, get_gametime() + 5.0);
}
}
public HealBotThink(Bot)
{
new iPlayers[32], iNum, id;
get_players(iPlayers, iNum);
for(new i; i<iNum; i++)
{
id = iPlayers[i];
if (!is_user_alive(id)) continue;
if (player_class[id] != Twoja_Klasa) continue;

change_health(id,30,0,"");
}
set_pev(Bot, pev_nextthink, get_gametime() + 5.0);
}


Sprawa wydaje się banalnie prosta ale za cholerę nie mogę sobie poradzić.
Mianowicie.
Jak zrobić żeby ładowało przykładowo
klasa1 10hp co 5 sekund
klasa2 5 hp co 10 sekund
klasa3 30hp co 10 sekund
?

Pozdrawiam.
  • +
  • -
  • 0

#2 Weed

    Zaawansowany

  • Użytkownik

Reputacja: 13
Początkujący

  • Postów:108
  • Imię:Ganjor
  • Lokalizacja:Holandia
Offline

Napisano 18.09.2010 18:37

tez mam w tym prolem;> co napisalem w swoim tmacie...
CreateHealBot()
{
        new Bot = engfunc(EngFunc_CreateNamedEntity, engfunc(EngFunc_AllocString, "info_target"));
        if (Bot)
        {
                set_pev(Bot, pev_classname, "HealBot");
                dllfunc(DLLFunc_Spawn, Bot);
               set_pev(Bot, pev_nextthink, get_gametime() + 5.0);
        }
}

set_pev(Bot, pev_nextthink, get_gametime() + 5.0);
Tutaj jakos else 3ba pewnie dodac...

i tutaj:|

public HealBotThink(Bot)
{
        new iPlayers[32], iNum, id;
        get_players(iPlayers, iNum);
        for(new i; i<iNum; i++)
        {
                id = iPlayers[i];
                if (!is_user_alive(id)) continue;
                if (player_class[id] != Twoja_Klasa) continue;
                
                 change_health(id,30,0,"");
        }
       set_pev(Bot, pev_nextthink, get_gametime() + 5.0);
}

if (player_class[id] != Twoja_Klasa) continue;
                
                 change_health(id,30,0,"");
        }
       set_pev(Bot, pev_nextthink, get_gametime() + 5.0);

Ale jak i o to jest pytanie:P

Użytkownik Weed edytował ten post 18.09.2010 18:39

  • +
  • -
  • 0

Dołączona grafika


#3 KariiO

    Super Hero

  • Power User

Reputacja: 395
Wszechpomocny

  • Postów:1133
  • GG:
  • Imię:Korneliusz
  • Lokalizacja:Cieszyn
Offline

Napisano 18.09.2010 22:24

Witam.
Chciałbym dodać regeneracje HP na każdej broni PARU klasą

Kod Vertricusa znaleziony na forum.
plugin_init


register_think("HealBot", "HealBotThink");
CreateHealBot();

koniec sma

CreateHealBot()
{
new Bot = engfunc(EngFunc_CreateNamedEntity, engfunc(EngFunc_AllocString, "info_target"));
if (Bot)
{
set_pev(Bot, pev_classname, "HealBot");
dllfunc(DLLFunc_Spawn, Bot);
set_pev(Bot, pev_nextthink, get_gametime() + 5.0);
}
}
public HealBotThink(Bot)
{
new iPlayers[32], iNum, id;
get_players(iPlayers, iNum);
for(new i; i<iNum; i++)
{
id = iPlayers[i];
if (!is_user_alive(id)) continue;
if (player_class[id] != Twoja_Klasa) continue;

change_health(id,30,0,"");
}
set_pev(Bot, pev_nextthink, get_gametime() + 5.0);
}


Sprawa wydaje się banalnie prosta ale za cholerę nie mogę sobie poradzić.
Mianowicie.
Jak zrobić żeby ładowało przykładowo
klasa1 10hp co 5 sekund
klasa2 5 hp co 10 sekund
klasa3 30hp co 10 sekund
?

Pozdrawiam.

3 Boty nie wchodzą w grę ?
  • +
  • -
  • 1

#4 Onyke

    Godlike

  • Autor tematu
  • Przyjaciel

Reputacja: 705
Guru

  • Postów:2178
Offline

Napisano 19.09.2010 08:29

Niby działa tylko jakiś warning wyskakuje.
+
  • +
  • -
  • 0

#5 Adminek AMXX.PL

    Admin :)

  • Bot

Reputacja: 156
Profesjonalista

  • Postów:7177
  • Lokalizacja:AMXX.PL
Offline

Napisano 19.09.2010 10:42

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Na życzenie Autora

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych