Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Blad w .sma


  • Zamknięty Temat jest zamknięty
21 odpowiedzi w tym temacie

#1 Spo^iler

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:65
  • Lokalizacja:Poznań
Offline

Napisano 12.09.2010 18:54

Mam pytanie pomoglby mi ktos przy zniwelowaniu 7 bledow w .sma?? najlepiej teraz nagradzam oczywiscie

Dołączona grafika

jest to bardzo pilna sprawa wiec proszę kogos zeby mi pomogl
  • +
  • -
  • 0

#2 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 12.09.2010 18:56

twój inglish is not good ? ja tam nie widzę error tylko warning (jak masz amxx studio to tools->Indenter)
  • +
  • -
  • 0

#3 Spo^iler

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:65
  • Lokalizacja:Poznań
Offline

Napisano 12.09.2010 18:57

dodam ze nie sa to trudne bledy bo spojrzalem w te linie i naprawdę wydaje mi sie jest to latwe do zrobienia a ja po prostu nie mam zielonego pojecia ;D hehe

12 wrzesień 2010 - 19:59:
i to amx studio samo to zrobi??
  • +
  • -
  • 0

#4 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 12.09.2010 19:01

a jak by było inaczej to po co bym ci to podawał ? po za tym te ostrzeżenia nie mają wpływu na pracę pluga
  • +
  • -
  • 0

#5 OnlyDiabloMod

    Zaawansowany

  • Użytkownik

Reputacja: 3
Nowy

  • Postów:141
  • Lokalizacja:Łódź
Offline

Napisano 12.09.2010 19:05

Tak.

@Edit.
Up mnie wyprzedził.

Użytkownik OnlyDiabloMod edytował ten post 12.09.2010 19:05

  • +
  • -
  • 0
Moja sieć serwerów: CS-Budowlani.pl

#6 Spo^iler

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:65
  • Lokalizacja:Poznań
Offline

Napisano 12.09.2010 20:13

niby nic nie robia a mam bledy w logach ;]

L 09/12/2010 - 21:00:47: [FAKEMETA] Invalid entity.
L 09/12/2010 - 21:02:04: Start of error session.
L 09/12/2010 - 21:02:04: Info (map "de_train") (file "addons/amxmodx/logs/error_20100912.log")
L 09/12/2010 - 21:02:04: String formatted incorrectly - parameter 4 (total 3)
L 09/12/2010 - 21:02:04: [AMXX] Run time error 25 (plugin "dbmod.amxx") - debug not enabled!
L 09/12/2010 - 21:02:04: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 09/12/2010 - 21:09:08: [FUN] Invalid player 4
L 09/12/2010 - 21:09:08: [AMXX] Run time error 10 (plugin "dbmod.amxx") (native "give_item") - debug not enabled!
L 09/12/2010 - 21:09:08: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
  • +
  • -
  • 0

#7 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 12.09.2010 20:37

ale to nie przez nie musisz daj logi z debugiem ale rozwiązanie problemu to pewnie if(is_user_alive(id))
  • +
  • -
  • 0

#8 Pawex

    Wszechpomocny

  • Użytkownik

Reputacja: 94
Zaawansowany

  • Postów:381
  • Lokalizacja:Polska
Offline

Napisano 12.09.2010 20:52

Bo te ostrzeżenia nic nie robią...
Pewnie masz nie odblokowane moduły, albo nie masz wszystkich
  • +
  • -
  • 0

#9 Knopers

    Nie patrz tak na mnie !

  • Przyjaciel

Reputacja: 587
Wszechwiedzący

  • Postów:2013
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Cz-wa
Offline

Napisano 12.09.2010 20:54

Bo te ostrzeżenia nic nie robią...
Pewnie masz nie odblokowane moduły, albo nie masz wszystkich


Czemu zawsze jak są błędy w logach to uważacie że nie ma odblokowanych modułów ?
Jak by czegoś brakowało to by wywaliło bez debuga że czegoś brakuje :F
  • +
  • -
  • 0

#10 Spo^iler

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:65
  • Lokalizacja:Poznań
Offline

Napisano 12.09.2010 21:01

moduly w .sma sa takie
#include <amxmodx>
#include <amxmisc>
#include <hamsandwich>

#include <engine>
#include <fakemeta>
#include <cstrike>

#include <fun>
#include <fakemeta_util>
#include <sqlx>
#include <csx>

a mam wlaczone te:
mysql
sqlite
fun
engine
fakemeta
;geoip
sockets
;regex
;nvault
cstrike
csx
hamsandwich

a to wycinek z logow:

L 09/12/2010 - 21:54:31: [FUN] Invalid player 5
L 09/12/2010 - 21:54:31: [AMXX] Run time error 10 (plugin "dbmod.amxx") (native "give_item") - debug not enabled!
L 09/12/2010 - 21:54:31: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 09/12/2010 - 21:55:28: [FUN] Invalid player 5
L 09/12/2010 - 21:55:28: [AMXX] Run time error 10 (plugin "dbmod.amxx") (native "give_item") - debug not enabled!
L 09/12/2010 - 21:55:28: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 09/12/2010 - 21:58:10: Start of error session.
L 09/12/2010 - 21:58:10: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20100912.log")
L 09/12/2010 - 21:58:10: Invalid player id 0
L 09/12/2010 - 21:58:10: [AMXX] Run time error 10 (plugin "abd.amxx") (native "get_user_attacker") - debug not enabled!
L 09/12/2010 - 21:58:10: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes)


caly czas sie powtarza to z tym player'em... powiem szczerze ze zaczyna mnie to w......

Użytkownik Spo^iler edytował ten post 12.09.2010 21:03

  • +
  • -
  • 0

#11 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 12.09.2010 21:42

Poczytaj co nie co o_O
Crash - Nieoficjalny polski support AMX Mod X

#12 Spo^iler

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:65
  • Lokalizacja:Poznań
Offline

Napisano 12.09.2010 22:12

przeczytalem ;] ale to nie zmienia faktu ze link ktory dales w niczym mi nie pomoze a jak zauwazyles pewnie dalem temat z prosba o to zeby mi ktos pomogl rozwiazac ten problem . . . ;]
  • +
  • -
  • 0

#13 Knopers

    Nie patrz tak na mnie !

  • Przyjaciel

Reputacja: 587
Wszechwiedzący

  • Postów:2013
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Cz-wa
Offline

Napisano 12.09.2010 22:15

daj logi z debugiem

+ sma
  • +
  • -
  • 0

#14 Spo^iler

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:65
  • Lokalizacja:Poznań
Offline

Napisano 13.09.2010 00:00

.sma nie moge dac jedynie wycinki z bledami bo za duzo zapalcilem za tego diablo...
dbmox.amxx debug
wpisalem tak jak powyzej i nie zmienily sie logi...

mapa poprawka znalazlem tego loga po debugu:

L 09/12/2010 - 22:45:03: [AMXX] [0] dbmod.sma::RoundStart (line 1254)
L 09/12/2010 - 22:47:10: [FUN] Invalid player 9
L 09/12/2010 - 22:47:10: [AMXX] Displaying debug trace (plugin "dbmod.amxx")
L 09/12/2010 - 22:47:10: [AMXX] Run time error 10: native error (native "give_item")

Użytkownik Spo^iler edytował ten post 13.09.2010 03:25

  • +
  • -
  • 0

#15 Knopers

    Nie patrz tak na mnie !

  • Przyjaciel

Reputacja: 587
Wszechwiedzący

  • Postów:2013
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Cz-wa
Offline

Napisano 13.09.2010 09:42

.sma nie moge dac jedynie wycinki z bledami bo za duzo zapalcilem za tego diablo...

Jak zapłaciłeś to ten kto ci sprzedał powinien naprawić błędy za free :F
Jak płacisz za plugin to powinieneś mieć zapewniony support od jego autora.

Daj całą funkcję RoundStart
  • +
  • -
  • 0

#16 Spo^iler

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:65
  • Lokalizacja:Poznań
Offline

Napisano 13.09.2010 13:55

public RoundStart(){
for (new i=0; i < 33; i++){
used_item[i] = false
DemageTake1[i]=1
count_jumps(i)
give_knife(i)
JumpsLeft[i]=JumpsMax[i]

if(player_class[i] == Nekromanta) g_haskit[i]=1
else g_haskit[i]=0
if(player_class[i] == Mefisto) c_jump[i]=3
else c_jump[i]=0
if(player_class[i] == Szkielet) c_jump[i]=2
else c_jump[i]=0
golden_bulet[i]=0


to .sma jakies pojebane jest... w ogole w tej lini nie ma roundstart ale daje Ci to jest troche nizej niz 1254...
  • +
  • -
  • 0

#17 Knopers

    Nie patrz tak na mnie !

  • Przyjaciel

Reputacja: 587
Wszechwiedzący

  • Postów:2013
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Cz-wa
Offline

Napisano 13.09.2010 14:46

To nie jest całą funkcja prosiłem o całą
  • +
  • -
  • 0

#18 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 13.09.2010 14:56

try
public RoundStart(){
for (new i=0; i < 33; i++){
if(!is_user_connected(i)){
continue;
}

  • +
  • -
  • 0

#19 Pawex

    Wszechpomocny

  • Użytkownik

Reputacja: 94
Zaawansowany

  • Postów:381
  • Lokalizacja:Polska
Offline

Napisano 13.09.2010 15:03

L 09/12/2010 - 21:00:47:
[FAKEMETA] Invalid entity.
Dlatego pomyslalem, ze ma nieodblokowane moduły. Panie Knopersie :b
  • +
  • -
  • 0

#20 Spo^iler

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:65
  • Lokalizacja:Poznań
Offline

Napisano 13.09.2010 16:28

mam teraz takie bledy jeszcze ale wstawilem tego co Dark napisal:

L 09/13/2010 - 09:50:37: String formatted incorrectly - parameter 4 (total 3)
L 09/13/2010 - 09:50:37: [AMXX] Displaying debug trace (plugin "dbmod.amxx")
L 09/13/2010 - 09:50:37: [AMXX] Run time error 25: parameter error 
L 09/13/2010 - 09:50:37: [AMXX]    [0] dbmod.sma::award_item (line 3808)
L 09/13/2010 - 09:50:37: [AMXX]    [1] dbmod.sma::DeathMsg (line 1520)
L 09/13/2010 - 09:52:05: Invalid player id 0
L 09/13/2010 - 09:52:05: [AMXX] Run time error 10 (plugin "abd.amxx") (native "get_user_attacker") - debug not enabled!
L 09/13/2010 - 09:52:05: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 09/13/2010 - 09:54:20: Invalid player id 0
L 09/13/2010 - 09:54:20: [AMXX] Run time error 10 (plugin "abd.amxx") (native "get_user_attacker") - debug not enabled!
L 09/13/2010 - 16:33:33: String formatted incorrectly - parameter 4 (total 3)
L 09/13/2010 - 16:33:33: [AMXX] Displaying debug trace (plugin "dbmod.amxx")
L 09/13/2010 - 16:33:33: [AMXX] Run time error 25: parameter error 
L 09/13/2010 - 16:33:33: [AMXX]    [0] dbmod.sma::award_item (line 3808)
L 09/13/2010 - 16:33:33: [AMXX]    [1] dbmod.sma::select_rune_menu (line 5761)
L 09/13/2010 - 16:41:35: String formatted incorrectly - parameter 4 (total 3)
L 09/13/2010 - 16:41:35: [AMXX] Displaying debug trace (plugin "dbmod.amxx")
L 09/13/2010 - 16:41:35: [AMXX] Run time error 25: parameter error 
L 09/13/2010 - 16:41:35: [AMXX]    [0] dbmod.sma::award_item (line 3808)
L 09/13/2010 - 16:41:35: [AMXX]    [1] dbmod.sma::DeathMsg (line 1520)
L 09/13/2010 - 16:54:06: Start of error session.
L 09/13/2010 - 16:54:06: Info (map "de_prodigy") (file "addons/amxmodx/logs/error_20100913.log")

Użytkownik Spo^iler edytował ten post 13.09.2010 16:30

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych