Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

cod mod problemy


  • Zamknięty Temat jest zamknięty
12 odpowiedzi w tym temacie

#1 **Smieszek**

    Zaawansowany

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:95
  • GG:
  • Lokalizacja:Smólsko
Offline

Napisano 11.09.2010 09:36

Witam.
Mam problem ze swoim cod modem.
Otóż tak:
- Klasa Skoczek nie posiada żadnej broni a powinna mieć mp5, famasa 115hp bazowe i 110% biegu
- Zrobić tak aby klasa: AWP rambo nie zabijała na hita.
- Klasie Komandos dać zabijanie na hita z noża ale zmniejszyć prędkość biegania.
- Jak można to dodać item: AWP Snajper żeby dzięki nie mu można było zabijać na hita.

edit//
- Usunąć ze sklepiku opcje:
Doświadczenie i Super Doświadczenie.

Hmm na razie tyle.

bardzo proszę o naprawienie i dodanie.

Załączone pliki


Użytkownik **Smieszek** edytował ten post 11.09.2010 10:48

  • +
  • -
  • 0

#2 Kusek

    z Wikipedii

  • Power User

Reputacja: 445
Wszechobecny

  • Postów:1655
  • Imię:Krystian
  • Lokalizacja:Nowa Dęba
Offline

Napisano 11.09.2010 11:41

teraz Ci ustawiłem że ramboawp zabija 1/3 z awp
if(weapon == CSW_AWP)
{
if(klasa_gracza[idattacker] == RamboAWP && random(3) == 1)
damage = float(health);
}

Załączone pliki


Użytkownik Frajer edytował ten post 11.09.2010 11:42

  • +
  • -
  • 1

#3 **Smieszek**

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:95
  • GG:
  • Lokalizacja:Smólsko
Offline

Napisano 11.09.2010 11:45

ok dzięki.
ej czyli zrobiłeś tylko z rambo awp?
i jak zrobiłeś 1/3
czy jak że ma 1 z 3 szans na zabicie?
  • +
  • -
  • 0

#4 Kusek

    z Wikipedii

  • Power User

Reputacja: 445
Wszechobecny

  • Postów:1655
  • Imię:Krystian
  • Lokalizacja:Nowa Dęba
Offline

Napisano 11.09.2010 11:51

tak
tak
tak
  • +
  • -
  • 0

#5 **Smieszek**

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:95
  • GG:
  • Lokalizacja:Smólsko
Offline

Napisano 11.09.2010 11:54

ok dzięki.
więc 1 problem już z głowy
  • +
  • -
  • 0

#6 Kusek

    z Wikipedii

  • Power User

Reputacja: 445
Wszechobecny

  • Postów:1655
  • Imię:Krystian
  • Lokalizacja:Nowa Dęba
Offline

Napisano 11.09.2010 11:56

jak jeden ^^, zrobiłem jeszcze
- Usunąć ze sklepiku opcje:
Doświadczenie i Super Doświadczenie.
- Klasa Skoczek nie posiada żadnej broni a powinna mieć mp5, famasa 115hp bazowe i 110% biegu

czyli 3

lecz nie wiem czy klasa działa bo nie sprawdzałem
  • +
  • -
  • 0

#7 **Smieszek**

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:95
  • GG:
  • Lokalizacja:Smólsko
Offline

Napisano 11.09.2010 12:05

oo
dzięki.
a co do klasy skoczek
to biega szybko ale nie ma żadnej broni nadal :/
  • +
  • -
  • 0

#8 Kusek

    z Wikipedii

  • Power User

Reputacja: 445
Wszechobecny

  • Postów:1655
  • Imię:Krystian
  • Lokalizacja:Nowa Dęba
Offline

Napisano 11.09.2010 13:50

wrzuć to, potem sprawdź logi może jakiś error jest dlaczego nie działa klasa

Załączone pliki


  • +
  • -
  • 0

#9 **Smieszek**

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:95
  • GG:
  • Lokalizacja:Smólsko
Offline

Napisano 11.09.2010 13:57

to mam w logach:
L 09/11/2010 - 14:31:52: [AMXX] Run time error 10 (plugin "cod.amxx") (native "give_item") - debug not enabled!
L 09/11/2010 - 14:31:52: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

  • +
  • -
  • 0

#10 Kusek

    z Wikipedii

  • Power User

Reputacja: 445
Wszechobecny

  • Postów:1655
  • Imię:Krystian
  • Lokalizacja:Nowa Dęba
Offline

Napisano 11.09.2010 14:01

dopisz debug po cod.amxx czyli
cod.amxx debug
i potem pokaż errory
  • +
  • -
  • 1

#11 **Smieszek**

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:95
  • GG:
  • Lokalizacja:Smólsko
Offline

Napisano 11.09.2010 14:14

ok.
jest już broń w klasie.
Ale nie dodaje hp i biega tak samo.

logi:
L 09/11/2010 - 15:13:12: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20100911.log")
L 09/11/2010 - 15:13:12: [FUN] Item "weapon_mp5" failed to create
L 09/11/2010 - 15:13:12: [AMXX] Displaying debug trace (plugin "cod.amxx")
L 09/11/2010 - 15:13:12: [AMXX] Run time error 10: native error (native "give_item")
L 09/11/2010 - 15:13:12: [AMXX]    [0] 4c8b94b02c026.sma::Odrodzenie (line 977)
L 09/11/2010 - 15:13:12: [AMXX]    [1] 4c8b94b02c026.sma::WybierzKlase_Handle (line 1645)

  • +
  • -
  • 0

#12 Kusek

    z Wikipedii

  • Power User

Reputacja: 445
Wszechobecny

  • Postów:1655
  • Imię:Krystian
  • Lokalizacja:Nowa Dęba
Offline

Napisano 11.09.2010 14:25

teraz wrzuć to i powinno hulać

Załączone pliki


  • +
  • -
  • 1

#13 **Smieszek**

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:95
  • GG:
  • Lokalizacja:Smólsko
Offline

Napisano 11.09.2010 14:35

Dobra więc tak.
W niektórych klasach nie ma broni żadnych.
Ta klasa skoczek nadal nie działa prawidłowo.
Mogę zapłacić 10 zł przelew oczywiście za naprawienie wszystkiego.
z klasami itp.

a tu plik z logów.

Załączone pliki


Użytkownik **Smieszek** edytował ten post 12.09.2010 12:54

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych