Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Błąd z bazą danychBrak połączenia i /klas


  • Zamknięty Temat jest zamknięty
15 odpowiedzi w tym temacie

#1 breco

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:13
  • Lokalizacja:Polska
Offline

Napisano 31.08.2010 16:01

Witam,
Wgrywam Diablo Moda STĄD i już trace przy nim cierpliwość,
Działa wszystko oprócz komendy: /klasa chyba dlatego że nie może się połączyć z bazą
Założyłem baze danych na niceshoot.pl tam też mam serwer cs.
W Access Hosts wpisałem: %, czyli dostęp do bazy jest.

W amxx.cfg wpisałem
///Diablo Mod

diablo_xpbonus 7 //ilość expa za zabicie standardowo ustawione na 7
diablo_xpbonus2  50 //ilość expa za wykonania celu misji standardowo ustawione na 50
diablo_durability  8 //Tracisz wytrzymałość za każde obrażenia ? Ile za każdym razem
diablo_spawnchance 1/3 //1/x szansa na zrespienia worka
SaveXp 0/2  //zapisywanie doświadczenia
diablo_classes abcdefgh //które klasy maja być dostępne
diablo_avg 0 //zaczynanie od sredniej serwera (liczonego od lvl 1)
diablo_dmg_exp 0 //za ile zabranego hp wrogowi dostaje sie 1 exp (domyslnie 20, 0 - off)

////SQL
diablo_sql_host "niceshoot.pl"
diablo_sql_user "breco_dm"
diablo_sql_pass "******"
diablo_sql_database "breco_dm"
diablo_sql_table "dm"
Z braku pomysłów wpisywałem to też do sgl.cfg

A oto logi:
L 08/31/2010 - 16:50:09: 08/31/2010 - 16:50:09 ### MAPA: de_dust2 ### 
L 08/31/2010 - 16:50:31: Error on Table query: Access denied for user 'breco_dm'@'ks307099.kimsufi.com' (using password: YES)
L 08/31/2010 - 16:50:31: Could not connect to SQL database.
L 08/31/2010 - 16:50:40: Error on Table query: Access denied for user 'breco_dm'@'ks307099.kimsufi.com' (using password: YES)
L 08/31/2010 - 16:50:40: Could not connect to SQL database.
L 08/31/2010 - 16:50:40: Error on Table query: Access denied for user 'breco_dm'@'ks307099.kimsufi.com' (using password: YES)
L 08/31/2010 - 16:50:40: Could not connect to SQL database.
L 08/31/2010 - 16:55:23: Error on Table query: Access denied for user 'breco_dm'@'ks307099.kimsufi.com' (using password: YES)
L 08/31/2010 - 16:55:23: Could not connect to SQL database.
itd.

Proszę o pomoc :mellow:

31 sierpień 2010 - 17:06:
dodam że moduły są odblokowane

Użytkownik breco edytował ten post 31.08.2010 16:03

  • +
  • -
  • 0

#2 ExuS

    Profesjonalista

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:175
  • GG:
  • Steam:steam
  • Lokalizacja:Zamość
Offline

Napisano 31.08.2010 17:35

Nie nadałeś dostępu zewnętrznego. Dodaj ip serwera do listy w direct admin lub cpanel (nie wiem jaki niceshoot ma).
  • +
  • -
  • 0
Serwery na sprzedaż - http://forum.gamehostingtalk.pl/showthread.php?12427-Serwery-sieci-GoldenGaming-pl

#3 breco

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:13
  • Lokalizacja:Polska
Offline

Napisano 31.08.2010 17:45

ma direct admin ale już dodałem do Access Hosts, nawet na kilka sposobów:
  • %
  • %IP serwera, bez hosta
  • samo IP, bez host
  • ks307099.kimsufi.com

i dalej to samo

Użytkownik breco edytował ten post 31.08.2010 17:46

  • +
  • -
  • 0

#4 ExuS

    Profesjonalista

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:175
  • GG:
  • Steam:steam
  • Lokalizacja:Zamość
Offline

Napisano 31.08.2010 18:02

Sprawdź usera, czy nie powinno być breco .
  • +
  • -
  • 0
Serwery na sprzedaż - http://forum.gamehostingtalk.pl/showthread.php?12427-Serwery-sieci-GoldenGaming-pl

#5 breco

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:13
  • Lokalizacja:Polska
Offline

Napisano 31.08.2010 18:11

nie, nazwa usera i bazy danych jest taka sama

31 sierpień 2010 - 19:52:
wgrałem inną wersję moda i dalej jest to samo, ocb?
nowe cvary:
diablo_sql_host "niceshoot.pl"
diablo_sql_user "breco_diablomod"
diablo_sql_pass "*****"
diablo_sql_database "breco_dm"
diablo_sql_table "dbmod_tablet"
diablo_sql_save "0"

  • +
  • -
  • 0

#6 Juma

    Wszechpomocny

  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:373
  • GG:
  • Steam:steam
  • Imię:Arek
  • Lokalizacja:Haynau
Offline

Napisano 31.08.2010 20:15

diablo_sql_host "niceshoot.pl"

No wątpię aby taki host miał być :D Poszukaj w Panelu IP serwera i wpisz to jako host ;P

Użytkownik Juma edytował ten post 31.08.2010 20:16

  • +
  • -
  • 0

#7 breco

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:13
  • Lokalizacja:Polska
Offline

Napisano 31.08.2010 20:52

wpisałem IP ale ciągle jest to samo
  • +
  • -
  • 0

#8 NiceShoot.pl

    Życzliwy

  • Użytkownik

Reputacja: 4
Nowy

  • Postów:27
  • Lokalizacja:Tychy
Offline

Napisano 01.09.2010 07:10

Jest błąd w Pana konfiguracji:
diablo_sql_host "niceshoot.pl"

Host bazy to nie niceshoot.pl a ip które dostaje Pan gdy zakupuje hosting: 195.2.255.175 czyli powinno wyglądać tak:
diablo_sql_host "195.2.255.175"
Reszta parametrów połączenia jakich Pan użył jest poprawna (nie widzę tylko jak z hasłem) tak więc serwer powinien już bez problemu nawiązać połączenie.
Jeżeli jednak byłyby jakieś problemy zapraszam do kontaktu z supportem z pewnością problem zostanie szybko rozwiązany.
  • +
  • -
  • 0

#9 breco

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:13
  • Lokalizacja:Polska
Offline

Napisano 01.09.2010 10:32

tak również próbowałem ale dalej nic,
logi "diablo.log":
L 09/01/2010 - 11:30:04: 09/01/2010 - 11:30:04 ### MAPA: de_dust2 ### 
L 09/01/2010 - 11:30:36: Error on Table query: Access denied for user 'breco_dm'@'ks307099.kimsufi.com' (using password: YES)
L 09/01/2010 - 11:30:36: Could not connect to SQL database.
L 09/01/2010 - 11:30:53: Error on Table query: Access denied for user 'breco_dm'@'ks307099.kimsufi.com' (using password: YES)
L 09/01/2010 - 11:30:53: Could not connect to SQL database.
L 09/01/2010 - 11:30:53: Error on Table query: Access denied for user 'breco_dm'@'ks307099.kimsufi.com' (using password: YES)
L 09/01/2010 - 11:30:53: Could not connect to SQL database.
L 09/01/2010 - 11:31:02: Error on Table query: Access denied for user 'breco_dm'@'ks307099.kimsufi.com' (using password: YES)
L 09/01/2010 - 11:31:02: Could not connect to SQL database.
L 09/01/2010 - 11:31:02: Error on Table query: Access denied for user 'breco_dm'@'ks307099.kimsufi.com' (using password: YES)
L 09/01/2010 - 11:31:02: Could not connect to SQL database.

hasło jest dobre na 100%

01 wrzesień 2010 - 10:39:
diablo_sql_host "195.2.255.175"
diablo_sql_user "breco_diablomod"
diablo_sql_pass "*****"
diablo_sql_database "breco_dm"
diablo_sql_table "dbmod_tablet"
diablo_sql_save "0"

i nic :huh:

Użytkownik breco edytował ten post 01.09.2010 10:33

  • +
  • -
  • 0

#10 Gość_cypis_*

  • Gość

Reputacja: 0

Offline

Napisano 01.09.2010 10:49

To zrobiłeś źle baze danych :> ... jak chcesz to napisz mogę ci zrobić . 1959430 ... za Free

#11 false

    Wszechmogący

  • Użytkownik

Reputacja: 53
Pomocny

  • Postów:652
  • Lokalizacja:z Polski
Offline

Napisano 01.09.2010 11:52

To zrobiłeś źle baze danych :> ... jak chcesz to napisz mogę ci zrobić . 1959430 ... za Free


"Access denied for user"

czyli nie masz dostepu a na koncu (USSING PASSWORD : YES)

Moim zdaniem na 55% zle hasło :/
  • +
  • -
  • 0

#12 breco

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:13
  • Lokalizacja:Polska
Offline

Napisano 01.09.2010 12:07

hasło i reszta danych dobra, dzięki "cypis" wiem już że jest to wina serwera gry, jakoś blokuje połączenia ze wszystkim bazami, próbowaliśmy też z bazą dzaiałającą ale u mnie stutek jest dalej ten sam, napisałem do supportu niceshoot

01 wrzesień 2010 - 12:34:
w supporcie mi odpisali że serwer sam z siebie blokować połączenia nie może, więc nie mam pojęcia co to, wszystkie moduły sa odblokowane, wersja moda działająca, wersja amxa dobra

01 wrzesień 2010 - 13:03:
nie wiem o co chodzi, ale już działa :D
  • +
  • -
  • 0

#13 NiceShoot.pl

    Życzliwy

  • Użytkownik

Reputacja: 4
Nowy

  • Postów:27
  • Lokalizacja:Tychy
Offline

Napisano 01.09.2010 15:58

Ja widzę błąd otóż:
diablo_sql_host "195.2.255.175"
diablo_sql_user "breco_diablomod"

log: breco_dm'@'ks307099.kimsufi.com

Czyli albo zmienił Pan dane i nie zrestartował serwera albo w innym pliku były wpisane błędne dane do połączenia mysql.
  • +
  • -
  • 0

#14 Gość_cypis_*

  • Gość

Reputacja: 0

Offline

Napisano 01.09.2010 17:39

Wszechwiedzący nie wymądrzaj się ... bo jakoś mu zrobiłem nie tak jak ty ...

#15 Juma

    Wszechpomocny

  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:373
  • GG:
  • Steam:steam
  • Imię:Arek
  • Lokalizacja:Haynau
Offline

Napisano 01.09.2010 17:43

Wszechwiedzący nie wymądrzaj się ... bo jakoś mu zrobiłem nie tak jak ty ...


Może trochę ogaru co ? Pan tylko pomóc chciał i tyle, trzeba cenić takiego usługodawcę że pomaga jeszcze swoim klientom na innych forach :>
  • +
  • -
  • 0

#16 NiceShoot.pl

    Życzliwy

  • Użytkownik

Reputacja: 4
Nowy

  • Postów:27
  • Lokalizacja:Tychy
Offline

Napisano 01.09.2010 22:39

Wszechwiedzący nie wymądrzaj się ... bo jakoś mu zrobiłem nie tak jak ty ...


Klient napisał do naszego supportu wyjaśniliśmy co jest nie tak, co należy sprawdzić - w czym problem?
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych