Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

CoD mod


  • Zamknięty Temat jest zamknięty
14 odpowiedzi w tym temacie

#1 t3h1

    Początkujący

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:15
  • Lokalizacja:Polska
Offline

Napisano 30.08.2010 11:51

Witam. Ostatnio prosiłem o pomoc w przerobieniu CoD mod'a. Poradziłem sobie z tym sam, lecz teraz wystąpił nowy problem.
Plugin normalnie kompiluje się, lecz gdy ktoś dołączy na serwer, konsola hlds'a pokazuje takie coś:
couldn't exec listip.cfg
L 08/30/2010 - 12:44:34: -------- Mapchange to de_dust --------
Usage:
Setmaster unavailable, start a server first.
[AMXX] Loaded 3 admins from file
L 08/30/2010 - 12:44:34: Function "cmd_setlvl" was not found
L 08/30/2010 - 12:44:34: [AMXX] Run time error 19 (plugin "mumod.amxx") - debug not enabled!
L 08/30/2010 - 12:44:34: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

Executing AMX Mod X Configuration File 
Scrolling message displaying frequency: 10:00 minutes
Menu item 17 added to Menus Front-End: "Plugin Cvars" from plugin "pluginmenu.amxx"
Menu item 18 added to Menus Front-End: "Plugin Commands" from plugin "pluginmenu.amxx"
Connection to Steam servers successful.
   VAC secure mode is activated.
L 08/30/2010 - 12:44:54: [admin.amxx] Login: "T3h<1><STEAM_0:1:31570013><>" became an admin (account "xx.xxx.xxx.xxx") (access "abcdefghijklmnopqrstu") (address "xx.xxx.xxx.xxx")
Warning:  Unable to open sound/misc/circulati.wav for transfer
Warning:  Unable to open sound/djeyl/c4powa.wav for transfer
Warning:  Unable to open sound/djeyl/witch.wav for transfer
Warning:  Unable to open sound/djeyl/laugh.wav for transfer
L 08/30/2010 - 12:45:03: HudSyncObject -1 is invalid
L 08/30/2010 - 12:45:03: [AMXX] Run time error 10 (plugin "mumod.amxx") (native "ShowSyncHudMsg") - debug not enabled!
L 08/30/2010 - 12:45:03: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 08/30/2010 - 12:45:03: HudSyncObject -1 is invalid
L 08/30/2010 - 12:45:03: [AMXX] Run time error 10 (plugin "mumod.amxx") (native "ShowSyncHudMsg") - debug not enabled!
L 08/30/2010 - 12:45:03: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
Ostatnie 3 linijki powtarzają się ciągle, dopóki wszystkie osoby nie wyjdą z serwera.
Mógłby ktoś naprawić plugin?
Z góry przepraszam jak nie będę odpowiadał przez następne 2-5 godzin.

Załączone pliki


Użytkownik t3h1 edytował ten post 30.08.2010 11:53

  • +
  • -
  • 0

#2 matipolak

    Życzliwy

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:34
  • Lokalizacja:POLAND
Offline

Napisano 01.09.2010 16:27

zapodaj plik configs/modules.ini
i dodaj debug po Mumod.amxx w plugins.ini

Użytkownik matipolak edytował ten post 01.09.2010 16:28

  • +
  • -
  • 0

#3 camilost

    ^ BotQ - STER.owiec ^

  • Power User

Reputacja: 430
Wszechobecny

  • Postów:968
  • GG:
  • Steam:steam
  • Imię:Kamil
  • Lokalizacja:Tychy
Offline

Napisano 01.09.2010 17:09

Dziwne jakoś ^^ Patrzałem w Twoje SMA, wszystko z tym błędem opisany tak samo mam. Lecz w logach czysto. Zrób tak jak kolego powyżej (Dowiemy się dokładniej gdzie błąd).
  • +
  • -
  • 0

#4 t3h1

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:15
  • Lokalizacja:Polska
Offline

Napisano 01.09.2010 18:34

mysql
sqlite
fun
engine
fakemeta
cstrike
csx
;hamsandwich
;geoip
;sockets
;regex
;nvault
Mój modules.ini .
Edit:
Po odblokowaniu hamsandwich i użyciu debug'a takie coś w kółko lata przez konsole hlds'a :
L 09/01/2010 - 19:38:08: HudSyncObject -1 is invalid
L 09/01/2010 - 19:38:08: [AMXX] Displaying debug trace (plugin "mumod.amxx")
L 09/01/2010 - 19:38:08: [AMXX] Run time error 10: native error (native "ShowSyncHudMsg")
L 09/01/2010 - 19:38:08: [AMXX]    [0] Mumod.sma::PokazInformacje (line 1506)
Edit x2:
Jak to konsola mi "powiedziała" wszedłem do mumod.sma i tam do linii 1506, jest tam taka linijka:
ShowSyncHudMsg(id, SyncHudObj, "[Klasa : %s]^n[Doswiadczenie : %i / %i]^n[Poziom : %i]^n[Przedmiot : %s]", nazwy_klas[klasa_gracza[id]], doswiadczenie_gracza[id], doswiadczenie_poziomu[poziom_gracza[id]], poziom_gracza[id], nazwy_przedmiotow[informacje_przedmiotu_gracza[id][0]]);
Co w tym jest złego?

Użytkownik t3h1 edytował ten post 01.09.2010 18:54

  • +
  • -
  • 0

#5 matipolak

    Życzliwy

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:34
  • Lokalizacja:POLAND
Offline

Napisano 01.09.2010 18:56

usuń ; przed
hamsandwich
geoip
sockets
regex
nvault
w modules.ini
  • +
  • -
  • 0

#6 t3h1

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:15
  • Lokalizacja:Polska
Offline

Napisano 01.09.2010 18:59

niestety, to nic nie dało :mur: .
------------------
#include <amxmodx>
#include <amxmisc>
#include <fun>
#include <cstrike>
#include <fakemeta>
#include <engine>
#include <hamsandwich>
#include <nvault>
-------------------

#define PLUGIN "Call of Duty: MW Mod"
#define VERSION "0.7.9 Beta"
#define AUTHOR "QTM_Peyote"

#define STANDARDOWA_SZYBKOSC 250.0

#define ZADANIE_POKAZ_INFORMACJE 672
#define ZADANIE_WSKRZES 704
#define ZADANIE_WYSZKOLENIE_SANITARNE 736
#define ZADANIE_POKAZ_REKLAME 768
#define ZADANIE_USTAW_SZYBKOSC 832

//#define BOTY 1
A to nie jest wazne?

Użytkownik t3h1 edytował ten post 01.09.2010 19:27

  • +
  • -
  • 0

#7 matipolak

    Życzliwy

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:34
  • Lokalizacja:POLAND
Offline

Napisano 02.09.2010 14:42


enum { NONE = 0, Snajper, Komandos, Strzelec, Obronca, Medyk, Wsparcie, Saper, Demolitions, Rusher, Rambo };
new const zdrowie_klasy[] = { 0, 90, 140, 120, 120, 140, 120, 100, 110, 100, 130};
new const Float:szybkosc_klasy[] = {0.0, 1.0, 1.5, 1.2, 1.2, 1.0, 1.0, 1.0, 1.0, 1.3 , 1.15};
new const pancerz_klasy[] = { 0, 60, 100, 100, 150, 100, 0, 100, 100, 0, 150};
new const nazwy_klas[][] = {"Brak",
"DarkWizard",
"DarkLord",
"Elf",
"Summoner(vip)",
"MagicGladiator",
"DarkKnight"
};

new const opisy_klas[][] = {"Brak",
"Dostaje Scout i deagle, 90hp bazowe,2 FireBalle na E, 1/3 szansy natychmiastowego zabicia noza, 110% biegu, 60 pancerza",
"Dostaje Deagle, 140hp bazowe, Natychmiastowe zabicie z noza (prawy przycisk myszy), 150% biegu, 100 pancerza",
"Dostaje AK i M4A1, 120hp bazowe, 120 % biegu, 100 pancerza",
"Dostaje M3, 120hp bazowe, 120% biegu, ma wszystkie granaty, 150 pancerza",
"Dostaje UMP45, 140hp bazowe, posiada apteczke, 100 pancerza",
"Dostaje MP5, 120 hp bazowe",
"Dostaje P90, 100hp bazowe, 100 pancerza, Dostaje 3 miny, gdy ktos w nie wejdzie wybuchaja",
"Dostaje AUG, 110 hp bazowe, 100 pancerza, Ma wszystkie granaty, Dostaje dynamit, który zabiera sporo zycia wszystkim znajdującym się blisko niego",
"Dostaje szotgana M3, 100 hp bazowe, 130% biegu",
"Dostaje Famasa, 130 hp bazowe, 120% biegu, za kazde zabojstwo +20 hp oraz pelen magazynek, podwojny skok"
};

[QTM COD:MW Mod] Jak dodać nową klasę - Nieoficjalny polski support AMX Mod X
  • +
  • -
  • 0

#8 t3h1

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:15
  • Lokalizacja:Polska
Offline

Napisano 02.09.2010 15:10

Niestety, MatiPolak, ale to nic nie dało. Twój link jest do dodania nowych klas, który mi w niczym nie pomógł. :/
  • +
  • -
  • 0

#9 camilost

    ^ BotQ - STER.owiec ^

  • Power User

Reputacja: 430
Wszechobecny

  • Postów:968
  • GG:
  • Steam:steam
  • Imię:Kamil
  • Lokalizacja:Tychy
Offline

Napisano 02.09.2010 15:23

t3h1, masz podstawową wersję COD M, czy coś dodawałeś? Jeśli klasy pokaż Spis klas (To co podał MatiPolak) albo jeśli itemy to Spis+opisy itemów : P
  • +
  • -
  • 0

#10 matipolak

    Życzliwy

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:34
  • Lokalizacja:POLAND
Offline

Napisano 02.09.2010 17:17

to co wyżej dodałem to wycinek twojego sma dokładniej klas
tu masz 6 klas

new const nazwy_klas[][] = {"Brak",
"DarkWizard",
"DarkLord",
"Elf",
"Summoner(vip)",
"MagicGladiator",
"DarkKnight"
};

a np. tu masz 10 klas

enum { NONE = 0, Snajper, Komandos, Strzelec, Obronca, Medyk, Wsparcie, Saper, Demolitions, Rusher, Rambo };


wnioski wyciągnij sam

Użytkownik matipolak edytował ten post 02.09.2010 17:18

  • +
  • -
  • 0

#11 t3h1

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:15
  • Lokalizacja:Polska
Offline

Napisano 02.09.2010 20:16

Niestety, to też nie podziałało :blink: . Zrobiłem tak jak mówiłeś, tzn. usunąłem resztę klas, ale to nic nie dało :blink: . Błąd dalej ten sam.
  • +
  • -
  • 0

#12 camilost

    ^ BotQ - STER.owiec ^

  • Power User

Reputacja: 430
Wszechobecny

  • Postów:968
  • GG:
  • Steam:steam
  • Imię:Kamil
  • Lokalizacja:Tychy
Offline

Napisano 03.09.2010 07:08

Policz czy wszystko się zgadza (licząc z zerami)
Sprawdź Przedmioty i ich opisy, Klasy i ich opisy,zdrowie,predkosc,armor
  • +
  • -
  • 0

#13 t3h1

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:15
  • Lokalizacja:Polska
Offline

Napisano 03.09.2010 12:01

Policzyłem dokładnie, lecz wszystko się zgadza. Co do itemów, to zmieniałem ich NAZWY, a opisy są takie jak w cod mod.
Według mnie, gdyby to była wina zmienionych nazw itemów, by się nie kompilowało.
  • +
  • -
  • 0

#14 camilost

    ^ BotQ - STER.owiec ^

  • Power User

Reputacja: 430
Wszechobecny

  • Postów:968
  • GG:
  • Steam:steam
  • Imię:Kamil
  • Lokalizacja:Tychy
Offline

Napisano 03.09.2010 12:38

Tak dla wyjaśnienia.
Nie wina zmienionych nazw, tyle czy liczba ta sama. Bo itemy nie patrzy nazwy tylko nr. w kolejności.
  • +
  • -
  • 0

#15 t3h1

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:15
  • Lokalizacja:Polska
Offline

Napisano 03.09.2010 20:04

Tak, liczba jest ta sama. Jeszcze sprawdzę czy itemy z Codmod'a poprawia dzialanie.
Edit:
Zrobiłem nazwy z oryginalnego cod mod'a, lecz to nic nie dało. Dodatkowo mogę dodać, że w say'u pisze "dostales 0 expa za podłożenie paki". Nic więcej nie wiem.

Użytkownik t3h1 edytował ten post 03.09.2010 20:13

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych