Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Amxbans, Diablo i SRN się gryzą


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 Bravais

    Nowy

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:5
  • Lokalizacja:Żelechów
Offline

Napisano 29.08.2010 13:05

Cześć.
Przedstawię sytuację.
Mam serwer diablo z bazą na hostingu x.
Są też zainstalowane amxbans 5.0 oraz SRN (System Rezerwacji Nikców) na oddzielnych bazach na hostingu forum mojej sieci.
Mamy więc 3 bazy. 2 na tym samym hostingu i trzecia na oddzielnym.

I teraz tak:
- DiabloMod śmiga aż miło, ale tylko przy wyłączonych pluginach amxbans.amxx oraz oraz srn.amxx
- Jak włączam amxbans i srn to mam tak w logach, mało tego - przestaje działać poprawnie diablomod - wszystkie itemy, itd się ładują, ale nie można wybrać klasy - błąd połączenia z bazą.

diablo.log:
L 08/29/2010 - 13:32:48: [amxbans.amxx] [Amxbans] Wiadomosc: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (2002)
L 08/29/2010 - 13:32:48: [amxbans.amxx] [Amxbans] Status zapytania:
L 08/29/2010 - 13:32:48: [amxbans.amxx] [Amxbans] Polaczenie nieudane!
L 08/29/2010 - 13:32:48: [amxbans.amxx] [Amxbans] Blad zapyania, lokacja: 17
L 08/29/2010 - 13:32:48: [amxbans.amxx] [Amxbans] Wiadomosc: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (2002

Powyższe błędy nie mają miejsca na innych serwerach z identycznie skonfigurowanym amxbans i srn i modem, który korzysta z baz, która są zlokalizowane tak samo jak te od diablo (serwer War3FT).

Jakieś pomysły ?
  • +
  • -
  • 0

#2 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 29.08.2010 13:21

Nie może się połączyć z MySLQ'em trochę angielskiego jeszcze nikomu nie zaszkodziło, Załóż nową bazę lub popraw dane :)

#3 Bravais

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 2
Nowy

  • Postów:5
  • Lokalizacja:Żelechów
Offline

Napisano 29.08.2010 13:47

Wpadłem na to wcześniej. Sprawdzane na różnych hostingach i na różnych bazach. Z angielskim nie mam kłopotów ;)
  • +
  • -
  • 0

#4 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10832
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 29.08.2010 14:05

tak spytam na co ci 3 bazy ? jedna nie wystarczy ? przecież plugi będą zapisywać swoje informacje na odzielnych tabelach i tu może leżeć problem za dużo połączeń :) spróbuj all do jeden bazy
  • +
  • -
  • 0

#5 Bravais

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 2
Nowy

  • Postów:5
  • Lokalizacja:Żelechów
Offline

Napisano 29.08.2010 14:11

No w sumie racja. Jedna baza na SRN, druga na exp na diablo, 3 amxbans (+4 inne serwery).
Spróbuję w takim razie podpiąć się z bazą od expa do tej z amxbans...

Jednak nie działa. Wrzuciłem diablo do bazy z amxbans. Nie czyta bazy z hostingu na którym stoi forum.
Efekt taki jak opisany wyżej - zwiecha serwera podczas próby zapisania expa do bazy...
Spróbuję zatem zainstalować amxbans na hostingu z expem diablo. Jak pójdzie - okaże się, że błąd pewnie leży po stronie firmy hostingowej...

29 sierpień 2010 - 16:28:
Sry za double posta, ale tak, żeby wszyscy wiedzieli - problem leży po stronie firmy hostingowej.
Po zainstalowaniu amxbans na tym samym hostingu co baza od expa diablo, wszystko pięknie zaczęło śmigać.

Użytkownik Bravais edytował ten post 29.08.2010 14:39

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych