Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

DiabloMod 5.9l na nowym menu - Problem z klasą premium.


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 Juma

    Wszechpomocny

  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:373
  • GG:
  • Steam:steam
  • Imię:Arek
  • Lokalizacja:Haynau
Offline

Napisano 26.08.2010 17:55

Witam. Otóż mam problem. W swoim diablomodzie, użyłem tego menu Goq'a:
[Tutorial] Latwe dodawanie klas + nowe menu - Nieoficjalny polski support AMX Mod X

I nie wiem teraz gdzie dodać if( get_user_flags(id) & FLAGA) gdyż wcześniej było to przy cache klasy.

[TUTORIAL] Jak Dodac Klase Premium . - Nieoficjalny polski support AMX Mod X

Ten poradnik mi nie pomógł.
  • +
  • -
  • 0

#2 hefcio

    Życzliwy

  • Użytkownik

Reputacja: 5
Nowy

  • Postów:33
  • Lokalizacja:Polska
Offline

Napisano 28.08.2010 01:36

w
public handle_create_class(id, menu, item){

dodaj pod :
if(player_class[id]==Nekromanta)
                g_haskit[id] = 1
        if(player_class[id]==Hunter)
                g_GrenadeTrap[id] = 1

if(player_class[id]==TWOJA KLASA && !(get_user_flags(id) & FLAGA))
asked_klass[id]= 1
  • +
  • -
  • 0

#3 Juma

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:373
  • GG:
  • Steam:steam
  • Imię:Arek
  • Lokalizacja:Haynau
Offline

Napisano 28.08.2010 10:24

Niestety nie działa ..
  • +
  • -
  • 0

#4 Onyke

    Godlike

  • Przyjaciel

Reputacja: 705
Guru

  • Postów:2178
Offline

Napisano 28.08.2010 10:34

Znajdź

return ITEM_DISABLED


Dopisz nad tym

if(!(get_user_flags(id)&ADMIN_BAN)&&item==Nr_klasy_premium) return ITEM_DISABLED


Ps
Było na forum :>
  • +
  • -
  • 0

#5 Juma

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:373
  • GG:
  • Steam:steam
  • Imię:Arek
  • Lokalizacja:Haynau
Offline

Napisano 28.08.2010 11:03

Eh.. No wciąż niedziała ;P
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych