Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Diablomod 5.9l problem z kompilacją


  • Zamknięty Temat jest zamknięty
5 odpowiedzi w tym temacie

#1 SWiTcH

    Życzliwy

  • Zbanowany

Reputacja: -2
Mniej niż zer0.

  • Postów:24
  • Lokalizacja:Tarnobrzeg
Offline

Napisano 14.08.2010 13:08

Witam. Przerobiłem,poprawiłem diablomod,tzw. swoją wersje,bo były same bugi.W niej pozmieniałem komendy,Hud,nazwy itemów itd.próbuje go skompilować w Amx studio ale pisze błąd:


Pawn compiler not found.Please check settings and try again.


Załączam moje .sma,abyście mogli mi w razie wypadku poprawić,to co powoduje ten błąd.....proszę pomóżcie mi

Załączone pliki


Użytkownik SWiTcH edytował ten post 14.08.2010 13:09


#2 Dimni

    Zaawansowany

  • Użytkownik

Reputacja: 45
Pomocny

  • Postów:88
  • Lokalizacja:eLWuO City
Offline

Napisano 14.08.2010 13:42

Pawn compiler not found.Please check settings and try again.


Nie wgrałeś lub nie wskazałeś pliku kompilatora.
Zobacz Tools | Settings, opcja Compiler. W pierwszej linijce wskaż plik amxxpc.exe.

Użytkownik Dimni edytował ten post 14.08.2010 13:46

  • +
  • -
  • 0

#3 SWiTcH

    Życzliwy

  • Autor tematu
  • Zbanowany

Reputacja: -2
Mniej niż zer0.

  • Postów:24
  • Lokalizacja:Tarnobrzeg
Offline

Napisano 14.08.2010 14:18

//AMXXPC compile.exe
// by the AMX Mod X Dev Team


//// DiabloMOD_5.9l.sma
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(243) : error 018: initialization data exceeds declared size
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(1377) : error 017: undefined symbol "Barbarzynca"
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(1618) : warning 217: loose indentation
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(2078) : error 001: expected token: "]", but found ","
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(3208 -- 3209) : error 037: invalid string (possibly non-terminated string)
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(3209) : warning 217: loose indentation
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(3209 -- 3210) : warning 215: expression has no effect
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(3210) : warning 217: loose indentation
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(4264) : error 010: invalid function or declaration
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(4268) : error 021: symbol already defined: "format"
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(4271) : error 010: invalid function or declaration
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(4273) : error 010: invalid function or declaration
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(4611) : error 017: undefined symbol "Barbarzynca"
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(4653) : error 017: undefined symbol "Barbarzynca"
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(6604) : error 017: undefined symbol "Barbarzynca"
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(6841) : error 017: undefined symbol "Barbarzynca"
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(8092) : error 017: undefined symbol "Barbarzynca"
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(8358) : warning 203: symbol is never used: "keys"
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(8358) : warning 203: symbol is never used: "text"
//
// 13 Errors.
// Could not locate output file C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\compiled\DiabloMOD_5.9l.amx (compile failed).
//
// Compilation Time: 3,09 sec
// ----------------------------------------

// File not found.

Press enter to exit ...


Próbowałem kompilować,a tu takie błędy

#4 Dimni

    Zaawansowany

  • Użytkownik

Reputacja: 45
Pomocny

  • Postów:88
  • Lokalizacja:eLWuO City
Offline

Napisano 14.08.2010 14:27

Łap.
Głupie błędy - literówki, brak domknięcia klamerek itp.

Załączone pliki


  • +
  • -
  • 0

#5 SWiTcH

    Życzliwy

  • Autor tematu
  • Zbanowany

Reputacja: -2
Mniej niż zer0.

  • Postów:24
  • Lokalizacja:Tarnobrzeg
Offline

Napisano 14.08.2010 15:35

//AMXXPC compile.exe
// by the AMX Mod X Dev Team


//// DiabloMOD_5.9l.sma
// C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\DiabloMOD_5.9l.sma(0) : fatal error 101: cannot write to file: "C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\compiled\DiabloMOD_5.9l.amx"
//
// Compilation aborted.
// 1 Error.
// Could not locate output file C:\Documents and Settings\JA\Pulpit\cstrike\addons\amxmodx\scripting\compiled\DiabloMOD_5.9l.amx (compile failed).
//
// Compilation Time: 0,03 sec
// ----------------------------------------

// File not found.

Press enter to exit ...


a to możesz wyjaśnić?

#6 Dimni

    Zaawansowany

  • Użytkownik

Reputacja: 45
Pomocny

  • Postów:88
  • Lokalizacja:eLWuO City
Offline

Napisano 14.08.2010 16:18

Jedyne co przychodzi mi do głowy to myśl, że może posiadasz starą wersję kompilatora - mi zadziałało od razu.
Łap skompilowane.

EDIT: Prosiłbym o zamknięcie tematu, bo autor najwyraźniej o nim "zapomniał"

Załączone pliki


Użytkownik Dimni edytował ten post 16.08.2010 09:52

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych