Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

POBLEMM


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 Dragon16

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:55
Offline

Napisano 03.10.2008 20:22

Leci mi 1 muzyka z 6 wszystkie sie sicągneły a tylko 1 leci :/ macie tu moj roundsound.ini
; CT Sounds

"sound/misc/dragon/sound.mp3" "CT"

"sound/misc/dragon/sound2.mp3" "CT"

"sound/misc/dragon/sound3.mp3" "CT"



; T Sounds

"sound/misc/dragon/sound4.mp3" "T"

"sound/misc/dragon/sound5.mp3" "T"

"sound/misc/dragon/sound6.mp3" "T"


  • +
  • -
  • 0

#2 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 03.10.2008 20:24

Mało informacji. Która mp3-ka gra ? Gra ona przy obu team'ach czy tylko przy właściwym ?
Pokaż .sma
  • +
  • -
  • 0

#3 Dragon16

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:55
Offline

Napisano 04.10.2008 07:47

#include <amxmodx> 

new const sounds_ct[][] = {"sound/misc/dragon/sound.mp3","sound/misc/dragon/sound2.mp3","sound/misc/dragon/sound3.mp3"}

new const sounds_terro[][] = {"sound/misc/dragon/sound4.mp3","sound/misc/dragon/sound5.mp3","sound/misc/dragon/sound6.mp3"}
public plugin_init() 
{ 
  register_plugin("RoundSoundy","1","Sal") 
  register_event("SendAudio", "ct", "a", "2&%!MRAD_ctwin") 
  register_event("SendAudio", "terro", "a", "2&%!MRAD_terwin") 
} 

public plugin_precache() 
{ 
  new i 
  for(i = 0; i < sizeof sounds_ct; i++) 
  precache_generic(sounds_ct[i]) 

  new u 
  for(u = 0; u < sizeof sounds_terro; u++) 
  precache_generic(sounds_terro[u]) 
} 

public ct() 
{ 
  client_cmd(0,"stopsound") 

  client_cmd(0, "mp3 stop") 

  client_cmd(0, "mp3 play %s", sounds_ct[random_num(0, charsmax(sounds_ct))] ) 
} 

public terro() 
{ 
  client_cmd(0,"stopsound") 

  client_cmd(0, "mp3 stop") 

  client_cmd(0, "mp3 play %s", sounds_terro[random_num(0, charsmax(sounds_terro))] ) 
}

jak powiesz ze ten plugin jest git to mowie leci mi tylko 1 muzyka z 6 .MOze mi jakis inny plik zaproponujesz ??
i masz w załonczniku maja muzyke

Załączone pliki

  • Załączony plik  dragon.rar   914,73 KB  40 Ilość pobrań

  • +
  • -
  • 0

#4 PeZeT

    Zaawansowany

  • Użytkownik

Reputacja: 11
Początkujący

  • Postów:80
Offline

Napisano 04.10.2008 08:56

Wgraj ten plugin,który jest w załączniku i dodaj te CVAR'y do amxx.cfg
ers_enabled <1>

ers_player_toggle <1>

erc_time_ads <120>

erc_random_precache "3"

Muzykę zachowaj tam gdzie masz bez zmian ;)

Załączone pliki


  • +
  • -
  • 0

#5 Dragon16

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:55
Offline

Napisano 04.10.2008 11:28

Dalej tylko 1 muzyka leci weź mi może zrob tez plugin roundsound.sma

[ Dodano: 04-10-2008, 12:29 ]
Ale w MP3
  • +
  • -
  • 0

#6 Novy93

    Zaawansowany

  • Użytkownik

Reputacja: 15
Początkujący

  • Postów:142
  • Lokalizacja:Ruda Śląska
Offline

Napisano 04.10.2008 11:33

Sam plik .sma nic nie daje. Go się tylko kompiluje na .amxx. A widać, że niezbyt się znasz na pluginach, to byś nic nie wygrzebał :]
  • +
  • -
  • 0

#7 Dragon16

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:55
Offline

Napisano 04.10.2008 17:38

no wiem z sma sie kompiluje na plik amx i plik sma wkleja sie do scriptngs a amx to plugins .
Tera powiecie mi co mam zrobic zeby ta muzyka działała ???? Moze ty mi powiesz jak jestes taki mądry
  • +
  • -
  • 0

#8 Novy93

    Zaawansowany

  • Użytkownik

Reputacja: 15
Początkujący

  • Postów:142
  • Lokalizacja:Ruda Śląska
Offline

Napisano 04.10.2008 20:54

Najlepiej se wszystko wykasuj i rób wg jakiejkolwiek instrukcji :]
  • +
  • -
  • 0

#9 pawlik

    Wszechwiedzący

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:579
  • Steam:steam
  • Lokalizacja:Podkarpacie
Offline

Napisano 16.10.2008 13:10

Miałem tak samo... Trzeba było poustawiać parametry muzyczek na niższe. [Dodadkowo i konsoli cs'a wyskakiwały mi takie błędy]
BUILD 3382 SERVER (0 CRC)
Server # 2 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks 
Missing RIFF/WAVE chunks

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych