Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

fs_lazy_precache 1


  • Zamknięty Temat jest zamknięty
9 odpowiedzi w tym temacie

#1 Daimyo

    Zaawansowany

  • Użytkownik

Reputacja: 3
Nowy

  • Postów:119
  • Lokalizacja:rzeszow
Offline

Napisano 08.08.2010 15:03

Witam! Gdy wchodze na swoj serwer Zombie Plague po dodaniu paru dodatkow, ladowanie gry zatrzymuje sie na PRECACHING RESOURCES i tak zostaje... trzeba czekac o.k 20-30 minut az to minie.. jest to troche denerwujace? Jest jednak na to rozwiazanie - mianowicie komenda:

fs_lazy_precache 1


chcialbym zlozyc prosbe o stworzenie takiego pluga, ktory AUTOMATYCZNIE PRZY POLACZENIU NA SERWER USTAWIAL KLIENTOWI fs_lazy_precache z 0 na 1, bo gdy nie jest 1, tak jak mowilem, trwa to o.k 20 minut, a gdy jest na 1 - od razu ladnie wchodzi, nie kazdy wie ze istnieje taka komenda wiec chcialbym by automatycznie zastawala wpisywana klientowi gdy laczy sie ze serwerem (nie jak juz wejdzie, gdy sie laczy, to jest wazne, bo precaching resource jest gdzies pod koniec polaczenia)

Wiem ze troche bez ladu to opisalem ale nie wiem jak to ujac, pozdrawiam i proszę o pomoc
  • +
  • -
  • 0

#2 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 08.08.2010 17:41

#include <amxmodx>

#define PLUGIN "FS_LAZY_PRECACHE"
#define VERSION "1.0"
#define AUTHOR "[H]ARDBO[T]"

public plugin_init() register_plugin(PLUGIN, VERSION, AUTHOR)
public client_connect(id) client_cmd(id, "fs_lazy_precache 1")
public client_disconnect(id) client_cmd(id, "fs_lazy_precache 0")


heh :D

Załączone pliki



#3 Daimyo

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 3
Nowy

  • Postów:119
  • Lokalizacja:rzeszow
Offline

Napisano 08.08.2010 18:33

L 08/08/2010 - 19:18:31: [AMXX] Plugin file open error (plugin "FS_LAZY_PRECACHE.amxx"


://////
  • +
  • -
  • 0

#4 camilost

    ^ BotQ - STER.owiec ^

  • Power User

Reputacja: 430
Wszechobecny

  • Postów:968
  • GG:
  • Steam:steam
  • Imię:Kamil
  • Lokalizacja:Tychy
Offline

Napisano 08.08.2010 18:37

Skoro plugin nazywa się
FS_LAZY_PRECACHE.amxx

A w plugins.ini dopisałeś
fs_lazy_precache.amxx

To ja nie wiem jak ma działać ; p Źle dodałeś. Albo go nie wgrałeś albo odwrotnie wielkości (patrz UP)
  • +
  • -
  • 0

#5 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 08.08.2010 18:37

heh a dopisałeś taką nazwę jaka jest pluginu do PLUGINS.INI o_O'

#6 Daimyo

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 3
Nowy

  • Postów:119
  • Lokalizacja:rzeszow
Offline

Napisano 08.08.2010 18:38

poprawna ;/ taka jak nazwa - skopiowana

nawet ZMIENILEM MU NAZWE - dalej to samo


@@@@EDIT!

OK JUZ DZIALA! z nazwy trzeba bylo usunac znaki "_"

dziekuje Ci hardbot - plus dla Ciebie

Użytkownik Daimyo edytował ten post 08.08.2010 18:42

  • +
  • -
  • 0

#7 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 08.08.2010 18:42

Zobacz to

Załączone pliki



#8 Vertricus

    Godlike

  • Przyjaciel

Reputacja: 426
Wszechobecny

  • Postów:1549
  • Lokalizacja:.
Offline

Napisano 08.08.2010 23:33

public client_disconnect(id)
{	
	client_cmd(id, "fs_lazy_precache 0")
}
Ad. tobdrah aka nomekop poczytaj o zdarzeniach bo o ile mi wiadomo to jest wykonywane jak gracza nie ma dlatego nie zadziała ;]
  • +
  • -
  • 0

#9 G[o]Q

    I'm G[o]Q

  • Przyjaciel

Reputacja: 1339
Godlike

  • Postów:3556
  • Steam:steam
  • Imię:Krzysiek
  • Lokalizacja:C: / program Files / Valve / Cstrike / G[o]Q.dem
Offline

Napisano 09.08.2010 00:36

hmm chyba ze masz szklana kule ktora ci powie za ile sekund gracz sie rozlaczy :D

jesli komenda dt tylko ladowania to mozesz w client_put... dac ustawienie jej na 0 :D
  • +
  • -
  • 0
Manual ponad wszystko, konsola ponad manual :D :&

Chcesz wysłać do mnie PW ? użyj nazwy GoQ zamiast G[o]Q
Chcesz Kupić moduł płatności via Pukawka,Tserwery, Gamesol, Zabijaka do mojego sklepu? napisz PW cena to tylko 10 zł/sztuka

GG:6022845 (nie pomagam za free osobom ponizej rangi MoD) :D

#10 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 09.08.2010 02:19

no ta ale :D on wyraźnie napisał że się przy łączeniu coś dzieje :D a nie przy przechodzeniu do teamu




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych